LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-02-2003, 08:34 AM   #1
darthczyz
Member
 
Registered: May 2003
Distribution: Redhat 9
Posts: 49

Rep: Reputation: 15
dvorak question


i'm a dvorak keyboard user, and when i'm working in our lab, those keyboards are all qwerty (boo!). i was wondering if i could write an alias or something to switch the keyboard setting, or how to change that at the command line. i'm running RedHat 9. thanks

-skiz
 
Old 06-02-2003, 08:41 AM   #2
0x0001
Member
 
Registered: Sep 2002
Distribution: Slackware 8.1
Posts: 84

Rep: Reputation: 15
Try loadkeys(1).
When you want to automatically switch to dvorak when loging in, put the loadkey line .bashrc or .tcshrc. But be nice and change it back to default or other users just might be confused
Usually .logout is executed on logout.
 
Old 06-02-2003, 08:53 AM   #3
darthczyz
Member
 
Registered: May 2003
Distribution: Redhat 9
Posts: 49

Original Poster
Rep: Reputation: 15
no why would i ever want to confuse a qwerty user? thanks for your help
 
Old 12-08-2003, 02:30 AM   #4
Inuyasha-kun
LQ Newbie
 
Registered: Nov 2003
Distribution: Red Hat Linux 8
Posts: 20

Rep: Reputation: 0
Quote:
Originally posted by 0x0001
Try loadkeys(1).
When you want to automatically switch to dvorak when loging in, put the loadkey line .bashrc or .tcshrc. But be nice and change it back to default or other users just might be confused
Usually .logout is executed on logout.
Where would I modify a file if I want to have the boot and startup in Dvorak?
 
Old 12-08-2003, 02:52 AM   #5
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
In RedHat 8:
/etc/sysconfig/keyboard

(It's a textfile)

Regards
Martin
 
Old 12-08-2003, 05:58 PM   #6
Inuyasha-kun
LQ Newbie
 
Registered: Nov 2003
Distribution: Red Hat Linux 8
Posts: 20

Rep: Reputation: 0
Thanks. For my distro, what would I enter in the quotes?
 
Old 12-09-2003, 04:13 AM   #7
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
OK. The keyboard file looks like this on my computer (with a Swedish keyboard):
Code:
KEYBOARDTYPE="pc"
KEYTABLE="se-latin1"
The first line should probably stay as it is. I don't even know what the alternatives are... For the second line, there are a couple of alternatives. Too see them type:
Code:
~> ls -l /lib/kbd/keymaps/i386/dvorak/
total 16
-rw-r--r--    1 root     root          160 Sep  5  2002 ANSI-dvorak.map.gz
-rw-r--r--    1 root     root         1218 Sep  5  2002 dvorak-l.map.gz
-rw-r--r--    1 root     root          778 Sep  5  2002 dvorak.map.gz
-rw-r--r--    1 root     root         1215 Sep  5  2002 dvorak-r.map.gz
This may differ on your machine. I tried setting my KEYTABLE variable to "dvorak" (you should skip the .map.gz extention) and rebooted. Then I had a challenging time getting it back to where it was before. Especially my root password was a little tricky to type

Good luck!
Martin
 
Old 12-09-2003, 05:38 PM   #8
Inuyasha-kun
LQ Newbie
 
Registered: Nov 2003
Distribution: Red Hat Linux 8
Posts: 20

Rep: Reputation: 0
The "dvorak" in the second line didn't work, [ FAILED ]. The keymap thing never works, even though I installed it. Any other ideas for Red Hat 8?
 
Old 12-09-2003, 05:45 PM   #9
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
Are the keymaps installed? What do you get when you do the 'ls' command as I did above?

Martin
 
Old 12-09-2003, 05:54 PM   #10
Inuyasha-kun
LQ Newbie
 
Registered: Nov 2003
Distribution: Red Hat Linux 8
Posts: 20

Rep: Reputation: 0
Yes. they are installed, and ls does work. The bootup thing doesn't work.
 
Old 12-09-2003, 06:15 PM   #11
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
Sorry. If the keymap file 'dvorak.map.gz' is installed on your system under '/lib/kbd/keymaps/i386/dvorak/' then I'm out of ideas.

As a last resort, try (from the Start menu in X) System Settings > Keyboard. Can you change your keyboard to dvorak there? It should take effect immediately.

Regards
Martin
 
Old 12-09-2003, 06:20 PM   #12
Inuyasha-kun
LQ Newbie
 
Registered: Nov 2003
Distribution: Red Hat Linux 8
Posts: 20

Rep: Reputation: 0
That's what I already did. I want it to take effect before login...
 
Old 12-09-2003, 06:25 PM   #13
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
If you change the keyboard settings there, it should stay so even after a reboot. Actually, that program changes the '/etc/sysconfig/keyboard' file.

Regards
Martin
 
Old 12-09-2003, 06:40 PM   #14
Inuyasha-kun
LQ Newbie
 
Registered: Nov 2003
Distribution: Red Hat Linux 8
Posts: 20

Rep: Reputation: 0
Not for my distro... It only changes one user's settings.

Last edited by Inuyasha-kun; 12-12-2003 at 09:05 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dvorak apepost General 27 11-16-2006 09:19 PM
how do I setup a lefthanded dvorak keyboard wingo Linux - Newbie 5 11-13-2006 02:46 AM
dvorak made easy (slackware) phos LinuxQuestions.org Member Success Stories 1 12-05-2004 01:33 PM
qwerty to Dvorak blitzen Linux - Hardware 5 03-23-2004 12:37 PM
dvorak keymap seingoku Slackware 1 05-22-2003 10:14 PM


All times are GMT -5. The time now is 12:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration