LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-02-2004, 07:49 AM   #1
flexiRobot
LQ Newbie
 
Registered: May 2004
Location: Melbourne
Distribution: Knoppix/Debian
Posts: 6

Rep: Reputation: 0
Question DVD rom problem with Debian


Hi everyone. i'm a total newbie to linux. just managed to install knoppix to my hd.

After i installed knoppix and run it from my hd, i cannot access my dvd rom which i used it before to install knoppix.

when booting up i can see linux detects my dvd rom as hdb

and i typed "dmesg |grep -i dvd " , i got something like below:

hdb: Compaq DVD-ROM DRN-8080B, ATAPI CD/DVD-ROM drive
Vendor: COMPAQ Model: DVD-ROM DRN8080B Rev: 1.14

i guess the system recognises my dvd rom. but i just cannot access it from either:

device:/ DVD (in Konqueror)

when i clicked on the DVD icon, i was told

"mount: special device /dev/dvd does not exist
please check that the disk is entered correctly"

i tried to access the dvd rom from /mnt or /dev but in vain.


Can anyone help me ?

ThanX !
 
Old 06-02-2004, 07:54 AM   #2
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Did you mount the disk?
mount /dev/dvd /mnt/dvd
 
Old 06-02-2004, 08:00 AM   #3
flexiRobot
LQ Newbie
 
Registered: May 2004
Location: Melbourne
Distribution: Knoppix/Debian
Posts: 6

Original Poster
Rep: Reputation: 0
I tried that but i was told "mount: special device /dev/dvd does not exist".

i have completely no idea :S
 
Old 06-02-2004, 08:27 AM   #4
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Try
mount /dev/hdb /mnt/dvd
 
Old 06-02-2004, 09:01 AM   #5
flexiRobot
LQ Newbie
 
Registered: May 2004
Location: Melbourne
Distribution: Knoppix/Debian
Posts: 6

Original Poster
Rep: Reputation: 0
i got "error while guessing filesystem type"

i was actually trying to read a CD from my DVD rom.

i then tried mount -t iso9660 /dev/hdb /mnt/dvd and got
"wrong fd type, bad option, bad superblock on /dev/hdb, or too many mounted file systems"
 
Old 06-02-2004, 10:49 AM   #6
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 32
What displays
mount

or

cat /etc/mtab

It maybe that your dvd is already mounted.

If not it also can be that the FS type is not iso9660.
It can be e.g. also UDF.

Try
mount /dev/hdb -t auto /mnt/dvd
 
Old 06-02-2004, 10:53 AM   #7
flexiRobot
LQ Newbie
 
Registered: May 2004
Location: Melbourne
Distribution: Knoppix/Debian
Posts: 6

Original Poster
Rep: Reputation: 0
thanks for all the replies

i got it working by " mount -t udf /dev/scd0 /mnt"

but i still dont understand why it is so.
 
Old 06-02-2004, 11:03 AM   #8
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 32
CD/DVD can be formated with different Filesystems, although in most cases it's either UDF of ISO9600

if you mount using the auto option, mount can recognize what FS is on the CD or DVD and mount it the right way.
You can not mount an UDF formated disk with iso9660 option and vice versa. UDF and ISO9660 are different filesystems.

Take a look on your /etc/fstab

find there the entry for your cd/dvd and take a look on the column specifying the filesystem.
Change it to auto.
Here, how it looks in my fstab.
/dev/dvd /mnt/dvd auto ro,noauto,exec,user 0 0
(I think in your case you shall replace /dev/dvd with /dev/scd0)
After that you can mount your dvd simply with
mount /mnt/dvd

/dev/scd0 indicates that you have SCSI emulation on for your drive. This
was necessary in 2.4.x kernel in order to write CD+R/RWs.

Last edited by Vlad-A; 06-02-2004 at 11:07 AM.
 
Old 06-02-2004, 11:06 AM   #9
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Your using scsi emulation so you need to point it to /dev/scd0 not /dev/hdb
 
Old 06-02-2004, 11:33 AM   #10
flexiRobot
LQ Newbie
 
Registered: May 2004
Location: Melbourne
Distribution: Knoppix/Debian
Posts: 6

Original Poster
Rep: Reputation: 0
one more question, do i have to mount the DVD rom drive everytime when i restart the computer or is that the way linux works ?
 
Old 06-02-2004, 11:41 AM   #11
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Removing noauto from /etc/fstab will allow linux to automatically mount the device when your computer starts
 
Old 06-02-2004, 02:03 PM   #12
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 32
Actually there are two ways you can handle mounting:

1) You install the supermounter (submount) and you do not have to take care about mounting
removable media (floppy, CD/DVD, Memory Cards, etc) at all. This is done automatically
by submount.
http://submount.sourceforge.net/

2) The "traditional" way, where you need to mount the DVD *every time* you insert
a DVD/CD in your drive *and* unmount when you would like to eject them.
One exception are Audio-CDs which you can not mount.

Which option you will use depends on your preferences.

Although I think that submount is a nice thing, I prefer the
traditional way, since I have always done it that way :-)))

The noauto option tells Linux not to mount a Filesystem (in this case the DVD)
at boot. The reason why I use this option is because I have configurde my DVD as alternative boot device.
So when booting my Linux from hard drive there isn't any media (CD/DVD)
in the drive, therefore an attempt to mount the DVD during boot will result in an error.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10.0 dvd rom problem bf2master Linux - Newbie 2 11-10-2005 01:20 PM
Dvd-Rom Problem... Thinks it is software problem smcmlln Linux - Software 1 09-05-2005 09:13 AM
Debian sarge DVD-rom incredibly slow kikiloizo Linux - Hardware 0 12-04-2004 12:48 PM
RedHat 9 CD/DVD ROM problem biggles Linux - Hardware 12 09-27-2004 11:42 PM
Debian DVD ROM strange flexiRobot Linux - Hardware 0 05-29-2004 09:46 AM


All times are GMT -5. The time now is 02:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration