LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-21-2010, 05:30 AM   #1
chymeira
Member
 
Registered: Dec 2008
Location: CH/IL
Distribution: Slackware 13.1 Fedora 12
Posts: 73

Rep: Reputation: 16
Duel booting


Hello all,

I have a dekstop computer with 500Gs of hard drive fully dedicated to slackware 13.1 , but since last week I decided to install ( duel boot ) windows 7 so my lil brother can play games. using gparted i shrank my partition for 30Gs to give to windows and I installed windows. Here is my problem :
Now that I have 2 Os's installed but I cant choose which 1 to boot from. Windows automatically boots up and I dont know how to get into my slackware.
Plz help .

Thank you
 
Old 09-21-2010, 05:32 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Just use any Live distribution to install grub on it.

Edit:
Sorry did not read the post correctly. My bad. You have Slack. It runs LILO. Either you can do what repo said, or else if you are not familiar with Lilo then can install grub. You may find Grub easier to manage.

Last edited by linuxlover.chaitanya; 09-21-2010 at 06:05 AM.
 
Old 09-21-2010, 05:37 AM   #3
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Open this file in vi editor

Code:
vim /boot/grub/grub.conf
Chnage default=0 or 1

default=0

0=first label in file

1= second label in file

Sample file :In this file default=1;so sytem boots in Windows XP

Quote:
title Red Hat Linux (2.4.20-8)
root (hd0,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL hdd=ide-scsi
initrd /initrd-2.4.20-8.img
title Windows XP
rootnoverify (hd0,0)
chainloader +1
 
Old 09-21-2010, 05:40 AM   #4
chymeira
Member
 
Registered: Dec 2008
Location: CH/IL
Distribution: Slackware 13.1 Fedora 12
Posts: 73

Original Poster
Rep: Reputation: 16
can you guys guide me how to do it on lilo ? since slack still uses lilo ?

Last edited by chymeira; 09-21-2010 at 05:46 AM.
 
Old 09-21-2010, 05:50 AM   #5
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi chymeira, i think you have LILO if it has LILO thn you have to do this:

so you need to edit
/etc/lilo.conf

in taht make default=slackware (label of os)
 
Old 09-21-2010, 05:53 AM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Windows does overwrite the MBR.
Boot from a live cd
Edit /etc/lilo.conf
rerun lilo
reboot


Kind regards
 
Old 09-21-2010, 06:12 AM   #7
chymeira
Member
 
Registered: Dec 2008
Location: CH/IL
Distribution: Slackware 13.1 Fedora 12
Posts: 73

Original Poster
Rep: Reputation: 16
Im still having problems ... this is what my lilo.conf looks like :

append= "vt.default_utf8=0"
boot = /dev/sda

default = slackware

....
....

timeout = 200

...
...
image = /boot/vmlinuz
root = /dev/sda3
label = linux
read-only


is lilo -v the command for rerunning lilo ?
because the live ubuntu doesnt have that command

thank you

Last edited by chymeira; 09-21-2010 at 06:17 AM.
 
Old 09-21-2010, 06:17 AM   #8
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

Please give us the whole file and change the default option to slackware...It will work

Note:It should be slackware label (i dont know what's the label in you file)

Last edited by prayag_pjs; 09-21-2010 at 06:19 AM.
 
Old 09-21-2010, 06:18 AM   #9
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Did you run lilo command? It could either be /sbin/lilo.
 
Old 09-21-2010, 06:23 AM   #10
basheer
Member
 
Registered: Mar 2009
Location: Bangalore, India
Distribution: CentOS6.5, CentOS7, Ubuntu14.04
Posts: 182

Rep: Reputation: 29
Smile

Insert your slackware cd.
Sfter it comes to root prompt.
use liloconfig.

#liloconfig
There wiil be a menu,
select Simple
The next part of the LILO configuration is selecting where you want it installed.
Choose MBR here.

I hope this helps.
 
Old 09-21-2010, 06:39 AM   #11
chymeira
Member
 
Registered: Dec 2008
Location: CH/IL
Distribution: Slackware 13.1 Fedora 12
Posts: 73

Original Poster
Rep: Reputation: 16
this is my lilo.conf

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/sda

default = slackware

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used. We don't specify it here, as there's just one column.
bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda1
label = Linux
read-only
# Linux bootable partition config ends

I tried using liloconfig... I didnt have such a utility on my slackware 13.1 disk.

Im using live ubuntu ... and when I want to rerun lilo it says that It cannot locate lilo file ... my hard drive is mounted on /media/88-2212 ...

thank you again
 
Old 09-21-2010, 06:47 AM   #12
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

default= slackware was used only for example (reference)

make/change
Code:
default = Linux
(Your lable is Linux not Slackware)

After thsi reboot the system.It will boot in Slackware by default

Last edited by prayag_pjs; 09-21-2010 at 06:49 AM.
 
Old 09-21-2010, 06:50 AM   #13
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
Originally Posted by prayag_pjs View Post
Hi,

default= slackware was used only for example (reference)

make default = Linux

(Your lable is Linux not Slackware)
Don't forget to rerun lilo, after you made the changes.

Then boot into slackware, add windows to your lilo.conf, and rerun lilo


Kind regards
 
Old 09-21-2010, 05:10 PM   #14
chymeira
Member
 
Registered: Dec 2008
Location: CH/IL
Distribution: Slackware 13.1 Fedora 12
Posts: 73

Original Poster
Rep: Reputation: 16
Thank you every1 for all your replies.

I worked on the problem and this is how I fixed it.

I boot up with my Slackware cd , mounted my /dev/sda3 ( my slack partition ) and edited my lilo.conf the way you guys told me. After that I reran lilo and then I ran fdisk /dev/sda and toggle boot on /dev/sda3.

And now both work.

Thank you again . God it feels good to be back on slack ... windows makes me .... u know

Last edited by chymeira; 09-21-2010 at 05:56 PM.
 
Old 09-22-2010, 01:47 AM   #15
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Great you got it working and thanks for posting the solution.

Quote:
Thank you again . God it feels good to be back on slack ... windows makes me .... u know
I understand.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
duel booting os Seleucid Linux - Newbie 9 03-29-2010 10:13 AM
Duel Booting Windows XP harley51 Fedora 5 06-28-2009 03:57 PM
Duel Booting tommytomato Linux - General 16 05-31-2007 10:04 AM
Duel booting with Linspire mat_uk111 Linspire/Freespire 1 12-08-2005 03:36 PM
Duel Booting Jedi_Cheese Linux - Newbie 4 01-15-2002 12:56 AM


All times are GMT -5. The time now is 02:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration