LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Dualboot Win2K+Slackware (http://www.linuxquestions.org/questions/linux-newbie-8/dualboot-win2k-slackware-238571/)

akilles 10-04-2004 07:21 AM

Dualboot Win2K+Slackware
 
Hi.
This is a very newbie question, and I have searched for answers, but couldn't find what I was looking for. Hope someone here can find time to reply.
I decided to try Linux as well as Win2K at work. I have Win2K installed on a 8GB partition of 40 GB total. I left 16GB unformated for Linux, and the rest I formated with Fat32 for sharing files between systems.
After installing linux i had the following setup of the disk:
/dev/hda1 8GB NTFS
/dev/hda2 1GB (linux swap)
/dev/hda3 15GB Linux system
/dev/hda4 16GB Fat32 (Files shared.)

I installed LILO to MBR, and added the option to boot WinNT. This worked OK on friday, until almost 4:00 PM, when it started behaving odd. I had X-Windows running with FluxBox.
This morning, it wouldn't boot Linux at all. Something about the root filesystem couldn't be read-only. Now I have removed Linux again, but lilo works with booting WinNT. (I am posting from this now.)
I read something later about a boot partition having to be within the first 7.5GB for Linux to access it. My question is:
Would it be better if I set up the disk like this:
/dev/hda1 500MB /boot
/dev/hda2 8GB NTFS
/dev/hda3 1GB /swap
/dev/hda4 15GB /
/dev/hda5 15,5GB Fat32 (For sharing)

Also, how do I make the the boot-partition? Make the partition Linux Native, then mount it to /boot.... I've never tried this before, so I am completely blank.

Best regards
Geir O.

TazG 10-04-2004 07:33 AM

My Linux partition is farther than 7.5 GB from the beginning and it works fine. I have never heard of that.

Anyways I think both ways of setting up the disk should work, if it doesn't post your lilo.conf file.

akilles 10-04-2004 07:45 AM

Hmmm.
Could it be that I use NTFS?
I removed the Linux system, so I don't have the lilo.conf file any more.

The only thing I did was I added:

other=/dev/hda1
label=Win2K

Will install Linux again now.

-Geir O.

akilles 10-04-2004 08:51 AM

This post is made from Linux, with fluxbox as windowmanager.
I haven't tried booting Win2K yet, but about to do so now.

Geir O.


All times are GMT -5. The time now is 07:44 PM.