LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-14-2003, 11:40 AM   #1
clokwurk
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Rep: Reputation: 0
Question dualboot - lost win MBR


i'm setting up a dual boot with gentoo/Winxp.

xp on hda / gentoo on hdb

as I was setting up Gentoo partition for boot I accidentally used hda1 instead of hdb1...writing over the MBR for the wrong disk.


I'm all but done with the install...just configuring LILO - havn't rebooted yet.


Ideas? Suggestions?


thanks in advance - clok

Last edited by clokwurk; 09-14-2003 at 11:42 AM.
 
Old 09-14-2003, 11:55 AM   #2
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
You can try to fix it by booting with the winxp cdrom, get in the recovery console and do a fixboot and/or fixmbr
Or if by chance it's a fat32 partition I know a faster and more reliable way of restoring nt bootsector.
 
Old 09-14-2003, 11:58 AM   #3
clokwurk
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Original Poster
Rep: Reputation: 0
but is that going to screw up LILO operation?

do i need to redo that part of the config?
 
Old 09-14-2003, 12:12 PM   #4
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Make sure you created the linux bootdisk, after you do a fixboot/fixmbr use the bootdisk to boot into linux then reinstall lilo back into mbr
Or alternatively you can use nt boot loader to load linux, once your're in first install lilo to /dev/hdb1, then do a:
dd if=/dev/hdb1 of=gentoo.bin bs=512 count=1
copy gentoo.bin into a floppy disk(FAT formatted), reboot and get back into xp, copy gentoo.bin into c:\ (or where boot.ini,ntldr,ntdetect.com is, by default there's hidden, go in view options then enable show hidden system files if necessary)
then add
c:\gentoo.bin="Gentoo"
into your boot.ini

cheers
 
Old 09-14-2003, 03:58 PM   #5
clokwurk
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Original Poster
Rep: Reputation: 0
thank you for the info and speedy reply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.2 s-ata issues w/ Win XP dualboot Pipapeter Suse/Novell 10 06-14-2005 08:19 AM
dualboot with mup.sys hangs on win xp afrodocter General 9 08-14-2004 06:02 PM
Fix corrupted MBR on dualboot Machine Jingle Linux - Software 12 07-10-2004 03:13 PM
sarge with slack dualboot, lilo mbr preserved? flipper333 Debian 4 04-05-2004 02:49 PM
Win XP + mbr + grub = >:O jclark00001 Linux - Newbie 1 02-15-2003 08:36 AM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration