LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-01-2004, 05:33 PM   #1
bcf2
Member
 
Registered: Nov 2003
Location: Nowhere and somewhere
Distribution: Mandrake 10
Posts: 124

Rep: Reputation: 15
dual monitors in mandrake 10


I have read the tutorials that the other posts on this subject have posted, but I find that they don't make sense. How the heck do I enable Xinerama? What is the proper XF86Config Config?
 
Old 11-01-2004, 05:46 PM   #2
SirSlappy
Member
 
Registered: Jun 2003
Location: Glendale AZ
Distribution: Slackware 10
Posts: 153

Rep: Reputation: 30
hrm..

You obviously haven't read the other posts because most of them make plenty of sense. You should also learn to use keywords in your search.

Search for "dual monitors" and "xinerama"

You will easily find the proper lines to add, where to add them, and how to configure dual monitors for X.

JS
 
Old 11-01-2004, 06:44 PM   #3
bcf2
Member
 
Registered: Nov 2003
Location: Nowhere and somewhere
Distribution: Mandrake 10
Posts: 124

Original Poster
Rep: Reputation: 15
now I got xinerama running (using the built-in graphical way), but both screens are just black, could someone please tell me what I did wrong?
 
Old 11-01-2004, 07:44 PM   #4
SirSlappy
Member
 
Registered: Jun 2003
Location: Glendale AZ
Distribution: Slackware 10
Posts: 153

Rep: Reputation: 30
dude.

Dude.. you gotta learn how to help yourself before we can help you.

Post your xorg.conf file here so we can read it.

oh, and post your /etc/shadow file too
 
Old 11-02-2004, 04:30 AM   #5
wannabe
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
doesnt the shadow file hold passwrds on linux ?
 
Old 11-02-2004, 12:50 PM   #6
SirSlappy
Member
 
Registered: Jun 2003
Location: Glendale AZ
Distribution: Slackware 10
Posts: 153

Rep: Reputation: 30
lol

yes.. It does. that was a joke.

But the other file, paste it.
 
Old 11-02-2004, 05:15 PM   #7
bcf2
Member
 
Registered: Nov 2003
Location: Nowhere and somewhere
Distribution: Mandrake 10
Posts: 124

Original Poster
Rep: Reputation: 15
Here it is:

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
#FontPath "unix/:7100"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
#if something goes wrong with above fall back on these:
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "cz_qwerty"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Dell E770s"
HorizSync 30-70
VertRefresh 50-160

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Monitor"
Identifier "monitor2"

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
Driver "mga"
Screen 0
Option "DPMS"
EndSection

Section "Device"
Identifier "device2"
VendorName "Matrox"
BoardName "Matrox Mystique"
Driver "mga"
Screen 0
BusID "PCI:2:10:0"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "Screen"
Identifier "screen2"
Device "device2"
Monitor "monitor2"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
Screen "screen2" RightOf "screen1"
Option "Xinerama"
EndSection



Notice that this configuration just gives me a blank screen on screen 1 and nothing on screen 2...thanks in advance!

Last edited by bcf2; 11-02-2004 at 05:18 PM.
 
Old 11-02-2004, 05:47 PM   #8
SirSlappy
Member
 
Registered: Jun 2003
Location: Glendale AZ
Distribution: Slackware 10
Posts: 153

Rep: Reputation: 30
okay, are you sure you're using this config file for X?

You need to make that file xorg.conf and put it in /etc/X11/ directory.

Make sure you back up the current one.

The only thing I see in the conf file you posted that is strange is that there's a 15 bit depth, which I've never heard of.


This is an old one I used when I had two monitors... You will have to edit the video card stuff though. Also, the new X uses xorg.conf , not XF86Config. Anywho, make sure you're USING this file. I know there's a way to use a specified xorg.conf with the X command. Read up on that. I'm sure there's plenty on this site to teach you. Please post what else you get working. We'll help you out from there.

#######################################
##SirSlappy's Two Monitor XF86Config file.###
#######################################

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "xinerama" "on"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "record"
Load "extmod"
Load "dbe"
Load "dri"
Load "xtrap"
Load "glx"
Load "type1"
Load "speedo"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Monitor"
#DisplaySize 370 270 # mm
Identifier "Monitor1"
VendorName "DEL"
ModelName "DELL P991"
Option "DPMS"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "DigitalVibrance" # <i>
#Option "NoFlip" # [<bool>]
#Option "Dac8Bit" # [<bool>]
#Option "NoLogo" # [<bool>]
#Option "UBB" # [<bool>]
#Option "Stereo" # <i>
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "VideoKey" # <i>
#Option "NvAGP" # <i>
#Option "IgnoreEDID" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ConnectedMonitor" # <str>
#Option "ConnectedMonitors" # <str>
#Option "TVStandard" # <str>
#Option "TVOutFormat" # <str>
#Option "RenderAccel" # [<bool>]
#Option "CursorShadow" # [<bool>]
#Option "CursorShadowAlpha" # <i>
#Option "CursorShadowXOffset" # <i>
#Option "CursorShadowYOffset" # <i>
#Option "UseEdidFreqs" # [<bool>]
#Option "FlatPanelProperties" # <str>
#Option "TwinView" # [<bool>]
#Option "TwinViewOrientation" # <str>
#Option "SecondMonitorHorizSync" # <str>
#Option "SecondMonitorVertRefresh" # <str>
#Option "MetaModes" # <str>
#Option "UseInt10Module" # [<bool>]
#Option "NoTwinViewXineramaInfo" # [<bool>]
#Option "NoRenderExtension" # [<bool>]
#Option "Overlay" # [<bool>]
#Option "CIOverlay" # [<bool>]
#Option "ForceEmulatedOverlay" # [<bool>]
#Option "TransparentIndex" # <i>
#Option "OverlayDefaultVisual" # [<bool>]
#Option "NvEmulate" # <i>
#Option "NoBandWidthTest" # [<bool>]
#Option "CustomEDID-CRT-0" # <str>
#Option "CustomEDID-CRT-1" # <str>
#Option "CustomEDID-DFP-0" # <str>
#Option "CustomEDID-DFP-1" # <str>
#Option "CustomEDID-TV-0" # <str>
#Option "CustomEDID-TV-1" # <str>
#Option "TVOverScan" # <f>
#Option "IgnoreDisplayDevices" # <str>
#Option "MultisampleCompatibility" # [<bool>]
#Option "RegistryDwords" # <str>
#Option "NoPowerConnectorCheck" # [<bool>]
#Option "AllowDFPStereo" # [<bool>]
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV20 [GeForce3 Ti 200]"
BusID "PCI:1:0:0"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "Dac6Bit" # [<bool>]
#Option "Dac8Bit" # [<bool>]
#Option "ForcePCIMode" # [<bool>]
#Option "CPPIOMode" # [<bool>]
#Option "CPusecTimeout" # <i>
#Option "AGPMode" # <i>
#Option "AGPFastWrite" # [<bool>]
#Option "AGPSize" # <i>
#Option "RingSize" # <i>
#Option "BufferSize" # <i>
#Option "EnableDepthMoves" # [<bool>]
#Option "EnablePageFlip" # [<bool>]
#Option "NoBackBuffer" # [<bool>]
#Option "PanelOff" # [<bool>]
#Option "DDCMode" # [<bool>]
#Option "CloneDisplay" # <i>
#Option "CloneMode" # [<str>]
#Option "CloneHSync" # [<str>]
#Option "CloneVRefresh" # [<str>]
#Option "UseFBDev" # [<bool>]
#Option "VideoKey" # <i>
Identifier "Card1"
Driver "ati"
VendorName "ATI Technologies Inc"
BoardName "Radeon RV100 QY [Radeon 7000/VE]"
BusID "PCI:0:6:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 1
EndSubSection
SubSection "Display"
Depth 4
EndSubSection
SubSection "Display"
Depth 8
EndSubSection
SubSection "Display"
Depth 15
EndSubSection
SubSection "Display"
Depth 16
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Card1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Depth 1
EndSubSection
SubSection "Display"
Depth 4
EndSubSection
SubSection "Display"
Depth 8
EndSubSection
SubSection "Display"
Depth 15
EndSubSection
SubSection "Display"
Depth 16
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
###############EOF################
 
Old 11-03-2004, 06:32 PM   #9
bcf2
Member
 
Registered: Nov 2003
Location: Nowhere and somewhere
Distribution: Mandrake 10
Posts: 124

Original Poster
Rep: Reputation: 15
I'me exetremely close, I can get a prompt on one monitor, and when I start X, it swiches over to the other monitor and displayes X, my X file is as follows:
Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
#FontPath "unix/:7100"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
#if something goes wrong with above fall back on these:
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "cz_qwerty"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Dell E770s"
HorizSync 30-70
VertRefresh 50-160

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Monitor"
Identifier "monitor2"

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
Driver "mga"
Screen 0
Option "DPMS"
EndSection

Section "Device"
Identifier "device2"
VendorName "Matrox"
BoardName "Matrox Mystique"
Driver "mga"
Screen 0
BusID "PCI:2:10:0"
Option "DPMS"
EndSection

Section "Device"
Identifier "NVIDIA GENERIC"
VendorName "NVIDIA"
BoardName "Nvidia Geforce"
Driver "NVIDIA geforce"
Screen 2
BusID "PCI:0:0:1"
Option "DPMS"

EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "Screen"
Identifier "screen2"
Device "device2"
Monitor "monitor2"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 1024 768

EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
Screen "screen2" RightOf "screen1"
Option "Xinerama"
EndSection
 
Old 11-03-2004, 09:05 PM   #10
wannabe
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
not much help but...

well i started a mission to rid myself of M$ about 3 weeks ago, and ive been jumpin distros since, started with red hat 9 , then mandrake 10.1 and now fedora core 2

and i must admit i only managed to get dual monitors working on red hat and fc 2, apart from that i h8 how mandrakes forums cost money,

well i maybe a newb but im starting to get the feel for quality as far as distros go.

i believe i will check/try out all the major distros out there, but for now fc 2 is winning
 
Old 11-04-2004, 02:54 PM   #11
bcf2
Member
 
Registered: Nov 2003
Location: Nowhere and somewhere
Distribution: Mandrake 10
Posts: 124

Original Poster
Rep: Reputation: 15
<flamebait>mandrake is great!!!</flamebait>, now, that didn't help at all, so I will also accuse you of freeposting

ps please excuse the bump

pps Please excuse how annoying this post is
 
Old 11-04-2004, 11:20 PM   #12
SirSlappy
Member
 
Registered: Jun 2003
Location: Glendale AZ
Distribution: Slackware 10
Posts: 153

Rep: Reputation: 30
Well for n00bs, of course you think FC2 is great. It's easy. It sets up everything for you INITIALLY. However, Slackware is my choice and I'd say I am more than proficient with linux.

It's harder to install and get going, but it's MUCH lighter, faster, and customizale than the other distros IMHO.
 
Old 11-05-2004, 02:42 AM   #13
wannabe
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
well i must admit i envy (in a good way) any1 who has half a brain and has been using linux for at least 1year.

and im glad i finally made the transition and it appears i couldnt have picked a better time - 3 desktops posts are popping up all over the place (theres 1 in rage3d).

apparently M$ is planning this for 2007

LINUX is the best thing thats happened to me, computer wise since i got my commodore 64.

and at this point id like to thank the more experienced users out there that help newbs and big thumbs up for those of u involved in open projects (1 day hope to be able to contribute as well)

bit of topic but we kind of got onto subject

 
Old 11-05-2004, 06:30 PM   #14
bcf2
Member
 
Registered: Nov 2003
Location: Nowhere and somewhere
Distribution: Mandrake 10
Posts: 124

Original Poster
Rep: Reputation: 15
THIS IS OFF TOPIC, PLZ ANSWER THE QUESTION!!!!!!!!!!
 
Old 11-06-2004, 12:56 AM   #15
wannabe
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
im not sure what u want to do but to me it looks like u dont have ure server layout configured, there a website dedicated to this somewhere, but perhaps u can get some1 to telnet into ure system

and u might have too many display configurations

me newb so i hope i have helped ...somewhat
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up Dual Monitors on GeForce 6600GT dual DVI card. monkiidansu Linux - Hardware 1 09-29-2005 02:21 PM
Dual Monitors in Mandrake 10.1+ vcore Linux - Hardware 7 05-25-2005 04:55 PM
Dual Monitors Radeon 9600Pro Mandrake 10.0 radio birdman Linux - Hardware 4 12-03-2004 02:12 AM
Mandrake 10.1 - Dual Monitors. How? Micro420 Mandriva 1 10-31-2004 01:00 PM
Dual Monitors on Mandrake 10 Phoenix11 Mandriva 11 06-10-2004 05:08 PM


All times are GMT -5. The time now is 12:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration