LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Closed Thread
  Search this Thread
Old 02-01-2006, 11:31 AM   #1
quantumnicity
LQ Newbie
 
Registered: Feb 2006
Location: Germany
Distribution: Suse 10.0
Posts: 10

Rep: Reputation: 0
Dual display problems with Linux 10.0 and Nvidia GeForce 6800


Hi folks,

i'm a semi-newbie here on the forum, and i've just succesfully installed Suse 10.0 on my Dell Dimension alongside Windows XP Professional with a Nvidia GeForce 6800 graphic card with dual display capabilities (one digital, the other analog). I had tried this with an earlier version (i believe it was 9.2), but no dice- it didn't come to grips with the SATA hard drive and didn't even recognize it.

anyway, my problem is trying to get the twinview functionality to work properly, but it doesn't seem to work. i found some other postings related to this subject for similar graphic cards and edited the XF86.conf file accordingly, but alas- no luck. here's what it looks like:

# /.../
# SaX generated X11 config file
# Created on: 2006-02-01T04:47:51-0600.
#
#
#
# Automatically generated by [ISaX] (4.8)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
Option "RandR" "on"
EndSection

Section "Module"
Load "glx"
Load "type1"
Load "extmod"
Load "dbe"
Load "freetype"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Logitech Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 360 270
HorizSync 30-96
Identifier "Monitor[0]"
ModelName "Dell M 990"
Option "DPMS"
VendorName "Dell"
VertRefresh 50-160
UseModes "Modes[0]"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
DisplaySize 320 240
HorizSync 30-83
Identifier "Monitor[1]"
ModelName "Dell M 991"
VendorName "Dell"
VertRefresh 56-75
UseModes "Modes[1]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 165.29 1280 1376 1512 1744 1024 1025 1028 1077
Modeline "1024x768" 73.89 1024 1080 1192 1360 768 769 772 799
Modeline "1024x768" 86.18 1024 1088 1200 1376 768 769 772 803
Modeline "1024x768" 97.84 1024 1088 1200 1376 768 769 772 808
Modeline "1024x768" 110.91 1024 1096 1208 1392 768 769 772 813
Modeline "1024x768" 122.97 1024 1096 1208 1392 768 769 772 818
Modeline "1024x768" 131.43 1024 1096 1208 1392 768 769 772 821
Modeline "800x600" 44.13 800 840 920 1040 600 601 604 624
Modeline "800x600" 51.73 800 840 928 1056 600 601 604 628
Modeline "800x600" 58.73 800 840 928 1056 600 601 604 632
Modeline "800x600" 66.71 800 848 936 1072 600 601 604 635
Modeline "800x600" 73.98 800 848 936 1072 600 601 604 639
Modeline "800x600" 82.55 800 856 944 1088 600 601 604 643
Modeline "800x600" 90.10 800 856 944 1088 600 601 604 647
Modeline "800x600" 97.59 800 856 944 1088 600 601 604 650
Modeline "640x480" 27.74 640 664 728 816 480 481 484 500
Modeline "640x480" 32.64 640 672 736 832 480 481 484 503
Modeline "640x480" 36.97 640 672 736 832 480 481 484 505
Modeline "640x480" 42.22 640 680 744 848 480 481 484 508
Modeline "640x480" 46.80 640 680 744 848 480 481 484 511
Modeline "640x480" 51.43 640 680 744 848 480 481 484 514
Modeline "640x480" 57.18 640 680 752 864 480 481 484 517
Modeline "640x480" 62.12 640 680 752 864 480 481 484 521
EndSection

Section "Modes"
Identifier "Modes[1]"
Modeline "1280x1024" 114.54 1280 1360 1496 1712 1024 1025 1028 1062
Modeline "640x480" 25.10 640 656 720 800 480 481 484 498
Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 4
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
Device "Device[1]"
Identifier "Screen[1]"
Monitor "Monitor[1]"
EndSection

Section "Device"
BoardName "GeForce 6800"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "NVidia"
EndSection

Section "Device"
BoardName "GeForce 6800"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[1]"
Option "FlatPanel"
Screen 1
Option "Rotate" "off"
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "on"
Screen "Screen[0]"
Screen "Screen[1]" RightOf "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection


however, before i changed the file to include a second monitor, only a single monitor was showing up in Yast- but after i had changed the XF86.conf file, it did acknowledge that a second monitor was available, but when i tried to change the settings in Yast and test them (i.e. twinview,xinerama on, e.t.c.) it gave me an error message and instructed me to look at the file /var/log/Xorg.99.log. also, while i can see something on the secong monitor and can tell that it is obviously in the clone mode, it is a horrible resolution, the colors are all mixed up, and it's just completely distorted. the display on the first monitor is fine. i KNOW that it is very close to working, because when i boot Linux there is a perfect symmetrical display on both of the monitors in the clone mode- but as soon as the desktop appears, the second monitor goes blurry and takes on that bad resolution. Both monitors are 19" crt's with analog output.

nevertheless, i'm having lots of fun tinkering around with the system, and would appreciate any tips you guys could give me on getting my dual head display to function in Linux as well as it does in Windows XP!

thanx

Last edited by quantumnicity; 02-01-2006 at 11:33 AM.
 
Old 02-02-2006, 04:57 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

http://www.linuxquestions.org/rules.php

There's another thread going here: http://www.linuxquestions.org/questi...d.php?t=410398
This one is closed.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual display problems with Linux 10.0 and Nvidia GeForce 6800 quantumnicity Linux - Newbie 8 02-03-2006 06:32 PM
Will slackware like nVidia GeForce 6800 GT better then SuSE/FC4? mr_coffee Slackware 2 01-19-2006 01:25 AM
Display problems with Nvidia drivers on Debian (XFree86 4.3.0.1) with GeForce 4MX 440 lordnukem Linux - Hardware 6 02-05-2005 06:32 AM
Dual PCI-X Nvidia 6800 Ultra !! Has anyone tried it ? TheHushedCaskeT Linux - Hardware 6 12-31-2004 06:09 AM
TV out on an nvidia geforce 6800? Braveheart1980 Linux - Hardware 5 09-19-2004 10:25 AM


All times are GMT -5. The time now is 10:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration