LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-31-2006, 12:18 PM   #1
mayaa001
LQ Newbie
 
Registered: Jan 2006
Posts: 3

Rep: Reputation: 0
Dual booting WindowsXP and Fedora Core 3


I have two hard drives onto which i have just reinstalled Windows and Linux. I first installed WindowsXP on the 2nd hard drive. It was divided into 4 partitions, the first of which (the C drive) was where I installed the OS system. Here's what fdisk tells me about it when I print it out:

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 191 1534176 7 HPFS/NTFS
/dev/hdb2 192 9728 76605952+ f W95 Ext'd (LBA)
/dev/hdb5 192 956 6144831 7 HPFS/NTFS
/dev/hdb6 957 9728 70461058+ 7 HPFS/NTFS

Then I installed Fedora Core 3 onto the other hard drive. I divided it into three partitions:

/dev/hda1 * 1 127 1020096 83 Linux
/dev/hda2 128 2282 17310037+ 83 Linux
/dev/hda3 2283 2434 1220940 82 Linux swap

and since i didn't make a /boot partition my grub boot loader is on the first / partition.

Okay, so from pervios experienece I knew i would have to edit my /boot/grub/grub.conf file for both Linux and Windows to boot. So i did what worked last time:

default=1
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core 3 (2.6.9-1.667)
root (hd0,0)
kernel /boot/vmlinuz-2.6.9-1.667 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.9-1.667.img
title Windows XP
rootnoverify (hd1,0)
chainloader +1
makeactive
boot

Except it didn't work. Linux works just fine. But if I try to boot to WindowsXP, it just prints out for me the windows entry I have above and then tells me it can't find NTLDR.

So I read a bunch of other postings and have now also tried things like:

title Windows XP
rootnoverify (hd1,0)
map (hd1) (hd0)
map (hd0) (hd1)
chainloader +1
makeactive
boot

in various permutations but still the same result. What on earth is going wrong? Last time I didn't have WindowsXP installed with multiple partitions but I can't think of anything else i did differently.
Thanks

Last edited by mayaa001; 01-31-2006 at 12:22 PM.
 
Old 01-31-2006, 12:48 PM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
When you installed Fedora, what option did you select for installing the boot loader?

Note that you say you have GRUB in "/"---that won't work. GRUB has to be on a floppy or in the 1st sector of the first drive.

Normally people make the first drive windows, and put linux on the second. It is possible the other way around (using the remapping you have already discovered), but I have never done it.

Here is one of the ultimate resources for multi-boot:
http://www.justlinux.com/forum/showt...hreadid=143973
 
Old 01-31-2006, 12:59 PM   #3
mayaa001
LQ Newbie
 
Registered: Jan 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Dual booting WindowsXP and Fedora Core

When i installed Fedora I told it to put grub on /dev/hda since that was where the rest of Linux was. I'm not sure what other options you might mean.
In my /boot/grub/grub.conf file it says:

# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,0)
# kernel /boot/vmlinuz-version ro root=/dev/hda1
# initrd /boot/initrd-version.img
#boot=/dev/hda

Which is the same thing it said last time I did it this way. I'm not sure what you mean by "GRUB has to be...in the 1st sector of the first drive."

One important difference I just realized from what you said though is that last time my first drive was the Windows drive and the second drive was the Linux drive. So I guess that's why I have to do the mapping as you said. Is there something else I need to do too though?

Thanks for the link you sent. I'll try looking over it too.
 
Old 01-31-2006, 02:02 PM   #4
mayaa001
LQ Newbie
 
Registered: Jan 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Another twist...

I just realized that my first partition on hdb (the windows drive) is not the OS, it is swap. The 3rd partition is the OS though it seem to be labeled as hdb5. Not sure why.

Anyways, my current grub.cong entry for windows looks like this:

title Windows XP
map (hd1) (hd0)
map (hd0) (hd1)
root (hd1,2)
chainloader +1
makeactive
boot

I changed root (hd1,0) to (hd1,2) since that makes it look for the 3rd partition, right? But now it just says:

Error 12: Invalid Device Request

I also tried root (hd1,5) just in case. Same error though.

I'm assuming the mapping thing above took care of the problem of my Windows drive being the 2nd rather than 1st one. And I figured the root command needed to be placed after this mapping. Though that was just a guess. Not sure where else I'm going wrong though.

Last edited by mayaa001; 01-31-2006 at 02:04 PM.
 
Old 01-31-2006, 02:11 PM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by mayaa001
When i installed Fedora I told it to put grub on /dev/hda since that was where the rest of Linux was. I'm not sure what other options you might mean.

Which is the same thing it said last time I did it this way. I'm not sure what you mean by "GRUB has to be...in the 1st sector of the first drive."

O
When the machine boots, it looks for instructions in one of several places:
floppy
CD
1st sector fo first hardrive.

(The BIOS configuration will tell you where it looks and in what order)

If you are booting from HD, then grub WILL be in the first sector---which is what will happen when you tell Fedora to put it on /dev/hda

Take a look at the various references, grub manual, etc. on the "chainloader" command in grub config file. I THINK that "chainloader +1" sends the system to the next sector on the same drive where it is processing. Thus if grub is on drive 0, it will not find NTLDR on drive 1. I think this is what the remapping fixes.

Because my brain typically shorts out on the details, I usually stick with Windows on first, and Linux on second. Note that you may be ble to change boot order in BIOS--or you can simply physically chqange the drive connections
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help with Windows 98 se and fedora core 4 dual booting Albuca Linux - Newbie 7 09-06-2005 08:18 AM
need help with Windows 98 se and fedora core 4 dual booting Albuca Linux - Newbie 1 09-04-2005 08:06 PM
dual booting Window XP, Fedora Core 2 jaz Linux - Newbie 8 08-22-2004 07:58 PM
Dual booting WindowsXP and Gentoo - HOW??? black hole sun General 5 08-09-2004 01:45 PM
Dual booting SuSE and Fedora Core 2 acidream Linux - General 2 04-21-2004 12:32 PM


All times are GMT -5. The time now is 05:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration