LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-14-2003, 03:45 PM   #1
GoddessPrime
LQ Newbie
 
Registered: Sep 2003
Location: Earth, of course
Distribution: Red Hat 9.0
Posts: 12

Rep: Reputation: 0
Unhappy Dual Booting problems: XP and RH9


I'm trying to get my laptop to dual boot XP and RH9.

First, it (I'm assuming 'it' is grub) would only let me choose between RH9 or DOS for booting.

So I installed a program (in windows) called BootMagic that supposedly let me choose between RH9 and XP.

BootMagic wouldn't let me boot RH9. So, I've disabled BootMagic and NOW I can only boot XP.

*sigh*
 
Old 09-14-2003, 04:17 PM   #2
dan2974
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
I am having the same problem with the same software involved.
I been reduced to booting linux from a floppy,
Let me know if you found a better way.
 
Old 09-14-2003, 04:53 PM   #3
SirCharles
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Rep: Reputation: 0
I have not installed RH 9 yet but was going to do the same thing you gentlemen have done,,,,,,but maybe not now. I sure hope someone can give us a hand......
 
Old 09-14-2003, 04:58 PM   #4
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
By default, RedHat will assign the name DOS to all windows OSes (including windowsXP).
Did you try the DOS ?

To re-install GRUB, use your Linux boot disk to boot into Linux.
Login as root and type:
Code:
grub-install /dev/hda
This will install GRUB back in to the MBR.
 
Old 09-14-2003, 05:27 PM   #5
GoddessPrime
LQ Newbie
 
Registered: Sep 2003
Location: Earth, of course
Distribution: Red Hat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
I'll try that, thanks Mathieu.

However, I did try to choose DOS before and it wasn't booting up, thats why I assumed it was trying to boot DOS.
 
Old 09-14-2003, 06:08 PM   #6
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
If it still does not work, I will need more information.
Post the contents of the /boot/grub/grub.conf and /boot/grub/device.map files.

And the output of the following command (you will need to be root):
Code:
fdisk -l
 
Old 09-14-2003, 06:15 PM   #7
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
one reason windows would have failed to boot is if u used partition magic (or whatever other partitioning software) to set the linux partition active...

go into windows, and make the windows partition active, AlWaYs, windows wants to be the primary system at all times, so just let it be

use the software to make sure that windows will always be active; then disable boot magic (u should not use it for redhat, too complicated)

then, if u don't have a boot disk, just pop in cd 1 of redhat, type linux rescue, follow the onscreen instructions, do a chroot /mnt/sysimage when u get to a prompt, and type grub-install /dev/hda

yes, and also post the /boot/grub/grub.conf contents and results from fdisk -l (which u may have to exit x windows to do, do this by hitting ctrl alt f1 (f1-f6 u can use)
 
Old 09-14-2003, 06:38 PM   #8
GoddessPrime
LQ Newbie
 
Registered: Sep 2003
Location: Earth, of course
Distribution: Red Hat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
After I've typed grub-install /dev/hda and attempt to reboot to windows, I get a system disk error and it asks me to reinsert the disk and press any key.

I should also probably mention that I can't get any of the network devices to work (even though I followed the manual) so I have to use windows to get online.

I'll see to those outputs now.
 
Old 09-14-2003, 06:41 PM   #9
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
so u can get into windows?

what exactly does the system disk error say and when does this occur, before grub, or after grub?

post fdisk -l and contents of /boot/grub/grub.conf please
 
Old 09-14-2003, 07:38 PM   #10
GoddessPrime
LQ Newbie
 
Registered: Sep 2003
Location: Earth, of course
Distribution: Red Hat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Sorry, the formatting might not be the best because I had to copy the info to emacs, save to disk then open using notepad.

fdisk -l
Code:
[root@localhost root]# fdisk -l

Disk /dev/hda: 30.0 GB, 30005821440 bytes
255 heads, 63 sectors/track, 3648 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes


Device     Boot    Start       End    Blocks       Id  System
/dev/hda1             1         4        32098+    de  Dell Utility
/dev/hda2   *        11       2969   23768167+  7  HPFS/NTFS
/dev/hda3             5          10       48195      6  FAT16
/dev/hda4          2970        3648    5454067+   f  Win95 Ext'd (LBA)
/dev/hda5          2970        2982    104391       83  Linux
/dev/hda6          2983        3588   4867663+    83  Linux
/dev/hda7          3589        3648    481918+     82  Linux swap

Partition table entries are not in disk order

[root@localhost root]# /boot/grub/grub.conf
bash: /boot/grub/grub.conf: Permission denied
[root@localhost root]# /boot/grub/device.map
bash: /boot/grub/device.map: Permission denied
grub.conf
Code:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,4)
#          kernel /vmlinuz-version ro root=/dev/hda6
#          initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,4)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
	root (hd0,4)
	kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdb=ide-scsi
	initrd /initrd-2.4.20-8.img
title DOS
	rootnoverify (hd0,2)
	chainloader +1
device.map
Code:
# this device map was generated by anaconda
(fd0)     /dev/fd0
(hd0)     /dev/hda
 
Old 09-14-2003, 07:45 PM   #11
GoddessPrime
LQ Newbie
 
Registered: Sep 2003
Location: Earth, of course
Distribution: Red Hat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
so u can get into windows?
Not exactly, I have to place the BootMagic rescue disk in (because I, stupidly, don't have an XP rescue disk) which negates the grub-install command and re-enables BootMagic which allows me to restart again and choose windows.

Complicated, huh?

Thankfully I actually have an RH9 rescue disk.
 
Old 09-14-2003, 07:57 PM   #12
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Try setting /dev/hda5 (wherever your /boot is) to active aftering installing grub back into mbr
and change the rootnoverify line into (hd0,2) (wherever your ntldr,boot.ini,ntdetect.com is located)
 
Old 09-14-2003, 08:48 PM   #13
Knight
LQ Newbie
 
Registered: Jan 2003
Location: Dallas, Texas
Distribution: Red Hat 8
Posts: 2

Rep: Reputation: 0
Cool

I read somewhere that Grub was the default boot loader for Linux. Grub would not work in a dual boot environment. I have Linux RH 8 and I was using LiLo, but when I reformated and re-installed Win XP Pro, it did something to LiLo. So now I boot from a disk, which I have also heard a lot of people recommend. I hope this helps, as I'am also a n00b at this. MasterC is one of the mods and has helped me a lot with Linux and such, you can always drop him a line.
 
Old 09-14-2003, 09:35 PM   #14
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
In the grub.conf, replace all the lines under title DOS inclusively with the following lines.
Code:
title WindowsXP
	rootnoverify (hd0,1)
	chainloader +1
Grub was trying to boot the FAT16 partition (hd0,2).

-----
Quote:
[root@localhost root]# /boot/grub/grub.conf
bash: /boot/grub/grub.conf: Permission denied
/boot/grub/grub.conf is a file (including the full path).
To view the contents of the file, type:
Code:
more /boot/grub/grub.conf
Quote:
Grub would not work in a dual boot environment. ... So now I boot from a disk, which I have also heard a lot of people recommend.
Someone is lying to you.

If you re-install windows on a PC with Linux, windows will overwrite the MBR (which is where all bootloader including Grub and Lilo are installed) with its own bootloader.
To install Lilo in the MBR, type:
Code:
lilo

Last edited by Mathieu; 09-14-2003 at 09:39 PM.
 
Old 09-14-2003, 10:21 PM   #15
GoddessPrime
LQ Newbie
 
Registered: Sep 2003
Location: Earth, of course
Distribution: Red Hat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Merci beaucoup, Mathieu!!!!!!!!

It finally works!

As an added bonus I figured out what was wrong with my ethernet connection so it now works, aswell!!!!!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB stalls on RH9 dual booting XP paul1892 Linux - Newbie 3 01-02-2005 09:52 AM
Dual booting Windows XP and RH9 roguecoolman Linux - Newbie 14 02-22-2004 01:38 AM
Problems Dual Booting technerd Linux - Newbie 3 11-24-2003 09:13 AM
Dual Booting Debian w/ RH9 General_Tso Debian 9 07-19-2003 07:54 AM
Dual Booting with XP Pro and RH9 eacable Linux - General 3 05-13-2003 04:21 PM


All times are GMT -5. The time now is 05:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration