LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2005, 11:50 AM   #1
A.J.Gibson
LQ Newbie
 
Registered: Jan 2004
Posts: 19

Rep: Reputation: 0
Dual-Booting Mandrake and Linspire with LILO


Please help me, I'm running Mandrake 10.1 and Linspire 5.0 on my machine. Mandrake was installed first (it's my main system), then Linspire (just to try it out). Installing Linspire replaced the bootloader, so I reinstalled Mandrake's Lilo, but it Kernel Panics when I try to get to Linspire now. Mandrakes boot configurator was not helpful. What lilo.conf setting will work? Here is my current one:

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default="Mandrake_10.1"
boot=/dev/hda
map=/boot/map
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="Mandrake_10.1"
root=/dev/hda1
initrd=/boot/initrd.img
append="acpi=ht resume=/dev/hda3 splash=silent"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda1
initrd=/boot/initrd.img
append="acpi=ht resume=/dev/hda3 splash=silent"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda1
initrd=/boot/initrd.img
append="failsafe acpi=ht resume=/dev/hda3 splash=silent"
read-only
image=/A/boot/vmlinuz-2.6.10
label="Linspire_5.0"
root=/A
initrd=/A/boot/initrd-2.6.10.gz
append="acpi=ht resume=/dev/hda3 splash=silent"
read-only

Mandrake is on hda1, and Linspire on hda4. My swap partition is hda3 and I use hda2 for my home directory in Mandrake. I have my Mandrake mount hda4 as /A rather than /mnt/hda4. Linspire is on a ReiserFS, which might be an issue because I see error messages on start up for 'ext3' not found. Also, what do I need to do after changing the file, is /sbin/lilo sufficient? Thanks.
 
Old 10-09-2005, 03:15 PM   #2
felixc
Member
 
Registered: Jul 2005
Distribution: Debian
Posts: 94

Rep: Reputation: Disabled
label="Linspire_5.0"
root=/A
initrd=/A/boot/initrd-2.6.10.gz
append="acpi=ht resume=/dev/hda3 splash=silent"
read-only

I don't know much about LILO, but these guys http://www.freeos.com/articles/2701/ http://www.redhat.com/docs/manuals/e...-liloconf.html http://www.google.com/search?sourcei...iguration+file sure do.

However, it looks to me like your root is wrong. Try root=/dev/hda4 and then initrd=/dev/hda4/boot/initrd-2.6.10.gz

Cheers,

-Felix
 
Old 10-09-2005, 07:59 PM   #3
A.J.Gibson
LQ Newbie
 
Registered: Jan 2004
Posts: 19

Original Poster
Rep: Reputation: 0
On a related note: do I need an initrd.img file? The Linspire bootloader didn't seem to have one anywhere, there is a file named initrd but it's 10M. I tried usng it and it didn't work.
 
Old 10-10-2005, 11:19 AM   #4
A.J.Gibson
LQ Newbie
 
Registered: Jan 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by felixc
label="Linspire_5.0"
root=/A
initrd=/A/boot/initrd-2.6.10.gz
append="acpi=ht resume=/dev/hda3 splash=silent"
read-only

I don't know much about LILO, but these guys http://www.freeos.com/articles/2701/ http://www.redhat.com/docs/manuals/e...-liloconf.html http://www.google.com/search?sourcei...iguration+file sure do.

However, it looks to me like your root is wrong. Try root=/dev/hda4 and then initrd=/dev/hda4/boot/initrd-2.6.10.gz

Cheers,

-Felix
I tried this, but it complained about my init parameters. The initrd file lists is 10M, so I think it's wrong. But I have no other initrd file except the one I use with Mandrake, which is for Mandrake's kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lilo vs grub, dual-booting binkgle Ubuntu 6 05-16-2005 01:39 AM
Dual Booting LILO issues... [WebCarnage] Linux - Software 6 03-08-2004 05:30 PM
Dual Booting - XP/LILO loader lawadm1 Linux - General 1 02-29-2004 05:15 AM
dual booting seting up lilo avoidmoney Linux - Newbie 5 02-15-2004 03:52 PM
Lilo dual booting Slackwares Linux - Software 3 10-11-2003 03:42 AM


All times are GMT -5. The time now is 05:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration