LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2003, 03:34 AM   #1
ashlar
LQ Newbie
 
Registered: Jan 2003
Distribution: Red Hat
Posts: 6

Rep: Reputation: 0
dual boot winxp and RH 8.0


Hi I'm a linux newbie trying to set up a dual boot system using redhat with my existing windows xp system as a secondary OS for practice and testing at home.

my problem is I can't get grub to load the boot screen after I installed red hat 8.0. my system used to run XP exclusively on a single 20 Gb hard drive partitioned into 2 10 Gb partitions (1 for the system and the other for data). I recently bought an additional 20 Gb drive and partitioned 10 Gb and formatted it (FAT32) as a shared drive and thought of installing linux into the remaining unpartitioned space.

I partitioned and installed using Red Hat 8.0 and encountered no errors but when the system rebooted after the installation it booted straight into Win XP. I wasn't able to create a boot diskette because my floppy drive is buggy and I mostly use my CD and CD-R for backups and transfers.

I'm guessing my installation was ok because when I tried booting using the redhat CDs and going into rescue mode and accessing my installed folders it worked.

I've read quite a few articles already giving conflicting advice that during installation i should choose to install grub into the mbr or boot/. I've already done the installation twice just to test both cases but it still doesn't seem to work. help!
 
Old 01-21-2003, 03:56 AM   #2
finidi
Member
 
Registered: Dec 2002
Location: World
Distribution: Fedora Core 4
Posts: 127

Rep: Reputation: 15
This seems to be an issue of Grub 0.92 which come with RH 8.0 --- I don't know if it's have been fixed ---
Maybe the best solution is: reinstall RH selecting LILO as boot loader.
 
Old 01-21-2003, 05:02 AM   #3
ashlar
LQ Newbie
 
Registered: Jan 2003
Distribution: Red Hat
Posts: 6

Original Poster
Rep: Reputation: 0
I see is there any way to switch to lilo as bootloader
without having to reinstall the entire thing?
 
Old 01-21-2003, 07:31 AM   #4
deadbug
Member
 
Registered: Oct 2002
Location: San Antonio, Texas
Distribution: MDK 8.0, 9.0; RH 7.2, 8.0, 9.0, FC3, FC4, FC5
Posts: 355

Rep: Reputation: 30
Pretty simple, actually (if you can start Linux). Log on as root and configure /etc/lilo.conf (start with the contents of /etc/lilo.conf.anaconda). Then, in a terminal window, type:

lilo

Last edited by deadbug; 01-21-2003 at 07:34 AM.
 
Old 01-21-2003, 08:06 AM   #5
finidi
Member
 
Registered: Dec 2002
Location: World
Distribution: Fedora Core 4
Posts: 127

Rep: Reputation: 15
No doubt, simpler than mine
 
Old 01-21-2003, 07:58 PM   #6
ashlar
LQ Newbie
 
Registered: Jan 2003
Distribution: Red Hat
Posts: 6

Original Poster
Rep: Reputation: 0
i'm currently limited to booting linux thru my cd-rom (floppy's busted) in rescue mode. It doesn't really prompt me for a username or password when I start up. Can I just cd (change directory) to the installed linux drives and su into root this way?
I can't think of any other way of getting there otherwise.

also how do i go about configuring /etc/lilo.conf? Do I have to change stuff in the file thru a text editor or can i just run lilo from command line and take it from there

btw thanx for putting up with my questions
 
Old 01-22-2003, 03:38 AM   #7
finidi
Member
 
Registered: Dec 2002
Location: World
Distribution: Fedora Core 4
Posts: 127

Rep: Reputation: 15
In rescue mode go to the console prompt, cd /etc
Then cp lilo.conf.anaconda lilo.conf
if you didn't upgrade the supplied kernel, don't need to edit lilo.conf
else vi lilo.conf, adjusting kernel and initrd file names (at /boot)
finally, run "lilo", "sync", and reboot.
Now Lilo is the boot loader.
 
Old 01-22-2003, 10:49 PM   #8
ashlar
LQ Newbie
 
Registered: Jan 2003
Distribution: Red Hat
Posts: 6

Original Poster
Rep: Reputation: 0
i tried your advice but i also cant get lilo to work..
anyways this might sound funny but i've got a new problem.
i tried reinstalling linux (for the last time hopefully) selecting grub as the bootloader and surprise, surprise, it works now! i'm now able to boot into red hat and do all the stuff i want to do there BUT... now my new problem is everytime i try selecting windows xp from the grub loader my machine just reboots!! now i can't get to my windows system where all my files are. i've read somewhere that you can clear the mbr of grub by typing fdisk /mbr at command line but i dont really want to end up unable to get into linux again. and i'm not sure i want to go thru the hassle of doing everything from scratch just to try getting it working again. can anyone suggest a workaround? i'm able to access grub.conf from linux and my windows xp boot area looks something like this:

Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1

any suggestion would help greatly here. i'm hoping i can get this fixed before the week end or else i might have to end up removing grub AND linux for good just to get windows working
 
Old 01-23-2003, 02:49 AM   #9
finidi
Member
 
Registered: Dec 2002
Location: World
Distribution: Fedora Core 4
Posts: 127

Rep: Reputation: 15
I'm on the same, my Windoze partition (which I use marginally) is starting from BIOS (modifying the boot device every time I want to start it). Linux loads OK. My boot loader is Lilo... before that was Grub but after trying ALL I gave up.

I'll try to config Lilo... when have the time.
 
Old 01-23-2003, 05:58 PM   #10
finidi
Member
 
Registered: Dec 2002
Location: World
Distribution: Fedora Core 4
Posts: 127

Rep: Reputation: 15
Finally is dual-booting properly !!!! it was simple... Windows just wants to be in the first drive, using the "map-drive" option a soft-swapping can be performed.

This is my /etc/lilo.conf :

prompt
timeout=15
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
lba32

image=/boot/vmlinuz-2.4.18-19.8.0
label=linux
initrd=/boot/initrd-2.4.18-19.8.0.img
read-only
append="hdd=ide-scsi root=LABEL=/"

other=/dev/hdb1
label=DOS
table=/dev/hdb
loader = /boot/chain.b
map-drive = 0x80
to = 0x81
map-drive = 0x81
to = 0x80

This works for a system with Linux on the first ide hd and Windows on secondary hd.

HTH
 
Old 01-23-2003, 08:31 PM   #11
ashlar
LQ Newbie
 
Registered: Jan 2003
Distribution: Red Hat
Posts: 6

Original Poster
Rep: Reputation: 0
Talking Finally got mine working too!!

I played around with the settings ( rootnoverify (hd0,0) )in my grub.conf file and (finally!) got windows to boot properly! apparently, grub failed to detect the location of win xp on my hard drive properly so it kept trying to boot from a non-bootable partition. this might be the cause of the constant restart when i select it from the boot menu.

anyway thanks finidi and deadbug for helping me along in my (awkward :P) first steps in trying to get linux running in my system. next i'll probably be asking about device detection and other stuff but that would merit another thread. thanks again =)
 
Old 01-24-2003, 03:48 AM   #12
finidi
Member
 
Registered: Dec 2002
Location: World
Distribution: Fedora Core 4
Posts: 127

Rep: Reputation: 15
I'm glad too
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot WinXP/Debian, grub error booting WinXP ChemBot Linux - General 5 02-22-2007 05:13 PM
Need help fixing boot problem on Ubuntu/WinXp dual-boot Ay-Karamba! Linux - General 5 09-06-2005 10:20 PM
Need dual boot help...LILO..Winxp wont boot Scrag Linux - Hardware 2 09-01-2004 01:26 AM
Advice (and some) Needed: Dual-HDD, Dual-Boot - Linux, WinXP elnomadkvn Linux - General 1 03-28-2004 11:11 AM
Redhat 9 & winxp dual boot -xp won't boot opivy Red Hat 3 01-02-2004 02:08 PM


All times are GMT -5. The time now is 08:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration