LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Dual boot Windows XP and OpenSuse (http://www.linuxquestions.org/questions/linux-newbie-8/dual-boot-windows-xp-and-opensuse-769408/)

ggyyree 11-16-2009 05:14 AM

Dual boot Windows XP and OpenSuse
 
Hi there,

I met a problem with dual booting with WinXP and OpenSuse. I try to use Windows as the MBR which means I want to boot to WinXP as default, and Windows ntloader control the booting. I set the boot.ini under WinXP as,

Code:

[boot loader]
timeout=8
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
C:\linux.lnx="Grub Menu for OpenSuse 11"
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP 64-bit Pro SP3" /fastdetect
C:\GHLDR=One Key GHOST

then I copy the linux.lnx from the Linux below to connect the Linux Grub and Windows ntloader,

Code:

# mount -t vfat /dev/sda1 /mnt
# dd if=/dev/sdaY of=/mnt/linux.lnx bs=512 count=1

Last time it works fine to me; however, it doesn't work this time when I re-install a 64-bit version of Opensuse.

I don't know if it is a problem of 64-bit system or not. Should we still copy 512B of linux.lnx now?

Or my settings for OpenSuse boot is incorrect? When I install the OpenSuse, it asks something like below:

Code:

Boot from MBR?
Boot from root?
Boot from boot?
Boot from extended filesystem?

Which ones I should choose please?

Thanks a lot!

soleil24 11-16-2009 06:44 AM

Long time since I had win booting linux but iirc for that method to work, I'm pretty sure you'll need suse grub to be installed at root - because you're telling ntldr to hand off to "somewhere", that "somewhere" is the partition you've chosen as root so that's where grub needs to be. And that needs to be done before you do the copy of the front 512B of that partition.

Sure someone will correct me if my memory has got it wrong ;)

Much easier to have grub run it all !!

IG

ggyyree 11-16-2009 10:15 AM

Quote:

Originally Posted by soleil24 (Post 3758613)
Long time since I had win booting linux but iirc for that method to work, I'm pretty sure you'll need suse grub to be installed at root - because you're telling ntldr to hand off to "somewhere", that "somewhere" is the partition you've chosen as root so that's where grub needs to be. And that needs to be done before you do the copy of the front 512B of that partition.

Sure someone will correct me if my memory has got it wrong ;)

Much easier to have grub run it all !!

IG

Thanks, but refer to this link:

http://opensuse.swerdna.org/suseboot1.html

I have got a separate /boot then I need to choose 'Boot from boot',and I have already setup Grub at /boot; however, I don't know where I did something wrong. After ntloader shows the boot options:

Code:

-Grub Menu for OpenSuse 11
-Windows XP 64-bit Pro SP3

After I chose to boot OpenSuse nothing showed up. Windows XP could be login.

If I set the MBR to Opensuse then it can start...


Any other suggestions please post. Thanks a lot!

yancek 11-16-2009 05:33 PM

Compare what you said you did in your first post, below:

Quote:

dd if=/dev/sdaY of=/mnt/linux.lnx bs=512 count=1
to what is suggested in the link you supplied:

Quote:

dd if=/dev/sda3 of=/mnt/windows/suse.bin bs=512 count=1
he copies the code in OpenSuse boot sector to a file named suse.bin in the root of the windows partition which is mounted at /mnt/windows, this file goes to the root partition in windows, usually referred to as: C:\. If you don't have the file there, it won't work.

Quote:

I have got a separate /boot then I need to choose 'Boot from boot',
I'm not sure what that means, do you have a separate boot partition or just the Opensuse root partition? If you have a separate boot partition, I don't think the instructions on your link account for that.

soleil24 11-16-2009 05:35 PM

If you have a separate /boot partition and have put suse grub there, that's the partition you need to be copying the front 512B from to make your .lnx file - so the "/dev/sdaY" in your quoted code, Y needs to match the partition number for wherever /boot is (and is unlikely to be 1 as that will probably be your win partition)

ggyyree 11-20-2009 01:53 PM

Weird!?

It works by just choose 'Boot from extended filesystem' without mount a /boot.

Anyone can explain this to me would be appreciate.

And thanks for all your help!


All times are GMT -5. The time now is 03:20 AM.