LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-16-2009, 05:46 PM   #1
palisetty_suman
Member
 
Registered: Feb 2007
Location: TX, USA
Distribution: fedora
Posts: 191

Rep: Reputation: 33
Thumbs up dual boot windows and fedora


Hi while creating dual boot, i used the option "use free space and create custom layout" but i did not get the dual boot option. My sir just told me that, i need to add a line
grub.conf
I don't know when and where to add this line. Please help me.
 
Old 03-16-2009, 05:55 PM   #2
Berticus
Member
 
Registered: Jul 2005
Distribution: Arch
Posts: 159

Rep: Reputation: 31
The solution to this problem is pretty much everywhere.

At the end of the file, add:
Code:
title Windows
rootnoverify (hd0,1)
makeactive
chainloader +1
Change (hd0,0) to the partition Windows is on. A number prefixed with hd refers to the hard drive number, the second parameter is the partition number. The count starts with 0. So first hard drive is hd0, second hard drive is hd1, et cetera. Likewise, first partition is 0, second partition is 1, et cetera.

So if you want first hard drive, first partition it's (hd0,0)
first hard drive, second partition (hd0,1)
second hard drive, first partition (hd1,0)
 
Old 03-16-2009, 06:04 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Your "sir" told you?

Anyhow, you need to edit the file /boot/grub/grub.conf to include a stanza like this:
Code:
title Vista
        rootnoverify (hd0,0)
        chainloader +1
b]

F.Y.I.: You need "root" access to edit the gruub.conf file, so open a terminal and use the command su - to long in as "root" using that terminal window. Then use the command nano /boot/grub/grub.conf to edit the file.

Note 1: Unless you over-ride the default, anaconda should have created a Windows logon stanza for you labeled "Other," so if you see an "Other" option, try it.

Note 2: You may have the "hidemenu" option in your grub.conf file. If you do, you need to press the "Escape" key when the GRUB splash screen is displayed in order to see your menu choices.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple intermittent boot errors on a Fedora 9 / Windows XP dual boot system RichyAD Linux - General 4 09-15-2008 04:32 PM
Dual boot -fedora core 4 and windows xp- problem booting from windows xp cd r_desu Linux - Newbie 4 06-17-2007 05:33 PM
Dual boot, two disk Fedora Windows only opens Windows Javkin Fedora 2 10-20-2006 04:47 AM
dual boot Fedora 5 64 and windows otto k Fedora 16 08-10-2006 06:22 PM
Cannot select Fedora 2 on Fedora 2 and Windows XP Dual Boot RThomson Fedora - Installation 6 11-05-2004 09:49 PM


All times are GMT -5. The time now is 01:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration