LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-28-2006, 07:13 AM   #1
kachelle
LQ Newbie
 
Registered: Sep 2006
Location: Barbados
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Question Dual boot-up with Windows XP


When I boot up my computer, i want the option of either choosing windows xp or ubuntu. However, when I select Windows xp I get the following message:
---------------------------------------------------------
Booting ‘Microsoft Windows XP Professional’

Root (hd0,0)
Filesystem type unknown, partition type 0x7
savedefault
makeactive
chainloader +1
---------------------------------------------------------

How do i go about correcting this issue? i can open window files from within the Ubuntu; so i know the operating system is still there.
 
Old 09-28-2006, 07:20 AM   #2
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.2 (multilib)
Posts: 1,221

Rep: Reputation: 58
Some Windows installations have a small hidden partition at the start of the disc. Your ubuntu installation might have set up grub to boot off this partition but the main partition will be on the second partition hd0,1 and it is this that needs to be booted.

I suggest editing menu.lst and changing hd0,0 to hd0,1 and see if that helps.

(menu.lst needs to be edited as root. From memory it is in /boot/grub)
 
Old 09-28-2006, 07:26 AM   #3
hoe
Member
 
Registered: May 2004
Location: Fredericton, NB Canada
Distribution: Mepis
Posts: 81

Rep: Reputation: 15
The file to edit as root is /boot/grub/menu.lst . This is what mine looks like ... hd0 being the first hard drive and 0 being the first partition on that hard drive.


title Windows at hda1
rootnoverify (hd0,0)
chainloader +1

Wayne
 
Old 09-28-2006, 07:30 AM   #4
SlackDaemon
Member
 
Registered: Mar 2006
Distribution: RedHat, Slackware, Experimenting with FreeBSD
Posts: 222

Rep: Reputation: 30
make sure that the entry in menu.lst has rootnoverify (hd0,N)
under the windows stanza. Where N is 0 or 1. It looks like grub is trying to verify the filesystem type on the specified partition.
 
Old 10-03-2006, 06:01 PM   #5
kachelle
LQ Newbie
 
Registered: Sep 2006
Location: Barbados
Distribution: Ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks but no luck

I tried editing the menu.lst but no luck. Any other advice? I was thinking about uninstalling the ubuntu and reload again but I not certain how to uninstall. Also, I donot have a xp cd as it came preinstalled.
 
Old 10-04-2006, 03:53 AM   #6
hoe
Member
 
Registered: May 2004
Location: Fredericton, NB Canada
Distribution: Mepis
Posts: 81

Rep: Reputation: 15
You don't have to uninstall Ubuntu ... when you use the live CD to install it on the same partition it will reformat the partition before it installs itself therefore you will have a fresh install when you are done. But copy and paste your entire menu.lst here so we can have a look first.

Wayne
 
Old 10-04-2006, 06:42 PM   #7
kachelle
LQ Newbie
 
Registered: Sep 2006
Location: Barbados
Distribution: Ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
Unhappy Menu.lst

# menu .lst – See: grub (8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

# # default 0
# Set the default entry to the entry number Num. Numbering starts from 0, and
# The set entry number 0 is the default if the command is not used.

# You can specify ‘saved’ instead of a number. In this case, the default entry
# is the entry saved with the command ‘savedefault’.
# Warning: If you are sing dmraid do not change this entry to ‘saved’ or your array will
# desync and will not let you boot your system.
default 0

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
# hiddenmenu

## password [‘—md5’ ] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries procted by the
# command ‘lock’
# e.g. password topsecret
password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# chainloader +1
#
# title Linux
# root (hd0,1)
#kernel /vmlinuz root=/dev/hda2 ro
#
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST


### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST makers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for special kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.

## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/hda2 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=false

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternative
## e.g. defoptions=vga=791 resume=/dev/hda5
## defoptions=queit splash

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only count the first occurance of a kernel, not the
## alternative kernel options
## e.g. howmany=all
howmany=7
# howmany=all

## should update-ggrub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=false


## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=true

## ## End Default Options ##

title Ubuntu, kernel 2.6.15.-23-386
root (hd0,1)
kernel /boot/vmlinuz-2.6.15-23-386 root=/dev/hda2 ro quiet splash
initrd /boot/initrd.img-2.6.15-23-386
savedefault
boot

title Ubuntu, kernel 2.6.15.-23-386 (recovery mode)
root (hd0,1)
kernel /boot/vmlinuz-2.6.15-23-386 root=/dev/hda2 ro single
initrd /boot/initrd.img-2.6.15-23-386
boot

title Ubuntu, memtest86+
root (hd0,1)
kernel /boot/memtest86+ .bin
boot

## ## END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# ondev/hda0
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1
 
Old 10-05-2006, 07:13 AM   #8
hoe
Member
 
Registered: May 2004
Location: Fredericton, NB Canada
Distribution: Mepis
Posts: 81

Rep: Reputation: 15
It probably won't make a difference if you reinstall but rather there is something it doesn't like in you menu.lst

Try this but l would also try the Ubuntu forums where someone probably has encountered and solved the same problem. Once l had a problem and it turned out that l didn't have a space between chainloader and +1 . If someone in Ubuntu gave you their menu.lst of a working Grub menu.lst containing XP you might figure it out.

title Microsoft Windows XP Professional
root (hd0,0)
makeactive
chainloader +1

Wayne
 
  


Reply

Tags
boot, dual


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dual boot - Grub won't boot Windows on /windows/D partition biosol SUSE / openSUSE 9 04-09-2006 08:14 PM
Windows XP Suse 9.2 dual boot problem:Yast doesn't find windows Salawat SUSE / openSUSE 1 03-31-2006 04:33 AM
Linux-windows Dual boot question when upgrading from windows 2000 to XP sarikalinux Linux - Newbie 1 03-09-2006 02:21 PM
linux/ windows dual boot. Windows XP is in portable HDD (already installed) izquierdista Linux - General 1 02-03-2006 10:23 AM
How do I dual boot Linux and Windows XP from Windows boot file andyri Linux - Newbie 4 08-04-2004 10:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration