LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2002, 04:04 PM   #1
billmaly
LQ Newbie
 
Registered: Oct 2002
Location: Iowa
Distribution: Red Hat 8
Posts: 15

Rep: Reputation: 0
Dual boot problems, please help


Ongoing quest for a dual boot rig. I've installed Red Hat 8.0 to a 2nd hard drive on my system (IDE, Primary Slave drive). I installed without a boot loader and created a boot floppy. Booting from the floppy works flawlessly.

However, I don't want to boot from the floppy, I want NT (W2K in this case) Boot Loader to present me with a list of available OS's, and choose from there. If you look all over the net for dual boot instructions, you find many variations of this procedure:

--Log in as root. Look at /etc/lilo.conf and make sure the default boot location is indeed where you installed. If not, you can change it and apply by running lilo.
(I tried to look at this file, it does not exist in this location)

-- execute:
# dd if= /dev/HDxx of= /bootsect.lnx bs=512 count=1

(where HDxx equals the /boot partition of Linux, in my case, /hdb1, verifed by using the df command to check partitions)

This takes the first 512 bytes from the partition holding the boot record, and puts it into a file called bootsect.lnx. Replace /dev/hdc1 with the partition you used.

When I do this, I get a message that says:
1+0 records in
1+0 records out
The goddam documentation that's out there says NOTHING AT ALL about what that is supposed to mean!!!

-- mcopy that file to your _DOS_ floppy (don't forget to mount it first):
# mcopy bootsect.lnx /mnt/floppy

-- Restart your machine, no floppies. The W2k loader should show "normally" and get you right in to W2k.

-- Add an entry for W2k boot loader.

-- In a command shell, copy the file a:\bootsect.lnx into c:\.

-- Add a line to the end of boot.ini to read 'c:\bootsect.lnx="Linux"'

Well, I've done all that, many times, and when I try to boot to Linux, I get "Invalid boot partition" message.

I've got dual boot to work in the past, and when I did, the 1+0 message instead read 1+1 , not 1+0. I think it was back on an old version of Mandrake, using SCSI disks. However, now I am using IDE. In a word, why won't these supposedly simple procedures work for me???
 
Old 10-09-2002, 05:24 PM   #2
jglen490
Member
 
Registered: Apr 2002
Location: The next brick house on the right.
Distribution: Kubuntu 8.04
Posts: 668

Rep: Reputation: 31
The first clue is
Quote:
(I tried to look at this file, it does not exist in this location)
Lilo and the Lilo configuration file need to exist on your hard drive -- you have them on your floppy, but not your hard drive. What you have copied to the bootsect.lnx file is just whatever random code exists in the boot sector of your Linux partition, which is probably no code at all. Thus, you get the "Invalid boot partition" message from Windoze.

You need to copy the lilo.conf file from your floppy to /etc/lilo.conf. Then edit it to refer to the correct hard drive partition locations and run /sbin/lilo -v. The "-v" option on the lilo command will show any errors on your screen. You want to make sure that lilo is targeted to the Linux partition where it can find the lilo.conf file and to where lilo wrote it's boot sector code.
 
Old 10-09-2002, 11:53 PM   #3
billmaly
LQ Newbie
 
Registered: Oct 2002
Location: Iowa
Distribution: Red Hat 8
Posts: 15

Original Poster
Rep: Reputation: 0
I looked at my floppy under Linux, the only files on it are:
boot.msg, initrd.img, ldlinux.sys, syslinux.cfg, and vmlinuz. In case it matters, the syslinux.cfg file reads:
"default linux
prompt 1
display boot.msg
timeout 100
label linux
kernel vmlinuz
append initrd=initrd.img hdd=ide-scsi root=/dev/hdb2"

What's my next move? Thanks for posting...I think this is a step in the right direction.
 
Old 10-10-2002, 08:30 AM   #4
jglen490
Member
 
Registered: Apr 2002
Location: The next brick house on the right.
Distribution: Kubuntu 8.04
Posts: 668

Rep: Reputation: 31
The quoted part of the syslinux.cfg file does belong in your /etc/llilo.conf file. But you also need more info telling Lilo where to load the boot code -- such as a reference to the boot sector of your linux space ("hdb1", I believe).

You might want to read up on Lilo here at the mini-Howto.
 
Old 10-10-2002, 01:10 PM   #5
Aphix
LQ Newbie
 
Registered: Sep 2002
Location: UK
Distribution: SuSE 8.1 Pro
Posts: 29

Rep: Reputation: 15
How bout reinstalling Red Hat and letting it configure your bootloader?

Just a suggestion ... =)
 
Old 10-10-2002, 01:28 PM   #6
billmaly
LQ Newbie
 
Registered: Oct 2002
Location: Iowa
Distribution: Red Hat 8
Posts: 15

Original Poster
Rep: Reputation: 0
I'm thinking about that...just don't want to hose up my existing W2K MBR like I did last time. Of course, I aborted install because I had a bad CD3. That probably didn't help!
 
Old 10-10-2002, 02:59 PM   #7
Aphix
LQ Newbie
 
Registered: Sep 2002
Location: UK
Distribution: SuSE 8.1 Pro
Posts: 29

Rep: Reputation: 15
Hmm, my Mandrake 8.2 CD3 was bad too ...

I finished the installation before the system updates etc so it didnt get onto CD3. You can still update the system through the Mandrake control center after install ..
 
Old 10-10-2002, 03:13 PM   #8
billmaly
LQ Newbie
 
Registered: Oct 2002
Location: Iowa
Distribution: Red Hat 8
Posts: 15

Original Poster
Rep: Reputation: 0
I tried Mandrake 9 before RedHat, but my MS Intellimouse would lockup when running drake tools. I searched for a solution, but came up with nothing, so bye Mandrake, onto Red Hat.
 
Old 10-10-2002, 03:53 PM   #9
jglen490
Member
 
Registered: Apr 2002
Location: The next brick house on the right.
Distribution: Kubuntu 8.04
Posts: 668

Rep: Reputation: 31
Quote:
Originally posted by billmaly
I'm thinking about that...just don't want to hose up my existing W2K MBR like I did last time. Of course, I aborted install because I had a bad CD3. That probably didn't help!
Once again into the breach dear friends!!

There is no such thing as a W2K MBR. W2K does have boot code in the boot sector of its partition that ends up calling the W2K kernel (via ntldr). The MBR, in the instance when Windoze is the only OS and no other boot manager is present, contains nothing but partition addresses and about 490+/- bytes of very vanilla code that refers the BIOS and its bootstrap loader to the correct bootable partition.

Do not fear installing Lilo or Grub code to the MBR. The W2K ntldr will, of course, also work well enough but it does involve a higher level of complexity during the installation.
 
Old 10-10-2002, 09:41 PM   #10
billmaly
LQ Newbie
 
Registered: Oct 2002
Location: Iowa
Distribution: Red Hat 8
Posts: 15

Original Poster
Rep: Reputation: 0
KISS...keep it simple stupid.

Reinstalled Red Hat, but this time, I installed LILO on /hda (where W2K resides), and set it up so that W2K is my primary OS (I'm not ready to make the leap, yet). I can't quote EVERY step I took, but I was cautious and made sure I understood every step before I took it (still, was nervous). Well, upon reboot, the ugly ass LILO screen comes up, giving me options for W2K and Red Hat. I can boot to both WITHOUT a boot floppy. Victory...moral of the story, let the installer do the work for you, especially if you are a Linux n00b.
 
Old 10-11-2002, 12:19 AM   #11
kriton12
Member
 
Registered: Oct 2002
Posts: 81

Rep: Reputation: 16
GRUB

since you dislike the lack of flashiness of LILO, you may consider using GRUB as a boot loader (GRand Unified Boat Loader). It's a little newer than LILO and might be easier to use. However, i see that you have it working so you may just want to leave well enough alone.
 
Old 10-11-2002, 12:31 AM   #12
billmaly
LQ Newbie
 
Registered: Oct 2002
Location: Iowa
Distribution: Red Hat 8
Posts: 15

Original Poster
Rep: Reputation: 0
You'd think I'd leave it alone...I upgraded my NVidia drivers, then rebooted. Uh oh....where did X go? And what are those odd characters on my screen?? I did something bad....i'll reinstall and revisit tomorrow.

Also, during today's install, it was slow...I was afriad it had locked up, but I walked away and came back, and progress had occurd. Weird.
 
Old 10-11-2002, 07:03 AM   #13
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
When you say I upgraded my NVidia drivers, please, please tell me that you a) read the docs, and b) edited your /etc/X11/XF86Config-4 file accordingly?
 
Old 10-11-2002, 07:16 AM   #14
billmaly
LQ Newbie
 
Registered: Oct 2002
Location: Iowa
Distribution: Red Hat 8
Posts: 15

Original Poster
Rep: Reputation: 0
Uhhhhhh......
I read the instructions (at least some of them) off of NVidia's site, but I'll confess...I did not edit a file. Perhaps in my n00bish exuberence to play Tuxracer, I got ahead of myself and went to quickly. My very very bad. What (in a nutshell) needs to be editied?
 
Old 10-11-2002, 08:37 AM   #15
Aphix
LQ Newbie
 
Registered: Sep 2002
Location: UK
Distribution: SuSE 8.1 Pro
Posts: 29

Rep: Reputation: 15
Erm ...

nvidia's linux driver support is generally v.good ... If you downloaded the rpm setup, it should do it all automatically (it did for me) ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Boot Problems...big problems Goonie Linux - General 19 12-09-2006 05:44 PM
Problems With Dual Boot / Dual Drive Setup Norab Linux - Hardware 1 08-07-2005 10:15 PM
dual boot problems, now no boot loader after fixmbr mipia Debian 2 04-04-2004 10:43 PM
Dual boot for Redhat 9 and Solaris 9 boot manager problems steve_2010 Red Hat 1 01-30-2004 10:14 PM
dual boot problems sgaucho Linux - Newbie 6 03-26-2003 09:11 AM


All times are GMT -5. The time now is 10:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration