LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-16-2004, 01:49 AM   #1
jrfly
LQ Newbie
 
Registered: Sep 2004
Distribution: Mandrake 10.1
Posts: 16

Rep: Reputation: 0
dual boot problems, can't boot xp help please!


After a lot of tryings and secession of errors with lilo..now my pc is booting linux well, but cannot boot xp:
-1 hd - 4 partitions-
1-d: ntfs my windows xp that i want to boot (i think i have to change to c:, but how where)
2-c: fat 32 (installations files of mandrake 10.0) i started a new installation of xp here, (thinking in fix the mbr & swith partitons letters from it) but couldn't finish
3-#: mandrake
4-#: swap
i can't boot Xp, and want to access it a few time yet, and when try to boot by xp installation disk to fixmbr in the repair console then it breaks down lilo.
need help! Please

Last edited by jrfly; 09-16-2004 at 01:52 AM.
 
Old 09-16-2004, 03:00 AM   #2
Aussie_Ocka
LQ Newbie
 
Registered: Aug 2004
Location: On a rugged Australian Mountain top
Distribution: Suse 9.1 Personal
Posts: 19

Rep: Reputation: 0
Go here and read this thread , you'll understand whats going on.


http://www.linuxquestions.org/questi...t&pagenumber=1

 
Old 09-16-2004, 04:27 PM   #3
berkay
Member
 
Registered: Mar 2004
Location: TR
Distribution: Gentoo 2004.2
Posts: 100

Rep: Reputation: 15
What error do you get when you cannot boot xp?

-berkay-
 
Old 09-16-2004, 06:32 PM   #4
jrfly
LQ Newbie
 
Registered: Sep 2004
Distribution: Mandrake 10.1
Posts: 16

Original Poster
Rep: Reputation: 0
when I chose windows in lilo boot menu, the screen turned black and a cursor just keeps blinking..
i think i have to change to the right installation of xp to boot, but how...? since my boot loader is lilo..(maybe in xp repair console?)
when a did a dos boot by diskette and typed: fdisk /mbr it danificate both boots..and i fix it rescuing linux from installation..
and how i can create linux and dos boot diskettes..
thanks..

ps: the other same error thread didn't help..but thanks.
 
Old 09-16-2004, 08:55 PM   #5
celticX
Member
 
Registered: May 2004
Location: Northwest Ohio
Distribution: Slackware 10
Posts: 41

Rep: Reputation: 15
could you please post you "lilo.conf" file
 
Old 09-16-2004, 10:03 PM   #6
jrfly
LQ Newbie
 
Registered: Sep 2004
Distribution: Mandrake 10.1
Posts: 16

Original Poster
Rep: Reputation: 0
boot=/dev/hda
map=/boot/map
default="linux"
keytable=/boot/br-abnt2.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda3
initrd=/boot/initrd.img
append="devfs=mount acpi=ht resume=/dev/hda5 splash=silent"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda3
initrd=/boot/initrd.img
append="devfs=mount splash=silent acpi=ht resume=/dev/hda5"
read-only
image=/boot/vmlinuz-2.6.3-7mdk
label="263-7"
root=/dev/hda3
initrd=/boot/initrd-2.6.3-7mdk.img
append="devfs=mount acpi=ht resume=/dev/hda5 splash=silent"
read-only
other=/dev/hda2
label="windows"
table=/dev/hda
other=/dev/hda2
label="windows2"
table=/dev/hda
other=/dev/fd0
label="floppy"
unsafe
image=/boot/vmlinuz-2.6.3-7mdk
label="old_linux-nonfb"
root=/dev/hda3
initrd=/boot/initrd-2.6.3-7mdk.img
append="devfs=mount acpi=ht resume=/dev/hda5"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda3
initrd=/boot/initrd.img
append="failsafe splash=silent acpi=ht resume=/dev/hda5 devfs=nomount"
read-only
other=/dev/hda1
label="old_windows"
table=/dev/hda

but i think i have to change the xp installation in windows ambient, because the problem started after i made a kind of modification in boot.ini apoint to the right installation...
i ussually formmated and install windows and programs for friends and have to change boot.ini to delete those installation of their hd's..
but now i have rewritted mbr in xp rpair console. what should i do?

Last edited by jrfly; 09-16-2004 at 10:13 PM.
 
Old 09-17-2004, 04:24 AM   #7
stab
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Rep: Reputation: 0
I had the same problem.
Changing the hardrive access method to LBA in my bios solved the problem.

I hope this helps.
 
Old 09-17-2004, 12:48 PM   #8
jrfly
LQ Newbie
 
Registered: Sep 2004
Distribution: Mandrake 10.1
Posts: 16

Original Poster
Rep: Reputation: 0
Smile

i really don't know how, but changing it in bios setup solved the principal problem...
in fact there are a lot of things to do, like video, and i can't run any applications says "out of memory"
but i can boot my xp now, and that's what i wanted, because there are a lot of things i have to do before deleting it forever...
thanks all of you for the help!
 
Old 09-18-2004, 12:34 AM   #9
celticX
Member
 
Registered: May 2004
Location: Northwest Ohio
Distribution: Slackware 10
Posts: 41

Rep: Reputation: 15
well first whats wrong with your video? you mean graphics card? are you missing drivers? what card are you running? what is your problem? with the memory though sorry I'm currently unable to help in that area, but I'll try, How much memory do you have on your computer? How big is your swap drive?
 
Old 09-18-2004, 09:48 AM   #10
jrfly
LQ Newbie
 
Registered: Sep 2004
Distribution: Mandrake 10.1
Posts: 16

Original Poster
Rep: Reputation: 0
with linux is everything ok...
the problems are in Xp, so i don't care anymore..because i plan to format windows partiton after back up my data correctly!!
by the way, whats the right size for the swap? i have 512 ram, how can i calculate?! I have 4gB and guessing is so much..
 
Old 09-18-2004, 09:53 AM   #11
celticX
Member
 
Registered: May 2004
Location: Northwest Ohio
Distribution: Slackware 10
Posts: 41

Rep: Reputation: 15
a good rule of thumb is usually double your ram. I have 512 also and created my swap with 1024 It all depends on what you want to do!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems With Dual Boot / Dual Drive Setup Norab Linux - Hardware 1 08-07-2005 10:15 PM
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 02:44 PM
hOw to dual boot linux suse with a dual boot win98/xp pc walterkai SUSE / openSUSE 1 12-14-2004 06:04 PM
dual boot problems, now no boot loader after fixmbr mipia Debian 2 04-04-2004 10:43 PM
Dual boot for Redhat 9 and Solaris 9 boot manager problems steve_2010 Red Hat 1 01-30-2004 10:14 PM


All times are GMT -5. The time now is 08:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration