LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-01-2004, 04:49 PM   #1
maicorider
LQ Newbie
 
Registered: Sep 2004
Posts: 6

Rep: Reputation: 0
Dual Boot problems


Ok, I've read a lot of articles about this, but none seem to have helped, so I'm asking the experts

I've got an older system (Pentium II, 192MG RAM, 2 IDE HDs, 6GB and 8GB).

On HD1, Windows is installed on the only partition (HD0,0). On the second, I have 3 partitions, 3.5GB (root), .5GB(swap), and 4GB (vfat for file storage/sharing between systems).

So I installed Fedora Core 2, putting grub on the 1st partition of the installation, not the MBR. I did the whole dd if=/dev/hdc1 (the second disk is called 'hdc' becasue it's promary on the secong ribbon, CD is slave on 1st ribbon) of=linux.bin bs=512 count=1 command, and then copied it to C:\ and added an entry for it in boot.ini. But when I try booting from that, I get the "GRUB _" (_ flashing) on the screen, and linux doesn't boot. If I install grub to a floppy drive (grub-install /dev/fd0), I can boot to linux from the floppy for awhile until it gives me the "GRUB _" thing again ( i think it stops working if I try to boot from the HD andfail, and then try booting from the floppy again).

So, why on Earth is it booting from the floppy with grub installed, but when I copy the boot sector from hdc and put it on C:\, it won't boot?

Please help

TIA

Eric
 
Old 09-01-2004, 06:52 PM   #2
maicorider
LQ Newbie
 
Registered: Sep 2004
Posts: 6

Original Poster
Rep: Reputation: 0
bump...
 
Old 09-01-2004, 07:08 PM   #3
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well... i think you have to install grub in the MBR of hdb,(and copy that sector ). i had the same kind of problem......but i use lilo. i don't know grub at all. ( maybe try lilo , dunno if it comes with fedora...)

egag
 
Old 09-01-2004, 08:17 PM   #4
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 83
Per the LQ Rules, please do not bump your own thread until at least 24 hours have elapsed without a reply. Because the LQ membership is global, people in other time zones may not have seen this post yet, and thus it may take some time before a response is received.

http://www.linuxquestions.org/rules.php
 
Old 09-01-2004, 10:03 PM   #5
dsegel
Member
 
Registered: Aug 2004
Location: Davis, California
Distribution: Gentoo, always Gentoo.
Posts: 159

Rep: Reputation: 30
It sounds like the copy of grub installed onto /dev/hdc may not be pointing at the proper /boot partition and can't load the grub.conf menu.

Boot from your FC2 install disk, got into rescue mode, and check out the settings (boot partition, kernel image, etc.). There's another post by me a week or two ago that eplains how to do this and reinstall grub.
 
Old 09-02-2004, 12:05 PM   #6
maicorider
LQ Newbie
 
Registered: Sep 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Here is my grub.conf file. I editied one line to point specifically to /dev/hdc1 instead of LABEL=/

Code:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd1,0)
#          kernel /boot/vmlinuz-version ro root=/dev/hdc1
#          initrd /boot/initrd-version.img
#boot=/dev/hdc1
default=1
timeout=10
splashimage=(hd1,0)/boot/grub/splash.xpm.gz
title Fedora Core (2.6.8-1.521)
        root (hd1,0)
        kernel /boot/vmlinuz-2.6.8-1.521 ro root=LABEL=/
        initrd /boot/initrd-2.6.8-1.521.img
title Fedora Core (2.6.5-1.358)
        root (hd1,0)
        kernel /boot/vmlinuz-2.6.5-1.358 ro root=/dev/hdc1
        initrd /boot/initrd-2.6.5-1.358.img
title Other
        rootnoverify (hd0,0)
        chainloader +1
as far as I know this is all right. I have no separate /boot partition, so the paths are right with the /boot/ in front of the kernel, right?

So if this is all right, what else could cause my problem? I can still install grub to the floppy, and boot all kernels from there. So why doesn't it work on my hd?

Last edited by maicorider; 09-02-2004 at 12:06 PM.
 
Old 09-02-2004, 12:36 PM   #7
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
try using this utility to extract the bootsector while you're in winxp, instead of using "dd" in Linux.

When you do it use force lba.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Boot Problems...big problems Goonie Linux - General 19 12-09-2006 05:44 PM
Problems With Dual Boot / Dual Drive Setup Norab Linux - Hardware 1 08-07-2005 10:15 PM
dual boot problems, now no boot loader after fixmbr mipia Debian 2 04-04-2004 10:43 PM
Dual boot for Redhat 9 and Solaris 9 boot manager problems steve_2010 Red Hat 1 01-30-2004 10:14 PM
dual boot problems sgaucho Linux - Newbie 6 03-26-2003 09:11 AM


All times are GMT -5. The time now is 01:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration