LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-03-2005, 03:59 PM   #1
lightcastle
LQ Newbie
 
Registered: May 2005
Posts: 15

Rep: Reputation: 0
Dual boot problem (Ubuntu and mepis)


Hi everyone. I am an utter Linux newb who was tricked into putting Ubuntu for 64-bit on his machine. After a few months of thinking I was an idiot, I realized that 64-bit stuff simply isn't available yet in sufficient quantities to be useful for an average user (despite my techie friends' exhortations). So I went and installed Simply Mepis, which I like, although I find the KDE desktop very busy.

Anyways, I had already partitioned the hard drive when I put Ubuntu on, figuring I might make the machine dual boot in the future. So I easily preserved /home and such, and Mepis installed like a dream.

Except that I can't get to Ubuntu now. Somehow I must have screwed up and made it that the machine doesn't offer me the choice of OS. I have no idea how to fix this, and am hoping there is some simple line that will make the machine offer me the choice again.

Ubuntu is on /hda1, while Mepis is on /hda2. /home is on its own partition, as is the swap.

Any help to be found? (crosses fingers and prepares to sacrifice ducks to the computer gods.)
 
Old 11-03-2005, 07:05 PM   #2
ebsbel
Member
 
Registered: Jun 2005
Posts: 64

Rep: Reputation: 15
What happened is that the boot loader Grub(I think Grub is the option for Mepis) installed in the MBR. All you need to do is to is edit /boot/grub/menu.lst. Add an entry for Ubuntu and restart. An example from my menu.lst:
Code:
title Ubuntu64
        root (hd0,9)
        kernel /boot/vmlinuz root=/dev/hda10 ro quiet splash
        initrd /boot/initrd.img
I have my Ubuntu at /dev/hda10. You need to change 'root (hd0,9)' to 'root (hd0,0)' and 'root=/dev/hda10' to 'root=/dev/hda1'. Then it should work. You can check that the Ubuntu partition has the files that grub is trying to load, /boot/vmlinuz and /boot/initrd.img. otherwise you just change to the right file name.
E
 
Old 11-04-2005, 09:07 AM   #3
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
That is an answer as good as one can get.

The bit that may help is

One can mount Ubuntu partition /dev/hda1 in Mepis (Mepis could have mounted it automatically because that is what is different from others) and see the actual lines lines ubuntu use to boot itself. The file is /boot/grub/menu.lst in hda1. You can cut and paste the 4 relavant lines as indicated by esbel.

As Mepis now control the MBR your editing should be confined to the /boot/grub/menu.lst of hda2.
 
Old 11-04-2005, 05:54 PM   #4
ebsbel
Member
 
Registered: Jun 2005
Posts: 64

Rep: Reputation: 15
That's even more clever!
E
 
Old 12-01-2005, 03:03 AM   #5
lightcastle
LQ Newbie
 
Registered: May 2005
Posts: 15

Original Poster
Rep: Reputation: 0
It is very clever.

Except for one thing. I can't seem to edit menu_lst.


This is what the menu_lst on hda 2 looks like



Quote:
timeout 15
color cyan/blue white/blue
foreground ffffff
background 0639a1
gfxmenu /boot/grub/message

title MEPIS at hda2, kernel 2.6.10
kernel (hd0,1)/boot/vmlinuz-2.6.10 root=/dev/hda2 nomce quiet splash=silent vga=791
initrd (hd0,1)/boot/initrd.splash

title MEMTEST
kernel /boot/memtest86.bin
Over in hda 1 we find this in the menu_lst

Quote:
title Ubuntu, kernel 2.6.10-5-amd64-generic Default
root (hd0,0)
kernel /boot/vmlinuz root=/dev/hda1 ro console=tty0 quiet splash
initrd /boot/initrd.img
savedefault
boot

title Ubuntu, kernel 2.6.10-5-amd64-generic Default (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz root=/dev/hda1 ro console=tty0 single
initrd /boot/initrd.img
savedefault
boot

title Ubuntu, kernel 2.6.10-5-amd64-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.10-5-amd64-generic root=/dev/hda1 ro console=tty0 quiet splash
initrd /boot/initrd.img-2.6.10-5-amd64-generic
savedefault
boot

title Ubuntu, kernel 2.6.10-5-amd64-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.10-5-amd64-generic root=/dev/hda1 ro console=tty0 single
initrd /boot/initrd.img-2.6.10-5-amd64-generic
savedefault
boot

title Ubuntu, kernel memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin
savedefault
boot
So I have 2 questions:

First: Which of those lines should I paste in?

Second: Why is it than when I do paste something in, I get a warning saying I can't edit that file? I suspect it has to do with getting into super user mode, but I tried running KEdit in super user and that accomplished nothing. Maybe I have to log out and log back in as super user? (Mepis appears to not let you just switch into super user mode).

I thought maybe I had to run a text editor from the terminal, but I appear to only have vi, which is impossible to understand for a newbie.

So... any suggestions?
 
Old 12-01-2005, 03:16 AM   #6
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
(1) Log in as root as you need admin privileage to work with system files

(2) Any choice between title and boot, why not cut and the the whole lot (only bits between title and boot are relevant)?
 
Old 12-04-2005, 03:19 AM   #7
lightcastle
LQ Newbie
 
Registered: May 2005
Posts: 15

Original Poster
Rep: Reputation: 0
Well, we've fixed part of the problem

I edited menu_lst to be the following:

Quote:
timeout 15
color cyan/blue white/blue
foreground ffffff
background 0639a1
gfxmenu /boot/grub/message

title MEPIS at hda2, kernel 2.6.10
kernel (hd0,1)/boot/vmlinuz-2.6.10 root=/dev/hda2 nomce quiet splash=silent vga=791
initrd (hd0,1)/boot/initrd.splash

title Ubuntu at hda1, kernel 2.6.10-5-amd64-generic Default
kernel (hd0,0)/boot/vmlinuz root=/dev/hda1 ro console=tty0 quiet splash
initrd (hd0,0)/boot/initrd.splash

title MEMTEST
kernel /boot/memtest86.bin
This resulted in getting 3 options when I rebooted: Mepis kernel 2.6, Ubuntu amd64, and memtest. But when I select Ubuntu it just hiccups into offering me the same 3 again, and doesn't actually load Ubuntu.

Did I put in the wrong one? Should I put in all 4? And if I do, do I include the boot at the end?
 
Old 12-04-2005, 05:02 AM   #8
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Hey comme on, showing off to the whole world your wrong typing?

Where did you get
Quote:
kernel (hd0,0)/boot/vmlinuz root=/dev/hda1 ro console=tty0 quiet splash
initrd (hd0,0)/boot/initrd.splash
for your Ubuntu? Your were showing us it was
Quote:
root (hd0,0)
kernel /boot/vmlinuz root=/dev/hda1 ro console=tty0 quiet splash
initrd /boot/initrd.img
Condensing 3 into 2 lines with (hd0,0) before /boot would have worked if you didn't replaced the .img with .splash in the initrd filename.

Why Can't you do cut and paste? Hightlight text, ctrl+C to copy, move cursor to destination and ctrl+V.

Last edited by saikee; 12-04-2005 at 05:07 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Ubuntu/WinXp dual-boot Ay-Karamba! Linux - General 4 09-08-2005 08:27 PM
Need help fixing boot problem on Ubuntu/WinXp dual-boot Ay-Karamba! Linux - General 5 09-06-2005 10:20 PM
Mepis-friendly linux distros for dual-boot dealerman MEPIS 12 07-13-2005 10:27 PM
XP PRO and Ubuntu Dual Boot Problem kamikazejustin Linux - Newbie 2 04-27-2005 10:13 AM
Dual Boot Mandrake & Mepis pongmaster Linux - Newbie 7 09-04-2004 05:51 PM


All times are GMT -5. The time now is 12:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration