LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-12-2004, 12:20 PM   #1
daenney
LQ Newbie
 
Registered: Jul 2004
Distribution: Debian Squeeze, Ubuntu 10.10, CentOS 5.5
Posts: 8

Rep: Reputation: 0
dual boot, /mnt/hd = 0bytes


Hey
I'm new to Linux, the installation and everything went fine though.
I am using Mandrake 10.0 official with the KDE enviroment.
it's a DUAL-HD system, a Western Digital 10Gb and a Maxtor 40Gb
I have a dual-boot system:
1) 10GB. HD: Win XP Pro NTFS
2) 40GB HD: Linux Mandrake Ext2 + swap (510Mb)

The problem here is that I cannot write to the /mnt/hd directory, or do ANYTHING in that directory, even changing the access rights is impossible. I have also tried it with root privileges, the effect is the same.
When I select the HD and select properties it says that my HD = 0 bytes, although the Ext2 partition is around 37Gb.
When I check this through the "control pannel" it correctly shows HDA = windows and HDB = linux with 510Mb swap and the rest being the HD ext2.

Can anybody tell me what the hell is going on here and how I can fix this.

(Lilo bootloader on floppy)

P.S I can write anywhere else but not on the HD....

Help!!
Thanks....
 
Old 07-12-2004, 01:43 PM   #2
penguin4
Senior Member
 
Registered: May 2004
Location: california
Distribution: mdklinux8.1
Posts: 1,209

Rep: Reputation: 45
daenney; how ever u can go to http://www.ibilio.org/mdw/HOWTO/Bootdisk-HOWTO table of contents 1 thru 12 n appendix,s A-D. it is in detail expanded.
 
Old 07-12-2004, 07:05 PM   #3
daenney
LQ Newbie
 
Registered: Jul 2004
Distribution: Debian Squeeze, Ubuntu 10.10, CentOS 5.5
Posts: 8

Original Poster
Rep: Reputation: 0
Ok sure, but it has nohting to do with the question I asked
I want to know why i can't wrtie to /mnt/hd and why it says that it is empty and that it is 0bytes...

Thanx anyway

P.S it's ibiBlio.org and not ibilio.org

Last edited by daenney; 07-12-2004 at 07:07 PM.
 
Old 07-12-2004, 08:01 PM   #4
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
Post the contents of your /etc/fstab. Problems of this type are most often incorrect options in fstab.

One other thing. Since you are new to Linux, it's necessary to use the mount command to mount a device, if it isn't listed in fstab to mount automatically on boot.

Example: Suppose your fstab mounts the drive ro (read only), you won't be able to write to that drive. If the drive isn't listed in fstab, it won't be mounted, and when you try to look into that drive using your file manager, you won't see anything because it isn't mounted.

The mount command: mount /dev/hdb1 /mnt/hd, or mount /dev/hdb1, or mount /mnt/hd will all mount the first partition of hdb, if it's listed in fstab. It it's not listed, it won't be recognized and you'll get an error message telling you that it isn't a valid device.

The fstab entry should look something like:
/dev/hdb1 /mnt/hd ext2 rw,auto,user 1 1
or /dev/hdb1 /mnt/hd ext2 defaults 1 1
 
Old 07-13-2004, 04:43 AM   #5
daenney
LQ Newbie
 
Registered: Jul 2004
Distribution: Debian Squeeze, Ubuntu 10.10, CentOS 5.5
Posts: 8

Original Poster
Rep: Reputation: 0
This is the /etc/fstab as you asked

/dev/hdb5 / ext2 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom supermount dev=/dev/hdc,fs=udf:iso9660,ro,--,iocharset=iso8859-15 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
/dev/hda1 /mnt/windows ntfs umask=0,nls=iso8859-15,ro 0 0
none /proc proc defaults 0 0
/dev/hdb1 swap swap defaults 0 0
none /mnt/hd supermount dev=/dev/ide/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,kudzu,codepage=850 0 0

From reading this, I get the impression it doesn't mount my second HD, cause it mounts: cdrom, floppy and windows..., but there's no mentioning of the Linux partition hdb5

What's the next step?
Thanx

P.S I've run the mount /dev/hdb5 and /mnt/hd commands, he accepts them, no error message, but nothing else happens...

Last edited by daenney; 07-13-2004 at 04:50 AM.
 
Old 07-13-2004, 06:53 AM   #6
jess1975
Member
 
Registered: Jul 2004
Location: Germany
Distribution: Suse 11.1
Posts: 87

Rep: Reputation: 15
I have the same problem.

I thinks it has something to do with Windows cause it doesn't use 2Mb (at my PIII it was 8Mb) of the harddisk for it's Windows partition. It's pretty annoying and I didn't get rid of it either. I've deleted it from the desktop instead (configure desktop).

Let me know if you've got a solution.
 
Old 07-13-2004, 07:17 AM   #7
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,350

Rep: Reputation: 127Reputation: 127
Quote:
there's no mentioning of the Linux partition hdb5
Oh yes, the first line:
/dev/hdb5 / ext2 defaults 1 1 This is the root-directory of your Linux.

You shouldn't be able to write to the Windows-partition, or does Mdk 10 ship with write-support on NTFS?

But to your question: I don't think there's really anything wrong. The 'supermount'-feature mounts the partition when you access the directory where it's to be mounted. However, using Mdk 9.1 I've noticed that a disc mounted by supermount doesn't show up with 'du'. If you can access it, read & write I don't think there's anything to bother about.
I don't understand the filesystem-setting though?
Quote:
dev=/dev/ide/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,kudzu,codepage=850 0 0
fs=ext2:vfat ???
 
Old 07-13-2004, 06:22 PM   #8
sbohning
LQ Newbie
 
Registered: Jun 2004
Location: SF Bay area
Distribution: Mandrake 10 partial, Debian next
Posts: 4

Rep: Reputation: 0
The "fs=ext2:vfat" tells supermount to try those filesystem formats; (default is "auto".

See good tutorial on mounting and supermount at
http://www.start-linux.com/articles/article_168.php

and supermount README at
http://sourceforge.net/docman/displa...group_id=79609

You might try disabling supermount and/or changing fstab entries to do without supermount (but save a copy of old fstab), per bigrigdriver's post.

Not sure how this would affect KDE, though. You might try booting without KDE GUI first to see if the drive is accessible from a plain shell.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 02:44 PM
uploads 0bytes Master Fox Programming 6 01-17-2005 05:07 AM
i changed /mnt/cdrom to /mnt/CD-RW - now i've got a problem?!?! spyghost Linux - Software 7 09-30-2003 03:06 PM
/mnt/cdrom & /mnt/scd0 locks up machine RIgimp75 Mandriva 7 09-01-2003 10:32 PM
mount -t //192.168.0.1/mnt /mnt/windows -o password='' generates error broadsoft Linux - Networking 3 08-07-2003 05:51 AM


All times are GMT -5. The time now is 04:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration