LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-08-2006, 05:15 PM   #1
caleb705
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Rep: Reputation: 0
Thumbs up Dual Boot MBR problems


I recently decided to switch over to a dual boot between XP and FC 5, since I am required to use Unix based machines a lot for my work. I bought a second HD because I needed the space and thought I could put FC on it as well. I have been able to install it fine, but Grub won't open up when I am trying to boot linux, so I can't ever boot into linux. I have heard maybe that it is because my boot drive is not on the same drive as the MBR, is that true? If so any suggestions as to how to resize the c: partition that XP is on, without spending 50 bucks on software. I have tried to both load grub into the MRB and the first sector of the second HD, however every time i tried to reload it, it bypassed grub and went straight to windows.
 
Old 10-08-2006, 05:51 PM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Possibly - ideally, for dual-boot, grub should come up every time. The grub menue would give you the option to boot to either OS.

How have you tried to place GRUB into the MBR? (i.e. did you try at install?)

Have you set fedora (or windows) as the default OS?

Personally, I've had no trouble dual booting windows and fedora, where fedora is entirely on hdb and windows entirely on hda. I have always placed grub in mbr of hda and selected fedora as the default.
 
Old 10-08-2006, 05:54 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,186

Rep: Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953
Quote:
Originally Posted by caleb705
I have heard maybe that it is because my boot drive is not on the same drive as the MBR, is that true?
No.
Quote:
I have tried to both load grub into the MRB and the first sector of the second HD, however every time i tried to reload it, it bypassed grub and went straight to windows.
The BIOS will always use the first (valid) MBR it finds. The Fedora installer seems deficient - from others who have posted similarly.You have 3 choice (in order of ease of use/maintenence);
- install grub to the MBR of your Windows disk (by far the best option)
- change the boot disk in the BIOS. Grub may have a valid entry for Windows - maybe not (see comment above re Fedora).
- use the Windoze loader to load the grub boot sector record. Redhat used to have paper(s) on how to do this. Plenty of threads here.
 
Old 10-09-2006, 01:08 PM   #4
caleb705
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by syg00
No.The BIOS will always use the first (valid) MBR it finds. The Fedora installer seems deficient - from others who have posted similarly.You have 3 choice (in order of ease of use/maintenence);
- install grub to the MBR of your Windows disk (by far the best option)
- change the boot disk in the BIOS. Grub may have a valid entry for Windows - maybe not (see comment above re Fedora).
- use the Windoze loader to load the grub boot sector record. Redhat used to have paper(s) on how to do this. Plenty of threads here.
I have tried each of these suggesionts and none of them worked. The first booted right to windows without loading grub, the second wouldn't load windows, and the third it wouldn't allow me to map it too anything other than a windows install.

Could it be because I am trying to use the 64 bit version of fedora rather than the 32 bit?
 
Old 10-09-2006, 01:35 PM   #5
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Quote:
- use the Windoze loader to load the grub boot sector record. Redhat used to have paper(s) on how to do this. Plenty of threads here.
Does that mean the same thing as creating an "image" of the Linux boot partition, placing it on the Windows' harddisk and adding an entry to Windows' bootloader? It would, if I understood you correctly..though I'm not sure if grub is needed in that processa at all?
 
Old 10-09-2006, 01:59 PM   #6
IndyGunFreak
Senior Member
 
Registered: Aug 2003
Location: Indpls
Distribution: Laptops: Debian Jessie XFCE, NAS: OpenMediaVault 3.0
Posts: 1,355

Rep: Reputation: 70
Quote:
Originally Posted by caleb705
I have tried each of these suggesionts and none of them worked. The first booted right to windows without loading grub, the second wouldn't load windows, and the third it wouldn't allow me to map it too anything other than a windows install.

Could it be because I am trying to use the 64 bit version of fedora rather than the 32 bit?
Are you sure you're putting it in the Master Boot Record? I ask, because I thought I was to when I was having this problem with FC5. Here's what I would suggest. Use your XP disk to run the FixMBR and FixBoot commands.

This may not be what you want to hear, but here's what I did.

http://www.tech-recipes.com/windows_...n_tips483.html - Do the same thing to run Fixboot, just change the command obviously.

Re-install FC5. When it comes time to install the bootloader. Choose "Advanced" options(or something like that, may be Expert also), and it will then go to another screen asking where to install the bootloader. Choose the MBR from there and install the bootloader.

When I done the above, Grub loaded no problem.

IGF
 
Old 10-09-2006, 05:13 PM   #7
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,186

Rep: Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953Reputation: 1953
Quote:
Originally Posted by caleb705
I have tried each of these suggesionts and none of them worked. The first booted right to windows without loading grub, the second wouldn't load windows, and the third it wouldn't allow me to map it too anything other than a windows install.
Depends on your definition of "not worked" - at least we now have some more info.
As suspected, Anaconda seems to install the loader to the MBR of the second disk - see my comment re the deficiency of the installer.
Maybe you can coerce it to use the correct MBR via expert mode - I don't know as I refuse to use any of the Redhat derivatives.

As for FC not booting Windoze, again that is a shortcoming of the installer - easily rectified. Change the BIOS, boot FC, edit /boot/grub/menu.lst, and add the following two lines to the Windows entry, before to the chainloader line
Code:
map (hd0) (hd1)
map (hd1) (hd0)
(you need to be careful to include the blanks)
Quote:
Originally Posted by b0uncer
Does that mean the same thing as creating an "image" of the Linux boot partition, placing it on the Windows' harddisk and adding an entry to Windows' bootloader? It would, if I understood you correctly..though I'm not sure if grub is needed in that processa at all?
Almost - the "image" is one sector, not the whole boot partition.
That sector is the boot sector record, and is created by a multiboot compliant loader - that means generally lilo or grub. And yes you do need one of the loaders installed - you can't just reference the kernel image directly without one.
 
Old 10-09-2006, 05:31 PM   #8
caleb705
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
As suspected, Anaconda seems to install the loader to the MBR of the second disk
I installed the MBR to the windows disk, and then I checked the MBR of both disks and grub actually wasn't loaded on either for some reason.

Quote:
As for FC not booting Windoze, again that is a shortcoming of the installer - easily rectified. Change the BIOS, boot FC, edit /boot/grub/menu.lst, and add the following two lines to the Windows entry, before to the chainloader line
when I did this, with the MBR loaded on the second disk, I could load fedora fine, but it didn't recognize windows as being on the C: drive.

I also editted the windows boot loader and that gave me an arror that a windows file was corrupt, and that I had to do a complete windows reinstall.

I am thinking that maybe the installer is corrupt or something like that so I think I might try a different distro, as I'm not real attached to Fedora, any suggestions? I am thinking maybe suse.

Last edited by caleb705; 10-09-2006 at 05:33 PM.
 
Old 10-10-2006, 05:45 AM   #9
IndyGunFreak
Senior Member
 
Registered: Aug 2003
Location: Indpls
Distribution: Laptops: Debian Jessie XFCE, NAS: OpenMediaVault 3.0
Posts: 1,355

Rep: Reputation: 70
Quote:
Originally Posted by caleb705
I am thinking that maybe the installer is corrupt or something like that so I think I might try a different distro, as I'm not real attached to Fedora, any suggestions? I am thinking maybe suse.
Ubuntu 6.06(Dapper Drake), or if you prefer the KDE interface, Kubuntu. I personally hate the KDE interface, and have found everything below quite useful for Ubuntu. I'm fairly certain everything below should work with Kubuntu, although you may have to modify the instructions slightly on what menu to select.

This will tell you how to do almost everything under Linux Ubuntu.

https://wiki.ubuntu.com/Home?action=...rect=FrontPage

If you can't find something on Synaptic, here's a boatload of packages..

http://packages.ubuntu.com/dapper/allpackages

There's also a program called Automatix, which makes installing several programs as easy as point and click.

http://www.getautomatix.com/

You can try to overwrite Grub with an Ubuntu install, but I'd recommend clearing your master boot record and then running the install.

Insert a Windows disk, restart, Press R for a repair installation, when you get to the DOS prompt, type FIXMBR, then enter. You'll get a warning, choose to continue, restart the computer and remove Windows Disk. I'd also run the FIXBoot command from here.

IGF

Last edited by IndyGunFreak; 10-10-2006 at 05:50 AM.
 
Old 10-11-2006, 08:45 PM   #10
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
This is good advise - I'd like to second the Ubuntu suggestion here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to dual boot without using MBR royeo Linux - Newbie 4 09-11-2006 07:22 PM
dual boot mbr grub problems Xris718 Linux - General 4 08-09-2006 06:52 PM
problem with MBR / dual boot AdmiralFreezbee Linux - Newbie 11 03-31-2005 03:19 AM
MBR help dual boot xp and fc2 theconfused Fedora 7 09-03-2004 05:00 PM
Dual boot without touching the MBR? senectus Linux - Newbie 4 07-14-2003 09:17 AM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration