LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-05-2006, 09:50 PM   #1
hferretluv
Member
 
Registered: Sep 2005
Location: Washington state
Distribution: fedora core 9 i386 - x86
Posts: 44
Blog Entries: 1

Rep: Reputation: 15
Dual Boot Machine Fedora 5 / WinXP, XP messes up the IP addressing


I have a dual boot machine with FC 5 and also WinXP. When first installed, FC5 login screen shows the Correct IP address/Computer name.

Now, many of the linux programs I have installed depend on the IP address/computer name not being changed. When forced to occassionly use the WinXP, it is NOT possible to set the FULL IP address/name.

Then back to Fedora linux bootup time after having been on windows, and the fun begins. All of the sudden, the programs that depend on the accurate IP and names no long can find the correct info because winXP changed IP and names. Usually truncating or changing it completely.

Clamav depends on adresses that do not change. So do some of the other programs installed on the linux side. Is there some way to correct this from happening or preventing winXP from screwing things up?

Please help, and thank you for any help that can be given.
 
Old 05-06-2006, 09:27 AM   #2
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 393

Rep: Reputation: 47
Setup a static ip address under Linux and Windows? For example, 192.168.0.2 for both. That way it will never change.
 
Old 05-06-2006, 10:11 AM   #3
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
I have never heard of a function of XP that can affect the Linux system on the same box. Something is going on with the network.

How are you connected to the network? That is, are you connected to a DSL or cable modem directly or through a router, or are you using dial-up?

If you are on a router, is it set to provide an IP address (DHCP), or are you using a fixed IP?

How are you checking the name of the computer in Linux? My /etc/hosts file has the following in it:

127.0.0.1 chuck.cfgaf.com chuck

Try this:

cat /etc/hosts | grep 127

See what you get.

Good luck

C
 
Old 06-06-2006, 09:35 PM   #4
hferretluv
Member
 
Registered: Sep 2005
Location: Washington state
Distribution: fedora core 9 i386 - x86
Posts: 44
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Dual Boot Machine Fedora 5 / WinXP, XP messes up the IP addressing

Quote:
Originally Posted by Glennzo
Setup a static ip address under Linux and Windows? For example, 192.168.0.2 for both. That way it will never change.
First, apologies to all for taking so long to get back to you.

Do you mean that I can or should select any arbitray ip address?
'Cuz windows has a limit for the size of the machine name.
 
Old 06-06-2006, 09:47 PM   #5
hferretluv
Member
 
Registered: Sep 2005
Location: Washington state
Distribution: fedora core 9 i386 - x86
Posts: 44
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Dual Boot Machine Fedora 5 / WinXP, XP messes up the IP addressing

Quote:
Originally Posted by lotusjps46
How are you checking the name of the computer in Linux? My /etc/hosts file has the following in it:

127.0.0.1 chuck.cfgaf.com chuck

Try this:

cat /etc/hosts | grep 127

See what you get.

C
Thankyou all for your help.

This is what I got when I grepped it.

[harold@71-227-184-165 ~]$ cat /etc/hosts | grep 127
127.0.0.1 localhost.localdomain localhost
127.0.0.1 c-71-227-184-165.hsd1.or.comcast.net


I have it set up as computer/ethernet to cable modem, to the internet. Using seamonkey browser. Setup is 'DHCP' But the cable company does not change that true IP address.

But windows rewrites parts of clamav, amavisd, http, and a few others and then the startup is royally screwed up. Because suddenly fedora can not find the localhost.localdomain so it assigns the changes that windows assigned in the mbr


Harold
 
Old 06-08-2006, 03:01 AM   #6
riizikaz
LQ Newbie
 
Registered: Jun 2006
Posts: 2

Rep: Reputation: 0
i heard that some other peoples are having similar problem with ethernet. and their solution was that do not restart your computer when switching op systems, instead shutdown the pc and then run the op sys you want.
 
Old 06-08-2006, 04:27 AM   #7
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
It's nearly impossible for Windows to rewrite parts of clamav, .... It might reformat your whole Linux partition by accident.

Maybe Windows sets certain registers in your network card and without a power cycle they may still be there when you boot Linux. This might even be a Linux driver bug (not resetting stuff to a known state).
As said by riizikaz, shutdown the machine before switching to Linux. If that does not help, powercycle. If that does not help, come back here.

Can you indicate what exactly changes? IP address? Hostname? clamav configuration file? etc etc etc

You use dhcp. Don't take for granted what the ISP says. Check the IP address after a boot to linux with the command ifconfig. Next boot to windows and check the address with ipconfig. Next back to Linux and check again.
Does the address change?
 
Old 06-08-2006, 05:55 PM   #8
hferretluv
Member
 
Registered: Sep 2005
Location: Washington state
Distribution: fedora core 9 i386 - x86
Posts: 44
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Dual Boot Machine Fedora 5 / WinXP, XP messes up the IP addressing

Quote:
Originally Posted by Wim Sturkenboom
It's nearly impossible for Windows to rewrite parts of clamav, .... It might reformat your whole Linux partition by accident.

Maybe Windows sets certain registers in your network card and without a power cycle they may still be there when you boot Linux. This might even be a Linux driver bug (not resetting stuff to a known state).
As said by riizikaz, shutdown the machine before switching to Linux. If that does not help, powercycle. If that does not help, come back here.

Can you indicate what exactly changes? IP address? Hostname? clamav configuration file? etc etc etc

You use dhcp. Don't take for granted what the ISP says. Check the IP address after a boot to linux with the command ifconfig. Next boot to windows and check the address with ipconfig. Next back to Linux and check again.
Does the address change?

Have already tried the power off and then switch to the next os. Even to the point of leaving the computer power cord unplugged from the wall. That works sometimes.

What gets changed is some of the entries in .conf files for some and then some of the bootup files for others. Linux is booting, loading, and then says can not find address < original address > using 127.0.0.0 instead. And then several programs start NOT functioning correctly. Will try some of the other suggestions and let you know what happens.
 
Old 06-09-2006, 03:44 AM   #9
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
As said, first verify IP address after each boot. I have a dual boot here in an (MS) network. Under Windows, it always gets the samne address from the DHCP server. Under Linux it varies, usually the same as under windows but recently I had an occasion where that was not the case.
 
Old 06-09-2006, 01:57 PM   #10
Bobymc
Member
 
Registered: Apr 2006
Location: INDONESIA
Distribution: SLAX,Damn S.L,Suse,Mandrake,Rd HAT62,72,73,90, Mandriva2k6, FEdora, SUNmicrosys.
Posts: 269

Rep: Reputation: 30
Quote:
Originally Posted by Wim Sturkenboom
Maybe Windows sets certain registers in your network card and without a power cycle they may still be there when you boot Linux. This might even be a Linux driver bug (not resetting stuff to a known state).
As said by riizikaz, shutdown the machine before switching to Linux. If that does not help, powercycle. If that does not help, ?
I have 7 OS on my single HDD.(one of 'em is window)

took me days to examine the CONF

At FEDORA v1 time I found out that I loose 3c940 module after reboot. Could be win messing the hardware.

I havent found any problem since.

Dunno later.....
 
Old 06-12-2006, 09:21 PM   #11
hferretluv
Member
 
Registered: Sep 2005
Location: Washington state
Distribution: fedora core 9 i386 - x86
Posts: 44
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Dual Boot Machine Fedora 5 / WinXP, XP messes up the IP addressing:

windows shows this:

windows ip configuration

Ethernet adapter Local Area connection:

Connection-specific DNS Suffix . : hsd1.wa.comcast.net

IP Address . . . . . . . . . . . : 71.227.184.165

Subnet Mask. . . . . . . . . . . : 255.255.254.0

Default Gateway. . . . . . . . . : 71.227.184.1

This was the same all three times, but it did change the machine name on the last two cycles.

Absolute Off was also tried but gave same results


On the fedora Core 5 linux side this is what was given after command of ifconfig:

eth0 Link encap:Ethernet HWaddr 00:0D:61:31:0D:2D
inet addr:71.227.184.165 Bcast:255.255.255.255 Mask:255.255.254.0
inet6 addr: fe80::20d:61ff:fe31:d2d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:27618 errors:0 dropped:0 overruns:0 frame:0
TX packets:511 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5904936 (5.6 MiB) TX bytes:70628 (68.9 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3462 errors:0 dropped:0 overruns:0 frame:0
TX packets:3462 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3519196 (3.3 MiB) TX bytes:3519196 (3.3 MiB)


primary DNS: 68.87.69.146
secondary DNS: 68.87.85.98

The upper two lines showed up on restarts 2 and three, and windows had changed the computer's name
AGAIN.

This is so frustrating. I may back up somestuff, strip the drive and reinstall it again.
 
Old 06-13-2006, 12:47 AM   #12
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Your IP-address does not change, so that's a good thing (it also excludes a possible Linux bug). How do you check your computername in Linux?

Suggestions to solve the problem
1)
Configure all your programs to use the ip-address and not a computername.

or

2)
Add an entry in the file /etc/hosts
Code:
71.227.184.165 your_desired_computername
and configure the applications to use that name. If a program tries to resolve a computername, one of the places where it will look is in /etc/hosts and it will then use the associated IP-address.

PS 1)
The computername is something that's stored somewhere 'in the OS'. In linux it's stored in /etc/HOSTNAME (as far as I can figure out). In windows, it's probably somewhere in the registry (not sure).

PS 2)
I still don't believe that Windows changes it in Linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Boot Machine, WinXP on SATA, Slack on IDE Poindexter Slackware 8 03-05-2006 07:31 AM
Dual-boot with CentOS or Fedora and WinXP Dmjmusser Red Hat 1 02-17-2006 03:38 PM
dual boot messes with clock linuxhippy Fedora 3 07-31-2005 11:08 PM
Why not BOOT?(Fedora dual with winXP) maxali207 Linux - Newbie 11 06-07-2005 03:26 PM
Installing Mandrake9.2 on a Fedora winxp dual boot machine dhanakom Mandriva 2 07-04-2004 10:24 AM


All times are GMT -5. The time now is 11:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration