LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-17-2011, 01:08 PM   #1
Tripsun
LQ Newbie
 
Registered: Jan 2011
Distribution: Arch Linux
Posts: 22

Rep: Reputation: 0
Dual boot Lilo won't load Windows [SOLVED]


Hi everyone,

Just installed Slackware 13.37 and am trying to get dual boot to work properly. I have edited /etc/lilo.conf to point the Windows section to what I believe should be the correct partition (/dev/sda2)

Here is the relevant section
Code:
# LILO configuration file
# Windows bootable partition config begins
other = /dev/sda2
  label = Windows
  table = /dev/sda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda6
  label = Linux
  read-only
# Linux bootable partition config ends
I have mounted /dev/sda2 to /ntfs-c as suggested during install and when I browse through there I see the files from my windows setup so it is in fact the correct partition. When I load Windows on boot, however, it is pointing to the recovery partition (/dev/sda1). Any ideas? I am sure it is an easy fix somewhere.

Thanks!

Last edited by Tripsun; 05-17-2011 at 01:09 PM.
 
Old 05-17-2011, 01:17 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
After editing the lilo config file, you need to run (as root) /sbin/lilo to make the changes take effect.

Here is an article on configuring lilo:http://www.control-escape.com/linux/lilo-cfg.html

Last edited by bigrigdriver; 05-17-2011 at 01:18 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lilo won't load windows FAT partions not recognized anotherpenguin Linux - Newbie 9 11-16-2008 10:40 AM
Dual Boot RHEL 5.1 and WinXP, won't load Windoze caspianhiro Linux - Newbie 3 12-11-2007 03:35 PM
Grub won't load on dual boot with XP DuuhMojo Linux - Newbie 4 06-10-2005 04:07 PM
Solved: Suse 9.3 dual boot with Windows talLinux SUSE / openSUSE 2 05-22-2005 06:41 AM
My Linux Mandrake won't load on Dual Boot with XP bodderz Linux - Newbie 6 07-21-2004 09:45 AM


All times are GMT -5. The time now is 10:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration