LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-06-2002, 11:13 AM   #1
sadia
LQ Newbie
 
Registered: Dec 2002
Location: New Jersey
Distribution: Red Hat
Posts: 7

Rep: Reputation: 0
Angry dual boot


I have a 80gb hard drive. I partitioned and made 2 40gb parts.
I installed xp on the first part. All went well. I then installed Redhat 7.0 on the second part. I did a server config and manually created my part giving making the mount point / and giving it 36000 mb I that was created on /dev/hda2. I made my swap file 500md and continued with the install. all went well, I rebooted and then upgraded to install lilo and I installed it on the MBR and it recognized xp. After the install I removed the disk and rebooted and got a "missing operating system" Can anyone please help and tell me what I need to do to get both xp/linux in the lilo boot.

I can boot to linux usingthe boot disk but without I can't boot to is, and I can boot to xp if I make that the active partition. what do I need to do to correct this problem?
 
Old 12-06-2002, 11:32 AM   #2
then
Member
 
Registered: Oct 2002
Location: FDR India
Distribution: RH9, Knoppix, MEPIS
Posts: 65

Rep: Reputation: 15
1. "I rebooted and then upgraded to install lilo" -
* what do you mean by this?
* what did you upgrade?
IMHO lilo is installed before the first reboot, so you don't have to install lilo again...unless you chose not to install any bootloader while installing RedHat
2. "missing operating system" - are you able to boot into XP? Do you have any Anti-Virus software monitoring your MBR?
3. Is XP on FAT32 or NTFS?
4. Could you please post the content of your /etc/lilo.conf file
5. Is LBA mode ON for your hard disk in the BIOS?

Regards
theN
 
Old 12-06-2002, 12:33 PM   #3
sadia
LQ Newbie
 
Registered: Dec 2002
Location: New Jersey
Distribution: Red Hat
Posts: 7

Original Poster
Rep: Reputation: 0
dual boot

XP is on Fat 32 ..... how do look at the lilo config ? and I reinstalled redhat without "upgrading" and I still have the same problem
 
Old 12-06-2002, 12:43 PM   #4
sadia
LQ Newbie
 
Registered: Dec 2002
Location: New Jersey
Distribution: Red Hat
Posts: 7

Original Poster
Rep: Reputation: 0
one more thing when I do a /sbin/lilo I get a Warning message device 0x0302 exceeds 1024 cylinder limit Fatal: sector 83135313 too large for linear mode (try 'lba32' instead) and whe i do a /etc/lilo.conf at the root I get a bash: /etc/lilo.conf : Permission denied
 
Old 12-06-2002, 01:56 PM   #5
jglen490
Member
 
Registered: Apr 2002
Location: The next brick house on the right.
Distribution: Kubuntu 8.04
Posts: 668

Rep: Reputation: 31
Quote:
... whe i do a /etc/lilo.conf at the root I get a bash: /etc/lilo.conf : Permission denied
Are you trying to execute lilo.conf?

That file is the configuration file and you need to use an editor (vi, jed, joe, pine, etc.) to make any changes to to it. Then after you make the changes then you run, as root:

lilo -v
 
Old 12-06-2002, 02:29 PM   #6
sadia
LQ Newbie
 
Registered: Dec 2002
Location: New Jersey
Distribution: Red Hat
Posts: 7

Original Poster
Rep: Reputation: 0
dual boot

I am only trying to view what the config is set at to see why I cant boot directly to linux without the boot disk
 
Old 12-06-2002, 03:02 PM   #7
then
Member
 
Registered: Oct 2002
Location: FDR India
Distribution: RH9, Knoppix, MEPIS
Posts: 65

Rep: Reputation: 15
Quote:
one more thing when I do a /sbin/lilo I get a Warning message device 0x0302 exceeds 1024 cylinder limit Fatal: sector 83135313 too large for linear mode (try 'lba32' instead) and...
LILO has a problem seeing Linux's /boot partition if /boot parition is located after the 8.1GB point on the disk. In your case it seems to be so. Since your install seems to be new you could try this -

Go to your BIOS before any OS boots and enable LBA mode for your hard disk. In most BIOSes this option would be under the top left menu item.

After you enable LBA install RedHat again. During the RedHat installation lookout for a CHECKBOX about wanting LBA mode. SELECT the checkbox to enable LBA.
Quote:
whe i do a /etc/lilo.conf at the root I get a bash: /etc/lilo.conf : Permission denied
Type ls -al lilo* when you are in the /etc folder, you'll see that lilo.conf is owned by the root.

To view lilo.conf you first have to become the root by typing su -, they type the root's password. If you give the correct password your command prompt changes from $ to #. Then type vi /etc/lilo.conf. Then that will display the lilo.conf file.

IMHO your problem seems be that of LILO not being able to see the Linux /boot partition, since the /boot located beyond 8.1GB. The most viable solution seems to be to enable LBA mode and install RedHat again.

HTH & best of luck
theN
 
Old 12-06-2002, 03:56 PM   #8
sadia
LQ Newbie
 
Registered: Dec 2002
Location: New Jersey
Distribution: Red Hat
Posts: 7

Original Poster
Rep: Reputation: 0
dual boot

Thanx I will give it a try and see what happens.....I have a MSI Motherboard so I have to see where the lba is in the bios
 
Old 12-07-2002, 07:26 AM   #9
sadia
LQ Newbie
 
Registered: Dec 2002
Location: New Jersey
Distribution: Red Hat
Posts: 7

Original Poster
Rep: Reputation: 0
dual boot

upon examining my bios I discovered that when I went to set the LBA it was already turned on..............So the problem still exists :-(
 
Old 12-07-2002, 10:04 AM   #10
then
Member
 
Registered: Oct 2002
Location: FDR India
Distribution: RH9, Knoppix, MEPIS
Posts: 65

Rep: Reputation: 15
Hi

Sorry for the late response...power outage.

Thats cool , now all you got to do is to CHECK the LBA mode checkbox while installing RedHat. I think you get that checkbox just before paritioning or just before installing LILO (not sure which). Do lookout for it.

Let us know how things go.

Regards & best of luck
theN
 
Old 12-10-2002, 10:45 PM   #11
sadia
LQ Newbie
 
Registered: Dec 2002
Location: New Jersey
Distribution: Red Hat
Posts: 7

Original Poster
Rep: Reputation: 0
Dual Boot

I did what everyone told me to do and that didnt' work. however what I did was create a 2gb partion for the instal on the first 1024 cylinders and a 650mb swap file on the begining of the partition and I move windows back a bit with partiton magic. All went well on the install now I can dual boot both systems. However I have a new problem .....Now when I log in and I get the prompt for the login I put in the username I created and the password I created and I can't log in, and I have reinstalled 3x
s just to make sure I put the correct username and password in and I still can't log in. I have a the root on the 2gb partition as I stated earlier and I created a /usr on the partion after window could this be a problem ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems With Dual Boot / Dual Drive Setup Norab Linux - Hardware 1 08-07-2005 09:15 PM
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 01:44 PM
hOw to dual boot linux suse with a dual boot win98/xp pc walterkai SUSE / openSUSE 1 12-14-2004 05:04 PM
Advice (and some) Needed: Dual-HDD, Dual-Boot - Linux, WinXP elnomadkvn Linux - General 1 03-28-2004 10:11 AM
Newbie needs Mandrake/Win98 dual-HD, dual boot system design help... buddha Linux - Newbie 20 09-04-2003 08:57 PM


All times are GMT -5. The time now is 01:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration