LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-15-2008, 04:12 AM   #1
mariochaves
LQ Newbie
 
Registered: May 2008
Posts: 3

Rep: Reputation: 0
DSL linux lsusb shows nothing whrn usb connected


I can not ¨mount¨ drive or anithing else since my DSL regconize no USB drives, Can someone help me please
 
Old 05-16-2008, 01:10 PM   #2
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
Welcome to LQ!

Hmh ... based on information you've supplied I'd say something is wrong.

0. What do you have in mind saying does not recognize USB drives, no device nodes created in /dev? Is that what you mean? What is lsmod output?
1. Open a terminal , su to root and run tail -f /var/log/messages, then connect the drive. What the system tells you?
 
Old 05-17-2008, 12:52 AM   #3
mariochaves
LQ Newbie
 
Registered: May 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Smile USB not regconized

Thanks for the reply, Im really appreciate your help!

When I say NOT REGCONIZED I mean the usb flash drive seems to be like unplugged, I mean there is not sign of USB geting even power.

this is a brand new motherboard,I have tried usb devices using other OS, and all of them work fine, now I installed DSL linux and when I plug a USB flash drive, nothig happen, the USB KEy led does not turn on, and when I run LSUSB there is no device listed all of the entries shows 00000:00000

it is not a problem mounting the drive I think, it should be something before that

I hope there is some tipyou can provide

Thanks


Mario
 
Old 05-17-2008, 08:10 AM   #4
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
Since you didn't provide information requested all I can do is to show you how it should work. Below is the list of my USB controllers.
Code:
lspci | grep USB
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
Kernel modules loaded for USB:
Code:
lsmod
Module                  Size  Used by
...
ehci_hcd               30348  0 
uhci_hcd               21336  0 
...
As you see I have UHCI and EHCI devices and appropriate modules loaded.
 
Old 05-27-2008, 04:58 PM   #5
OWA14
LQ Newbie
 
Registered: May 2008
Posts: 4

Rep: Reputation: 0
Hi, I have the same problem, my usb controllers are all there, yet the two kernel modules aren't
 
Old 05-27-2008, 05:03 PM   #6
OWA14
LQ Newbie
 
Registered: May 2008
Posts: 4

Rep: Reputation: 0
Nevermind, I just don't know how to cd a usb
 
Old 05-28-2008, 11:36 PM   #7
mariochaves
LQ Newbie
 
Registered: May 2008
Posts: 3

Original Poster
Rep: Reputation: 0
USB not regconized

I apologyze I din not reply before,
My system is working now
what I needed to chage was some option on GRUB menu before booting
I added:
noapic nolapic pci=coacpi

It really fix the problem, I dont know how it really works, but when I changed those settings the lsusb command started shwoing my usb devices,
after that I just used MOUNT command and I use a script to obtain an ¨automounting¨ feature for my propuses it worked
I hope this info could be helpful for someone else
thanks for all uour help

this forum is the best!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB-Scanner not detected with lsusb PGPGPG Linux - Hardware 0 09-09-2006 11:29 AM
Webcam: lsusb shows nothing and no /proc/bus/usb/devices stevesk Linux - Hardware 8 08-02-2006 03:03 AM
USB Device listing in lsusb Jayaraghavendran Linux - Hardware 7 06-30-2006 02:52 AM
lsusb shows nothing RVDowning Mandriva 33 04-18-2006 03:03 PM


All times are GMT -5. The time now is 01:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration