LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-23-2008, 10:32 AM   #1
tbaror
Member
 
Registered: Apr 2006
Posts: 35

Rep: Reputation: 0
Drop packet on eth1


Hello,

i am having drop packet appearing on eth1 status (Linux rPath) which is ISCSI adapter.
eth1 nic is intel GT 32bit adapter
Device Received Sent Err/Drop
lo 0.55 KB 0.55 KB 0/0
eth0 5.12 MB 7.43 MB 0/0
eth1 7.56 GB 10.08 GB 0/12091

i am suspecting that the auto negotiate is the one causing those drops, i am trying to set it "autoneg off" via ethtool with no successes, since i dont have much of Linux experience if i can get help for set it correctly \

Thanks

Code:
root@localhost ~]# ethtool -s eth1 speed 1000 duplex full autoneg off
Cannot set new settings: Invalid argument
  not setting speed
  not setting duplex
  not setting autoneg
 
Old 11-23-2008, 10:49 AM   #2
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Hmm, I think that your system would be using the e1000 module.
You can pass parameters to the module to change the duplex:
Code:
    * modprobe e1000 AutoNeg=0x01 (Restricts autonegotiation to 10 Half)
    * modprobe e1000 AutoNeg=1 (Same as above)
    * modprobe e1000 AutoNeg=0x02 (Restricts autonegotiation to 10 Full)
    * modprobe e1000 AutoNeg=0x03 (Restricts autonegotiation to 10 Half or 10 Full)
    * modprobe e1000 AutoNeg=0x04 (Restricts autonegotiation to 100 Half)
    * modprobe e1000 AutoNeg=0x05 (Restricts autonegotiation to 10 Half or 100 Half)
    * modprobe e1000 AutoNeg=0x020 (Restricts autonegotiation to 1000 Full)
    * modprobe e1000 AutoNeg=32 (Same as above)
You should be able to add one of these parameters in your modprobe.conf or modules.conf
 
Old 11-23-2008, 10:55 AM   #3
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,580
Blog Entries: 14

Rep: Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969
Your command is syntactically correct.

It is telling you it can't set this interface the way you've requested. I was under the impression that GigE ethernet had to use autonegotiate using the full speed (1000).

Are you sure this is a GigE network card? It may simply be that the card you're using doesn't support speed 1000.

Run "ethtool eth1" and check the output. It should show you which modes are supported.
 
Old 11-23-2008, 11:11 AM   #4
tbaror
Member
 
Registered: Apr 2006
Posts: 35

Original Poster
Rep: Reputation: 0
Hi
first in which path i can find modprobe.conf or modules.conf

second this result of ethtool eth1
thanks

ethtool eth1
Settings for eth1:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: umbg
Wake-on: g
Current message level: 0x00000007 (7)
Link detected: yes
 
Old 11-23-2008, 11:21 AM   #5
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Depending on your system ... /etc

Though on some distributions the /etc/modprobe.d/ or /etc/modules.d/ directory is used to hold special files to set module parameters.

I am assuming your ethernet driver is modular, and that it is the e1000 module.
You can verify this by checking with lsmod.
Then you can unload the module and load it with the parameter you want just to test.
Code:
# rmmod e1000
# modprobe e1000 AutoNeg=32
Then see what results.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Traceroute detects drop-offs every 6th packet M_F_H Linux - Networking 6 05-23-2012 03:45 PM
Packet Forwarding from eth0 to eth1 isn't working rajat Linux - Networking 1 05-07-2007 05:24 AM
how to delay and drop the packet sonika_singhi Linux - Networking 4 04-02-2005 05:55 PM
drop packet in router becky_starr Programming 0 02-17-2004 09:43 AM
send-queue problem packet drop jorgen Linux - Networking 0 02-07-2004 03:04 PM


All times are GMT -5. The time now is 05:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration