LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-10-2008, 10:32 AM   #1
moks107
LQ Newbie
 
Registered: Nov 2008
Posts: 26

Rep: Reputation: 15
Driver help


Hi im a newbie to linux and i really need your help im using ubuntu 8 with windows xp which is in dual boot and the problem i have is how do i install the driver for my graphics card?see i have a ati radeon(an old one but its just my old pc anyway)and at first when i installed linux here it was fine the resolution was 800x600 but when i just tried my harddrive in another pc thats were the problems see when i kept the harddrive back it said it will run on low graphics because something wrong with the display something well but i have the driver for the display the problem is how do i install it?coz i cant find my cd in it?shouldnt it be mounted automatically?please help me and how do i install the driver cd?please help me now im running linux in 640x480 which is killing me because everything is soo big please help me
 
Old 11-10-2008, 10:36 AM   #2
ptemmerman
Member
 
Registered: Oct 2008
Location: Spain
Distribution: Ubuntu
Posts: 75

Rep: Reputation: 15
Hi Moks107.

I'm not current in Ubuntu, so pardon me if below is not exactly correct.
Starting version 7.10 (correct me if I'm wrong) Ubuntu is able to install the proprietary Ati driver automatically for you.

Look in the system > preferences (or administration) menu for an entry called Restricted Driver (or something similar). Follow the on screen instructions and pray
 
Old 11-10-2008, 10:57 AM   #3
moks107
LQ Newbie
 
Registered: Nov 2008
Posts: 26

Original Poster
Rep: Reputation: 15
thanks for the reply and umm i checked that out already and its in the system>administration>hardware drivers and when i tried to look at the list of drivers i didnt see anything listed not even one is this a big problem?or do i need to install ubuntu again man i hope i dont have to do dat.
 
Old 11-11-2008, 07:57 AM   #4
ptemmerman
Member
 
Registered: Oct 2008
Location: Spain
Distribution: Ubuntu
Posts: 75

Rep: Reputation: 15
Hi moks.

Try downloading the latest driver manually:

http://ati.amd.com/support/driver.HTML

The driver should come with a README or INSTALL file with further details on how to get it working.
In case you experience problems, just drop a message here.
 
Old 11-11-2008, 11:42 AM   #5
moks107
LQ Newbie
 
Registered: Nov 2008
Posts: 26

Original Poster
Rep: Reputation: 15
Hi thanks for your reply ptemmerman i really appreaciate it well umm i tried to search for my driver and man i had a hard time coz mostly i see drivers is for ATI all in wonder 7500 while my graphics card is just ATI radeon 7500 umm is there any other way ummm like how can i fix the mount for my linux?so that i can just my cd.i dont know wats wrong with the mount,but shouldnt the cd be mounted automatically when u insert it?coz mine doesnt detect it sorry if i ask a lot its just that im really a newbie at linux please help me
 
Old 11-11-2008, 04:39 PM   #6
ptemmerman
Member
 
Registered: Oct 2008
Location: Spain
Distribution: Ubuntu
Posts: 75

Rep: Reputation: 15
Hey Moks.

Seems your case is special. Your graphics card is based on the R100 chip. The proprietary ATI Linux driver only supports the R200 chip and up. You're only option is to use the opensource radeon driver. This driver should already be included in your Ubuntu 8.10 installation.

Make a copy of /etc/X11/xorg.conf (for backup, in case something goes wrong) and edit to have the file look like this:

Quote:
Section "Device"
Identifier "Configured Video Device"
Boardname "ATI Radeon"
Driver "radeon"
Screen 0
Vendorname "ATI"
Right now the "Driver" property should say "vesa" or something.
Restart X (press CTRL + ALT + BKSPC) or simply restart your machine. You should now have the the correct driver for your ATI card. If you're lucky your resolution should have changed automatically. If not, go to system>administration>screen resolution.

Hope that works.

Regarding the automounting of CDs, take a look at this:
http://www.togaware.com/linux/surviv...e_Manager.html

It basically says that you need the gnome-volume-manager (In case you are using GNOME as desktop environment).
 
Old 11-12-2008, 01:53 PM   #7
moks107
LQ Newbie
 
Registered: Nov 2008
Posts: 26

Original Poster
Rep: Reputation: 15
Hi ptemmerman!wow crap!it worked thats man!man i owe alot thanks alot for the help dude oh but i didnt do it exactly how u said it umm coz when i was going to edit the xorg.conf it said i needed permissions(o ya how do i do the permissions all i know is that u have to be in super user am i correct?but how do you do it?)so i looked around the file and saw a command there so i used in the terminal it was "sudo dpkg-reconfigure -phigh xserver -xorg" any idea on wat does this do?well after i did that i saw the new xorg.conf and i saw the section "device was changed into this:
Code:
Section "Device"
              Identifier "configured video device"
            endsection
Did i do something wrong?well when i restarted it,it shockingly worked well anyways thanks man!man u really know a lot about linux eh wat wer ur references?well now im going to do the automounting.thanks!
 
Old 11-13-2008, 02:33 AM   #8
ptemmerman
Member
 
Registered: Oct 2008
Location: Spain
Distribution: Ubuntu
Posts: 75

Rep: Reputation: 15
Hi Moks,

Glad you got it working.
Yes, to edit that file you need to be superuser.
To do so, just type "sudo su" and you will be changed to the root user (=superuser).

The dpkg-reconfigure just (as the name says) reconfigures an installed package. It reconfigured xserver-xorg, which is the package that takes care of you being able to see windows on your screen
The snippet you pasted isn't really the important part, the most important part is the "driver" line, which should be set to "radeon".
Yours doesn't say anything about this. Maybe you have another device entry in the xorg.conf file.

Cheers.
 
Old 11-13-2008, 03:50 PM   #9
moks107
LQ Newbie
 
Registered: Nov 2008
Posts: 26

Original Poster
Rep: Reputation: 15
yeah i know thats why im kinda worried about that because it doesnt say radeon hmm should i just leave it?its kinda weird eh.well thanks man i really appreciate your help man!looks like ive got a long way to go eh hehe well anyways thanks man!
 
Old 11-14-2008, 02:11 AM   #10
ptemmerman
Member
 
Registered: Oct 2008
Location: Spain
Distribution: Ubuntu
Posts: 75

Rep: Reputation: 15
Hey Moks

You're welcome.
I would leave it as it is. Don't change a winning team, you know
Good luck with your future Linux endeavors.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel GM 965 graphics driver and rtl8187b wireless driver for DamnSmallLinux tjwoosta Linux - Hardware 3 09-26-2008 12:05 AM
Etch continue loading old network card driver after new driver installation rtmex Linux - Networking 3 11-27-2007 07:07 AM
does the vesa console framebuffer driver conflict with the proprietary nvidia driver? mr.v. Linux - Hardware 2 01-28-2007 07:51 AM
R-Driver II usb 2.0 to ide cable driver for red hat Enterprise Edition 4. byju_das Linux - Hardware 0 11-23-2006 12:37 AM
Audio driver for ASUS board and HP 1150 Laser PRinter Driver ccatindia Linux - Hardware 1 05-11-2004 04:20 AM


All times are GMT -5. The time now is 08:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration