LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-27-2010, 07:29 PM   #1
onesikgypo
Member
 
Registered: Jun 2008
Posts: 56

Rep: Reputation: 15
Downgrading openssl on Centos


Hi,

I recently just installed centos, but it appears that when i installed it v 0.9.8e was installed consequently, all the lib's etc. are /lib/libssl.so.0.9.8e instead of an ordinary /lib/libssl.so.0.9.8 etc. and this is causing some problems for me, as programs are looking for /lib/libssl.so.0.9.8, and even if i symlink/copy/move /lib/libssl.so.0.9.8e to /lib/libssl.so.0.9.8 there are still some errors occurring.

I had been reading that supposedly yum is meant to have a "yum downgrade" option, however it doesnt appeart o be recognised when i run it on my centos server.

Any assistance wouldbe greatly appreciated.
 
Old 09-27-2010, 07:36 PM   #2
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
I will look into downgrading OpenSSL on CentOS, but in the meantime, have you read the yum manpage?
Code:
$ man yum
EDIT:

I found this for you on ServerFault. Basically, here is the command you are looking for:
Code:
# yum --allow-downgrade install desired_openssl_package

Last edited by indienick; 09-27-2010 at 07:42 PM. Reason: Illumination.
 
Old 09-27-2010, 08:51 PM   #3
onesikgypo
Member
 
Registered: Jun 2008
Posts: 56

Original Poster
Rep: Reputation: 15
Hi,

Unfortunately this did not work for me:

Code:
Command line error: no such option: --allow-downgrade
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed Dependency error occurs while installing openssl in centos prak86 Linux - Software 9 12-23-2009 06:07 PM
oops openssl-0.9.8e over openssl-0.9.8d bad install now 2 copies? rcorkum Slackware 4 06-29-2007 01:58 AM
Downgrading to X86 v3 Maxicat Linux - Software 6 10-10-2004 01:45 PM
Downgrading from 3.3 to 3.2 Niumex Linux - Distributions 0 09-02-2004 04:00 PM
Downgrading MamaDoll Linux - General 1 04-11-2003 04:17 PM


All times are GMT -5. The time now is 04:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration