LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-25-2004, 08:37 PM   #1
cthuhlu2
LQ Newbie
 
Registered: May 2004
Location: New England, USA
Distribution: Red Hat 9.0 on a PIII 500MHz Sony Vaio desktop.
Posts: 5

Rep: Reputation: 0
Doubt you've EVER heard of this one...


Okay, I'm not even sure HOW let alone WHERE to look up THIS situation:

I am running Red Hat 9.0 on my 4 yr old Sony PCV-R545DS which contains 2 hard drives:
hda> 20GB (10gb for Windows 98, 10GB for RH 9.0)
hdb> 80GB to hold all of my documents, files, pics, etc.

When I boot up in RH, I can see the 2nd HD (the 80GB, which is loaded into my /home/documents folder) just fine. I can access any of the files just fine( sort of ).

THE PROBLEM:
Only ROOT has read/write privaleges for the partition, everybody else has read-only!
Permissions for that folder are drwxr-xr-x

TRIED:
I have tried chown and fstab but once I mount the drive it automatically goes back to the above setting!

Since ROOT has normal access to it all then I know that at least it isn't an issue with not connecting to thedrive.

Since it changes back when the drive is mounted (overwritting any changes done) I wonder if it's something with the way the HD is mounted or a setting with the HD itself ? ! ? !


Any suggestions would be helpful. I think I've stumped my "local Linux Guru" who has helped me tremendously so far!


Thanks ~Andrew the Newbie
 
Old 05-25-2004, 08:50 PM   #2
rkef
Member
 
Registered: Mar 2004
Location: bursa
Posts: 110

Rep: Reputation: 15
I refer you to this thread.

There may be other options you want to set; check the manpages for mount(8) and fstab(5). For example if it's a multi-user system and you want certain people to have such access, set the gid accordingly.

HTH.

p.s. your thread title should be more descriptive and less... "I triple dog dare you!" It's probably somewhere in the rules of this board .

Last edited by rkef; 05-25-2004 at 09:12 PM.
 
Old 05-26-2004, 06:54 AM   #3
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,500

Rep: Reputation: 91
Hi!

Try mounting your windows partition with

/dev/hda1 /mnt/win vfat user,exec,dev,suid,rw,umask=000,auto 0 0

in your fstab. The "umask=000" part gives non-privileged users write access.
 
Old 05-26-2004, 09:06 PM   #4
cthuhlu2
LQ Newbie
 
Registered: May 2004
Location: New England, USA
Distribution: Red Hat 9.0 on a PIII 500MHz Sony Vaio desktop.
Posts: 5

Original Poster
Rep: Reputation: 0
Talking

Thanks!
I tried the /dev/hda1 /mnt/win vfat user,exec,dev,suid,rw,umask=000,auto 0 0 edition to the fstab and that seems to have worked beautifully!

I will try to be more descriptive in my future posts, but you have to admit, it was difficult to resist, wasn't it?
 
Old 05-27-2004, 09:44 AM   #5
TACD
LQ Newbie
 
Registered: Aug 2003
Location: Merrie Olde England
Distribution: SUSE 9.1 Personal
Posts: 23

Rep: Reputation: 15
Quote:
Originally posted by rylan76

Try mounting your windows partition with

/dev/hda1 /mnt/win vfat user,exec,dev,suid,rw,umask=000,auto 0 0

in your fstab. The "umask=000" part gives non-privileged users write access.
I will try this in a minute to fix my similar problem, but what do the other options do?
 
Old 05-27-2004, 12:04 PM   #6
cthuhlu2
LQ Newbie
 
Registered: May 2004
Location: New England, USA
Distribution: Red Hat 9.0 on a PIII 500MHz Sony Vaio desktop.
Posts: 5

Original Poster
Rep: Reputation: 0
I think, and please correct me if I'm wrong, the parameters are ...

/dev/hda1 /mnt/win vfat user,exec,dev,suid,rw, umask=000,auto 0 0
...is the partition address

/dev/hda1 /mnt/win vfat user,exec,dev,suid,rw, umask=000,auto 0 0
...is where you want to mount the directory to

/dev/hda1 /mnt/win vfat user,exec,dev,suid,rw, umask=000,auto 0 0
...is the format the partition is in (vfat for Windows' FAT32)

/dev/hda1 /mnt/win vfat user,exec,dev,suid,rw, umask=000,auto 0 0
...are the user groups granted access (I use "user" and "root" unless somebody tells me "BAD! BAD DOGGIE!")

/dev/hda1 /mnt/win vfat user,exec,dev,suid,rw, umask=000,auto 0 0
...are options (I think "auto" is what says to mount it during start-up)

/dev/hda1 /mnt/win vfat user,exec,dev,suid,rw, umask=000,auto 0 0
...I haven't a clue

Don't know if that helps you at all, but this is what I have figured out so far.

~Andrew
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Did U Heard about UPKG? deepclutch Debian 0 08-14-2005 03:17 AM
Ever heard of this?!?! Ghetto_Penguin Linux - Software 2 12-28-2004 12:35 PM
I heard of something... spartanM19SSM Linux - Newbie 3 09-29-2004 06:19 PM
Nothing like I heard Kylesun General 8 07-02-2004 05:06 AM
Ive heard.... Kenster Red Hat 1 12-09-2003 06:04 AM


All times are GMT -5. The time now is 11:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration