LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-26-2004, 06:06 AM   #1
teatime
LQ Newbie
 
Registered: Nov 2004
Location: Norwich, Norfolk, UK
Posts: 4

Rep: Reputation: 0
Question Doom 3, OSS, and installing things


Hello, long time reader first time poster. I am currently using Ubuntu (best distro with Ati support, and based on debian, always a plus )

I have 3 questions I hope you guys can help me with:

1. I have installed Doom 3 correctly, but I am getting an OSS and MMAP error. I really don't have a clue what this is. Am I missing a library of some sort relating to OSS? I can't find much information on google, I searched on here but the solutions people have posted don't work for me as I don't think I have OSS in the first place. I did a search on Synaptic and found some OSS related packages. But they seem to be installed. Maybe someting I need to install or configure?

Also I am having another problem on the subject of installing, I have pretty much conquered rpm's, deb's, and using alien. but how do I properly install TAR archives? for example I am trying to install Kino:

First I extract it:
tar -xvzf kino.tar.gz

Then go to the Drawer:
cd kino

Then configure:
./configure

And it goes all nuts at me, can't find file or folder...my ubuntu if it can't, because it is definetly there, I am doing this all as root, but I just can't do the ./configure, never have done, in any distro!

Last question (thank you for bearing with me for this long you god of a linux user you!) I don't have a Root account as such. I can get SU in a terminal window, but I can not actually log into root, from the main logon screen.

I hope you guys can help me,

Cheers Teatime...kiss-kiss
 
Old 11-26-2004, 06:25 AM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 69
Without seeing your configure's actual output, I can't say what might be wrong, except to ask if you have the various compiler and development packages installed that you need to compile software from source.

I can help you with the root login, though. Check your /etc/passwd file, and make sure that there's an entry for the root user. I'm guessing that you have a password (because you can su) but there should also be a login shell given, probably as “lologin” or similar. I can't think why you'd want to log in as root, but changing this to /bin/bash will let you do so. See
Code:
man passwd
for more information.
 
Old 11-26-2004, 06:36 AM   #3
teatime
LQ Newbie
 
Registered: Nov 2004
Location: Norwich, Norfolk, UK
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you I have my root sorted out now

As far as I know I have compilers installed, it simply reads out "could not find file or folder ./configure"
 
Old 11-27-2004, 07:34 PM   #4
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 69
Make sure that you are trying to run configure from the right directory. If you run
Code:
ls -l configure
then you should see a file called configure, belonging to the source code you unpacked.

If the file says something like -rw-r-r-- (without any xes in it) then the file isn't executable. You need to run
Code:
chmod a+rx configure
before you can run the script. You'll then see something like -rwxr-xr-x, which means that the file is executable. (Try looking at the file's properties in a file manager like Konqueror to see what the various bits mean)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse: confused on many things, why is installing things so hard? blackflare Linux - Newbie 11 10-16-2007 05:35 AM
installing Doom Legacy jaakkop Linux - Games 2 09-10-2005 11:11 AM
Doom 3 Audio not working w/ OSS judgedeath2 Linux - Software 0 11-05-2004 08:14 PM
Issue with snd-pcm-oss and snd-mixer-oss; OSS load failed EnigmaX Slackware 3 07-26-2004 04:26 PM
Installing Doom CropA General 0 03-29-2001 08:57 AM


All times are GMT -5. The time now is 12:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration