LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-29-2008, 04:16 PM   #1
johngcarlsson
Member
 
Registered: Jul 2004
Posts: 58

Rep: Reputation: 15
Don't understand dependency error


Hi,
I'm running CentOS 4 and trying to install a package called "synergy". When I try to install it, I run

yum install synergy

as root, and I get the messages

Error: Missing Dependency: rtld(GNU_HASH) is needed by package synergy
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package synergy

How do I install these dependencies? Shouldn't yum do that automatically?

Thanks, JGC
 
Old 05-29-2008, 06:42 PM   #2
largem
LQ Newbie
 
Registered: Apr 2006
Posts: 5

Rep: Reputation: 0
If the package needs another glibc package to be installed first, you have to think it over. It requires another version glibc that is different from the one on your machine.
Normally, upgrade or downgrade glibc on a running system is quite tough.

Maybe, you could find some older version of synergy that require of the same version of your glibc installed.

You could find the version of your glibc by using rpm -qa | grep glibc
 
Old 05-29-2008, 06:49 PM   #3
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,036

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
Originally Posted by largem View Post
If the package needs another glibc package to be installed first, you have to think it over. It requires another version glibc that is different from the one on your machine.
Normally, upgrade or downgrade glibc on a running system is quite tough.
In other words: it will break all your binaries leaving your system in an unusable state. So, unless you are using a source based distro like Gentoo, you are better just upgrading the distro.

Quote:
Maybe, you could find some older version of synergy that require of the same version of your glibc installed.
That, or compile the new version from source against your current glibc. Either way should work.
 
  


Reply

Tags
centos4, glibc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I don't understand this error FowlProgrammer Linux - Newbie 4 02-18-2007 07:42 AM
why isn't this source building? don't understand error hedpe Linux - Software 2 10-14-2006 08:40 PM
i don't understand disc partitions! critical error! joel b Linux - Newbie 1 03-27-2005 04:45 PM
Permissions error message I dont understand? BajaNick Linux - Security 5 02-16-2005 08:12 PM
DHCP Installation Error: Dependency Error rhonneil Linux - Networking 2 09-15-2003 05:56 AM


All times are GMT -5. The time now is 06:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration