LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-18-2009, 03:37 PM   #1
sl33p
Member
 
Registered: Dec 2008
Location: Tahiti
Distribution: Kali Linux
Posts: 42

Rep: Reputation: 17
Does the "python-dcop" package for Fedora exists?


Fedora 10 & EMESENE 1.0.1 with "CurrentSong" Plugin

Hi guys,
I'm using Fedora 10. I always get an error when trying to use currentSong plugin with amaroK: "Can't import dcopext or python-dcop". I have searched in google and this forum, and everbody recommends to install python-dcop or other packets. I have tried to install every packet I have seen published in the forums I read, but the problem is that I can't find nothing like python-dcop in Fedora repositories. Every documentation I have found about this problem seems to help Ubuntu users, but I haven't found anything for Fedora users.

I'm sure that there is a very easy solution for this, but It's getting complicated for me to find it, so if anybody could help me I'd be very pleased.

Thank you very much.

Regards.
 
Old 07-18-2009, 07:16 PM   #2
bertlef
Member
 
Registered: Dec 2004
Location: Costa Rica
Distribution: Ubuntu
Posts: 69

Rep: Reputation: 17
Have you tried compiling it?
 
Old 07-19-2009, 04:26 PM   #3
sl33p
Member
 
Registered: Dec 2008
Location: Tahiti
Distribution: Kali Linux
Posts: 42

Original Poster
Rep: Reputation: 17
No, because I couldn't even find the source package...

I googled it as python-dcop.tgz, python-dcop source, and further on sourceforge.net, without any success.

I also downloaded the python-dcop_3.5.10-1_amd64.deb package. Is there any package converter from .deb to .rpm? I know about alien, but I couldn't find it on any of Fedora repositories (including livna and google) either.

I've found though, a rpm for Mandriva. Will it be possible to convert it to the source file (using rpm2cpio and then extracting it), and later compiling it for Fedora 10, using my rpm?? Would that work, or I'm just speaking bullshit, lol! Hmm... I think I could do that if the rpm was a source rpm, right?

Thanks in advance!

Last edited by sl33p; 07-19-2009 at 04:34 PM.
 
Old 07-28-2009, 01:54 PM   #4
sl33p
Member
 
Registered: Dec 2008
Location: Tahiti
Distribution: Kali Linux
Posts: 42

Original Poster
Rep: Reputation: 17
Question

Returning to that question, I googled a little bit more, and found this package description:

DCOP Bindings for Python
Source package: kdebindings_3.5.10.orig.tar.gz

This package contains the shared libraries necessary to run and develop Python programs using the Python DCOP bindings libraries. DCOP is the KDE Desktop COmmunications Protocol, used for communicating with running KDE applications.

I think that's the reason I cannot find a .rpm for RedHat based systems, since Fedora uses Gnome as its main Desktop Manager. :/

But how can I find at least the source code so I can make/install it on my F10?

Thanks,
sl33p

Last edited by sl33p; 07-28-2009 at 02:01 PM.
 
Old 07-28-2009, 10:12 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
The 'kdebindings_3.5.10.orig.tar.gz ' is the source
code
to make python-dcop_3.5.x.
But you will need the most of kde 3.5.x to compile it.
And it will not work with KDE 4.x.

Obviously the " currentSong plugin " is meant for
kde 3.5.x only.

And there is nothing like python-dcop for KDE 4.x.
.....
 
Old 07-29-2009, 09:49 AM   #6
sl33p
Member
 
Registered: Dec 2008
Location: Tahiti
Distribution: Kali Linux
Posts: 42

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by knudfl View Post
The 'kdebindings_3.5.10.orig.tar.gz ' is the source
code
to make python-dcop_3.5.x.
But you will need the most of kde 3.5.x to compile it.
And it will not work with KDE 4.x.

Obviously the " currentSong plugin " is meant for
kde 3.5.x only.

And there is nothing like python-dcop for KDE 4.x.
.....
Well, I don't see where it's "Obvious" that currentSong plugin is meant for kde 3.5.x only.

I might try another MSN client then, Gnome based.

Thanks for the explanation!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't locate object method "splitpath" via package "PACK001" at /usr/lib/perl5/5.8.8/ sajigeorge Linux - Software 1 01-11-2009 07:33 AM
How to get the current virtual "desktop number" on KDE through dcop? cheema Linux - Software 1 05-13-2008 06:58 AM
User "list" running process "python" TroelsSmit Linux - Newbie 2 02-22-2005 05:55 AM
Can't locate object method "splitpath" via package "File::Spec" RobJohnston Linux - General 2 06-28-2003 10:59 AM


All times are GMT -5. The time now is 12:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration