LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-13-2010, 03:55 AM   #16
someone9999
LQ Newbie
 
Registered: Aug 2010
Posts: 15

Original Poster
Rep: Reputation: 0
ene not showing up when i type lspci it showed up before i changed the bios maybe i could try 1.09


when i type lspci its not showing up the ene card reader i remember it showed up before i changed the bios but dont remember if i used lspci or another function



00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller
00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Atheros Communications Atheros AR8132 / L1c Gigabit Ethernet Adapter (rev c0)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
 
Old 08-13-2010, 03:58 AM   #17
someone9999
LQ Newbie
 
Registered: Aug 2010
Posts: 15

Original Poster
Rep: Reputation: 0
its there when i type lsusb

it shows up

Bus 005 Device 002: ID 0489:e011 Foxconn / Hon Hai
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 007: ID 0cf2:6250 ENE Technology, Inc.
Bus 001 Device 002: ID 064e:a102 Suyin Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 
Old 08-13-2010, 04:23 AM   #18
minhna
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Rep: Reputation: 0
I have MSI u130 netbook and I had this problem too.
Quote:
minhna@minhna-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller
00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
minhna@minhna-laptop:~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0cf2:6250 ENE Technology, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 
Old 08-13-2010, 11:55 AM   #19
zootboy
Member
 
Registered: Nov 2008
Location: In a dumpster, with my laptop.
Distribution: Fedora
Posts: 124

Rep: Reputation: 25
Well, to test if it's working: power the system down, put in an SD card, boot it up and log in, remove and re-insert the card, then run 'dmesg' and see if it shows up in the log.

Also, make sure you try a couple different cards in the reader. Sometimes, certain card readers (for whatever reason) won't read certain cards.
 
Old 08-13-2010, 08:59 PM   #20
minhna
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Rep: Reputation: 0
dear zootboy, I did what you said and here is the content of dmesg command.
Thank you.
Attached Files
File Type: txt dmesg.txt (42.4 KB, 5 views)
 
Old 08-13-2010, 09:18 PM   #21
zootboy
Member
 
Registered: Nov 2008
Location: In a dumpster, with my laptop.
Distribution: Fedora
Posts: 124

Rep: Reputation: 25
Did the card reader show up at all? I see no errors in the dmesg log.
 
Old 08-13-2010, 10:14 PM   #22
minhna
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Rep: Reputation: 0
I tried to insert and remove few more time and see the dmesg log.
Quote:
[ 4256.293597] usb 1-3: USB disconnect, address 3
[ 4503.140176] usb 1-3: new high speed USB device using ehci_hcd and address 4
[ 4503.273752] usb 1-3: configuration #1 chosen from 1 choice
[ 4646.219827] usb 1-3: USB disconnect, address 4
[ 4651.908150] usb 1-3: new high speed USB device using ehci_hcd and address 5
[ 4652.041806] usb 1-3: configuration #1 chosen from 1 choice
But the card reader did not show up anything. I goto the /media, it's empty.
 
Old 08-13-2010, 10:23 PM   #23
minhna
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Rep: Reputation: 0
I tried to insert an USB disk
and this is the dmesg log:
Quote:
[ 4989.568156] usb 1-2: new high speed USB device using ehci_hcd and address 6
[ 4989.703607] usb 1-2: configuration #1 chosen from 1 choice
[ 4989.780727] Initializing USB Mass Storage driver...
[ 4989.781200] scsi4 : SCSI emulation for USB Mass Storage devices
[ 4989.781909] usbcore: registered new interface driver usb-storage
[ 4989.781927] USB Mass Storage support registered.
[ 4989.788740] usb-storage: device found at 6
[ 4989.788752] usb-storage: waiting for device to settle before scanning
[ 4994.784443] usb-storage: device scan complete
 
Old 08-14-2010, 04:19 AM   #24
someone9999
LQ Newbie
 
Registered: Aug 2010
Posts: 15

Original Poster
Rep: Reputation: 0
my dmesg file is attachedd the ene card reader does now show up
Attached Files
File Type: txt dm.txt (31.4 KB, 3 views)
 
Old 08-15-2010, 10:06 AM   #25
zootboy
Member
 
Registered: Nov 2008
Location: In a dumpster, with my laptop.
Distribution: Fedora
Posts: 124

Rep: Reputation: 25
I've just located this:

http://hardware4linux.info/component/14454/

It seems that the linux community has had trouble with this specific card reader. There may be a kernel patch that might work, but patching a kernel is a tricky proposition.

Last edited by zootboy; 08-15-2010 at 10:09 AM.
 
Old 08-15-2010, 09:40 PM   #26
someone9999
LQ Newbie
 
Registered: Aug 2010
Posts: 15

Original Poster
Rep: Reputation: 0
id give it a try if you can send me a link or refer me to some kernels to patch

if not i may just try another os

like osx or go back to windows

the reason i wanted to go to linux was because it is lightweight
and did not need all the software that came with windows ,so ill see about the kernel.
 
Old 08-15-2010, 10:11 PM   #27
zootboy
Member
 
Registered: Nov 2008
Location: In a dumpster, with my laptop.
Distribution: Fedora
Posts: 124

Rep: Reputation: 25
Read the comments on that page I linked. There was some mention of a kernel module, mmc_block, that might get it working. Do some googling on that.
 
Old 08-16-2010, 12:59 AM   #28
minhna
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Rep: Reputation: 0
Thank you zootboy for your help.
@someone9999: I will never go back to windows just for card reader. I can live without it.
 
Old 08-16-2010, 06:22 PM   #29
someone9999
LQ Newbie
 
Registered: Aug 2010
Posts: 15

Original Poster
Rep: Reputation: 0
thanks zootboy ill go over the comments about the kernel patch in the link.
 
Old 08-17-2010, 01:22 PM   #30
zootboy
Member
 
Registered: Nov 2008
Location: In a dumpster, with my laptop.
Distribution: Fedora
Posts: 124

Rep: Reputation: 25
Best of luck to the both of you.

@minhna:
I like that attitude. I would love to use linux all the time, but I'm stuck dual-booting until valve ports steam to linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ENE card reader on Acer Aspire Laptop franciscojrcosta Linux - Hardware 0 09-18-2008 08:13 AM
ene cb 710 card reader tanoatlq Linux - Hardware 1 03-31-2008 01:36 AM
Internal flash card reader in Acer Aspire 5101awlmi PekkaM Linux - Laptop and Netbook 1 04-13-2007 08:21 AM
ENE Technology Inc CB710 Memory Card Reader Controller foxy123 Linux - Laptop and Netbook 1 08-26-2005 12:12 PM
How do I get an ene card reader working with Suse 9.3? dorism Linux - Hardware 0 07-18-2005 01:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration