LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 09-24-2008, 11:45 PM   #1
olracdor
Member
 
Registered: Nov 2007
Posts: 95

Rep: Reputation: 15
does nvidia Geforce gtx 280 work on feodra 9?


does nvidia Geforce gtx 280 work on feodra 9? how can i install the driver for these? if theres any driver for the 280
 
Old 09-25-2008, 08:34 PM   #2
henry_shadowjet
Member
 
Registered: Oct 2006
Posts: 55

Rep: Reputation: 15
Hi there,

GeForce GTX 280 support has been added since version 177.13:
http://www.nvidia.com/object/linux_d...32_177.13.html (32bit)
http://www.nvidia.com/object/linux_d...64_177.13.html (64bit)

To get the latest drivers (BETA 177.76), though, use the following links:
ftp://download.nvidia.com/XFree86/Li...77.76-pkg1.run (32bit)
ftp://download.nvidia.com/XFree86/Li...77.76-pkg2.run (64bit)

I'm using Fedora 9, though not the same GPU, and these drivers work pretty well.

Good luck
 
Old 09-26-2008, 01:53 AM   #3
John VV
Guru
 
Registered: Aug 2005
Posts: 13,467

Rep: Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800
do not install the nvidia.run blob install use the livna repo and yum to install the driver
see:
http://www.mjmwired.net/resources/mj...f9.html#nvidia
but use " su - " and not sudo ( that is unless you already have sudo configured and setup)
Code:
su -
( your root password when asked )
rpm -ivh http://rpm.livna.org/livna-release-9.rpm
rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-livna
yum install kmod-nvidia
This is because some programs in fedora WILL NOT RUN using the nvidia.run .But will run just fine using the rpm

Last edited by John VV; 09-26-2008 at 01:55 AM.
 
Old 10-09-2008, 09:33 AM   #4
blitzo
LQ Newbie
 
Registered: Aug 2008
Location: NW PA
Distribution: Red Hat, Gentoo
Posts: 4

Rep: Reputation: 0
I am running into problems with Fedora 9 and the GTX 280. I prefer to install everything through yum.

olracdor - Did you get it working?

John VV - Is 177.+ in the Livna repo?
 
Old 10-09-2008, 11:55 AM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 13,467

Rep: Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800Reputation: 1800
the kmod for kernel 2.6.26.5-45
-----
kmod-nvidia-2.6.26.5-45.fc9.i686-173.14.12-5.lvn9.i686.rpm
for PAE
kmod-nvidia-PAE-173.14.12-5.lvn9.i686.rpm

so YES they are in the yum repos


PS. If you have already installed the *.run package at some point .THEN YOU MUST run
Code:
su -
telinit 3
( relogin as root )
cd / ( to the .run file ) 
sh *.run --uninstall
to remove the nvidia's blob
before installing the kmod-nvidia
 
Old 10-09-2008, 02:19 PM   #6
blitzo
LQ Newbie
 
Registered: Aug 2008
Location: NW PA
Distribution: Red Hat, Gentoo
Posts: 4

Rep: Reputation: 0
You misunderstood. The original poster needs version 177.13 or higher nvidia drivers, because anything before 177.13 does not support the GTX 280 card. Version 177+ is not in any of the well known repos for Fedora 9. So if you are using Fedora 9 or older you can not use the nvidia driver in the repos. You can use the binary driver nvidia provides on their website but due to conflicts with other software it is not recommended. I have found a work around, although I have not thoroughly tested. I was able to create a newer rpm of the nvidia-x11-drv package, thanks to some help within the Fedora community.

Quote:
Originally Posted by John VV View Post
the kmod for kernel 2.6.26.5-45
-----
kmod-nvidia-2.6.26.5-45.fc9.i686-173.14.12-5.lvn9.i686.rpm
for PAE
kmod-nvidia-PAE-173.14.12-5.lvn9.i686.rpm

so YES they are in the yum repos
 
Old 10-10-2008, 04:08 AM   #7
olracdor
Member
 
Registered: Nov 2007
Posts: 95

Original Poster
Rep: Reputation: 15
@blitzo

yeah! i got it working! but i used the driver from the nvdia website. i downloaded the latest kernel and installed the driver and its working fine now. THANKS guys!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 8.04 + Nivdia geforce 8800 GTX drivers not working gamer4lyf3 Linux - Newbie 9 05-13-2008 10:59 PM
Geforce 8800 GTX drivers upset my monitor gamer4lyf3 Linux - Newbie 2 02-17-2008 01:13 AM
install xgl on dell xps m1710 running sled10, geforce 7950 gtx tomp@ Linux - Newbie 1 12-20-2007 07:01 PM
Drivers for XPS M1710 laptop - Nvidia Geforce GTX 7900 GO Lorenkia Linux - Newbie 3 03-31-2007 12:36 PM
Geforce Go 7950 GTX Houseoffun Linux - Hardware 1 01-20-2007 07:25 PM


All times are GMT -5. The time now is 02:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration