LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-23-2014, 01:19 PM   #1
od13
LQ Newbie
 
Registered: May 2014
Posts: 4

Rep: Reputation: Disabled
Unhappy dns time warner redirect in Firefox


I am using Luna OS Elementary. Its pretty cool. I am using the latest version of Mozilla firefox. If I misspell something in the address bar I get redirect it to Time warner search, which I promptly close and start all over again. I found instructions on how to disable the time warner redirect for a windows system, but can't find anything for Linux. I have spent hours searching the internet for an answer. Can anyone help? Please
 
Old 05-23-2014, 01:43 PM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
I'm not sure what you want to do. Do you want to redirect misspellings to an different search engine? Or do you not want any redirection at all?
And why do you have to close anything at all? If you make a mistake in the navigation window then simply type the correct form over the mistake. Please try and make clear exactly what you're trying to do.
jdk

Last edited by jdkaye; 05-23-2014 at 01:52 PM.
 
Old 05-23-2014, 01:51 PM   #3
dijetlo
Senior Member
 
Registered: Jan 2009
Location: RHELtopia....
Distribution: Solaris 11.2/Slackware/RHEL/
Posts: 1,307
Blog Entries: 2

Rep: Reputation: Disabled
Hey Odie,

You probably just need to set your default search engine for firefox. If you have a search box next to your address bar, look for a down arrow in the box. Click it and you'll see the default options for search engines, choose one.
 
Old 05-23-2014, 02:53 PM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,952

Rep: Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693
Quote:
Originally Posted by od13
I am using Luna OS Elementary. Its pretty cool. I am using the latest version of Mozilla firefox. If I misspell something in the address bar I get redirect it to Time warner search, which I promptly close and start all over again. I found instructions on how to disable the time warner redirect for a windows system, but can't find anything for Linux. I have spent hours searching the internet for an answer. Can anyone help?
First, there is NO REASON to close your browser when you don't get the right website. Click in the address bar, and enter another address. What you're doing is akin to exiting your word-processor when you misspell a word.

The easiest way to get around this is to add these two lines:
Code:
nameserver 8.8.8.8
nameserver 8.8.4.4
...into the /etc/resolv.conf file. Those are Google's public DNS servers, which won't redirect you. That said, you will still have the same 'problem' when you misspell a website name...in that it won't come up or go to the wrong location.
Quote:
Originally Posted by dijetlo View Post
Hey Odie,
You probably just need to set your default search engine for firefox. If you have a search box next to your address bar, look for a down arrow in the box. Click it and you'll see the default options for search engines, choose one.
Sorry, that won't do anything for this problem. Time Warner (and other cable ISP's), routinely re-direct people to their site, in the event of a DNS lookup failure (such as a misspelled/nonexistent website). That's because they are providing the DNS services. You can opt-out, but it is a painful process.
 
1 members found this post helpful.
Old 05-23-2014, 03:09 PM   #5
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,176

Rep: Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837
for what it's worth...
this sounds a little like some malware a friend of mine caught on her windoze computers firefox - all searches get redirected to some obscure bs website, something like that.
just trying to help clarify things but i might be wrong of course.
 
Old 05-23-2014, 03:14 PM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,952

Rep: Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693
Quote:
Originally Posted by ondoho View Post
for what it's worth...
this sounds a little like some malware a friend of mine caught on her windoze computers firefox - all searches get redirected to some obscure bs website, something like that.
just trying to help clarify things.
I don't think that's the case here; Time Warner (and Brighthouse, too), provide 'their' DNS services. This is a fairly widely-reported issue, with no malware involved:
http://en.wikipedia.org/wiki/DNS_hij...lation_by_ISPs

It happened on my openSUSE box, and when I changed the resolv.conf and used Google's DNS servers, the problem vanished. Same for my wifes Windows laptop, and her iPad (after giving it a static address, and configuring things manually).
 
Old 05-23-2014, 03:53 PM   #7
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531Reputation: 3531
Additionally (and depending on how the redirection is done) there is at least one caching DNS server, Pdnsd, that allows you to deny certain DNS responses.
 
Old 05-23-2014, 04:39 PM   #8
dijetlo
Senior Member
 
Registered: Jan 2009
Location: RHELtopia....
Distribution: Solaris 11.2/Slackware/RHEL/
Posts: 1,307
Blog Entries: 2

Rep: Reputation: Disabled
Quote:
Sorry, that won't do anything for this problem.
Thanks for the correction, Tbone. I should have tested it before opening my mouth.
 
Old 05-23-2014, 05:20 PM   #9
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,825

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
It is not malware
it is the normal Bu11 $hi7 from the ISP
a dns hijack that the ISP is doing

set the above 8.8.8.8 and 8.8.4.4
then set your network manager to get IP address ONLY from dhcp

normally the ip AND the DNS is set BY your isp
 
Old 05-23-2014, 10:22 PM   #10
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,394

Rep: Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207
Yes, some sort of open dns ip should fix it.
 
Old 05-24-2014, 07:38 AM   #11
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,176

Rep: Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837Reputation: 837
Quote:
Originally Posted by od13 View Post
I found instructions on how to disable the time warner redirect for a windows system, but can't find anything for Linux.
it seems i was wrong, others are right.
i would say the process is the same on a windows or linux computer - maybe you can spot the similarities.

anyhow, others wrote:
Quote:
The easiest way to get around this is to add these two lines:
Code:
nameserver 8.8.8.8
nameserver 8.8.4.4
...into the /etc/resolv.conf file. Those are Google's public DNS servers, which won't redirect you.
you will have to open the file with
Code:
sudo gedit /etc/resolv.conf
iirc, this file tends to get overwritten, so if the problem persists, post again.

Last edited by ondoho; 05-24-2014 at 07:40 AM.
 
Old 05-24-2014, 08:04 AM   #12
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,018

Rep: Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622
Personally, I set my router to use Open DNS so that any clients connecting will pick that up through DHCP. Of course Open DNS have their own redirect page but I don't like the idea of Google registering all the sites I go to as well as my search history (just personal preference though).
 
Old 05-24-2014, 11:40 AM   #13
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Or just use your own server.
 
Old 05-24-2014, 11:44 AM   #14
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,018

Rep: Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622Reputation: 1622
Quote:
Originally Posted by Emerson View Post
Or just use your own server.
I hate to be picky but I don't see how this solves the problem in any way?
 
Old 05-24-2014, 11:45 AM   #15
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
You are in full control, nothing gets redirected.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mutt with Time/Warner Cable Zwergele Linux - Newbie 4 01-09-2014 09:40 PM
Time/Warner Cable and Mutt Zwergele Slackware 4 11-08-2013 02:45 AM
LXer: TiVo accuses Motorola, Time Warner of violating - time warp - patents LXer Syndicated Linux News 0 03-28-2012 02:10 PM
Connecting to Time Warner WiFi utlavp@aol.com Linux - Newbie 3 06-20-2010 04:03 PM
Time Warner wants more money! cousinlucky General 5 06-05-2009 08:23 AM


All times are GMT -5. The time now is 12:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration