LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-14-2007, 10:50 AM   #1
Benso37
LQ Newbie
 
Registered: Jan 2005
Posts: 19

Rep: Reputation: 0
DNS server question...


I just installed and configured a DNS server on my Fedora 7 install. However, I don't think it's working...

I added my windows box as a host on this new DNS, then I went to my windows box and changed the DNS configuration to use my new DNS. When ping google.com nothing happens but when I change it back to my old DNS (windows dns server I built myself), then it pings.

Weird thing is that from my windows or any other host, I can ping the DNS server and other hosts on the DNS by using the hostname. That tells me that the issue is with either the root hint or the forwarder.

I am posting my named.conf file here...any help will be greatly appreciated.

Code:
server xxx.xx.165.100 {
};
options {
	directory "/var/named";
	dump-file "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
	/*
	 * If there is a firewall between you and nameservers you want
	 * to talk to, you might need to uncomment the query-source
	 * directive below.  Previous versions of BIND always asked
	 * questions using port 53, but BIND 8.1 uses an unprivileged
	 * port by default.
	 */
	 // query-source address * port 53;
};

zone "opendns." IN {
	type forward;
	forwarders {	208.67.220.220 port 53;
};
};
zone "165.xx.xxx.in-addr.arpa." IN {
	type master;
	file "xxx.xx.165.db";
};
zone "251.xx.xxx.in-addr.arpa." IN {
	type master;
	file "xxx.xx.251.db";
};
zone "myzone." IN {
	type master;
	file "myzone.db";
};
zone "." IN {
	type hint;
	file "named.root";
};

zone "localdomain." IN {
	type master;
	file "localdomain.zone";
	allow-update { none; };
};

zone "localhost." IN {
	type master;
	file "localhost.zone";
	allow-update { none; };
};

zone "0.0.127.in-addr.arpa." IN {
	type master;
	file "named.local";
	allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.  0.0.0.0.0.0.ip6.arpa." IN {
        type master;
	file "named.ip6.local";
	allow-update { none; };
};

zone "255.in-addr.arpa." IN {
	type master;
	file "named.broadcast";
	allow-update { none; };
};

zone "0.in-addr.arpa." IN {
	type master;
	file "named.zero";
	allow-update { none; };
};

include "/etc/rndc.key";
 
Old 09-14-2007, 02:35 PM   #2
rex vonireful
LQ Newbie
 
Registered: May 2004
Distribution: Fedora
Posts: 4

Rep: Reputation: 0
My first thought is check if iptables is allowing DNS traffic.

# system-config-securitylevel

and choose the Customize button. Add port 53:udp if it isn't there already.

Or you could add the entry in manually in /etc/sysconfig/iptables.

Restart iptables:

# service iptables restart

That might help. If not, on to your DNS configuration...
 
Old 09-14-2007, 05:08 PM   #3
thelvaci
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Rep: Reputation: 0
Hi Benso37,

The DNS servers can be one of cached or primary. It seems your intent is to set a primary one. You have to ensure resolve.conf must point to localhost.

Try rndc restart command if rndc key is ok.

You should check if DNS server works with nslookup command.
set q=mx
hp.com
for example.

You can try host ns1.yahoo.com <your IP> command to check how your DNS server is recognized by yahoo.

Apart from all of these please read some nice articles on setting up primary DNS servers.

Hope this helps...
 
Old 09-15-2007, 09:10 AM   #4
ktask
LQ Newbie
 
Registered: Sep 2006
Location: Victoria, Texas
Distribution: Redhat, Ubuntu, Xandros, Linspire
Posts: 2
Blog Entries: 1

Rep: Reputation: 2
DNS Server Question ...

A forwarder is for the purpose of resolving domain name queries for which your own DNS is not the authority. The DNS servers for such purpose (resolving TLD) should not and do not need a zone defined in your own records, just an "option".

Looking at the definitions of zones it appears you might be attempting to use opendns.org for outside resolution and the features that opendns offers.

Please see: opendns dot com the Support Section and setup of DNS.

Suggest commenting out:

// zone "opendns." IN {
// type forward;
// forwarders { 208.67.220.220 port 53;

and just before the }; that ends the options section of your DNS configuration, add:

forwarders {208.67.220.220;[other IP's];};

Note the semi-colon at the end of each IP is necessary as well as the closing };.

save the file

then check your named.conf syntax with this command as root user:

/usr/sbin/named-checkconf

restart DNS: /sbin/service named restart

then go to workstation to check.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
A dns server question adrianmak Linux - Software 3 09-20-2005 12:24 AM
Yet Another N00b Question, want to create my own DNS/Web Server Rage2132 Linux - Networking 6 04-25-2005 09:04 AM
noob question, what can I do with a dns server? ziggie216 Linux - General 7 11-11-2003 08:28 PM
Quick DNS server Question bankrupt Linux - Networking 2 08-22-2003 03:56 PM


All times are GMT -5. The time now is 09:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration