LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-07-2012, 09:39 PM   #1
Kipkay211
LQ Newbie
 
Registered: Nov 2011
Location: Kingsport, TN
Distribution: Ubuntu, Slackware
Posts: 25

Rep: Reputation: 1
Question Display problem with screen when booting up Slackware 13.37


Sorry I'm very new to Slackware and only know how to basically turn the computer on. I'm having trouble booting Slackware 13.37, I have somehow managed to install it and restarted the system but every time I try booting it starts the black screen with fast scrolling words (like normal) and after so long the screen goes all black (no words) and a box appears and says "input signal out of range change settings to 1280x1624-60hz" and the moniter goes to sleep. Any reasons this would happen or solutions for how to fix it is very much appreciated. Thank you for even looking at this thread and very much thanks for all replies.
 
Old 04-08-2012, 08:30 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,851

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Quote:
"input signal out of range change settings to 1280x1624-60hz"
This simply indicates you do not have a good xorg.conf configuration. There are thousands of video cards and chip sets, the correct one has not been detected for your system.

Here is a link to help. -->http://www.slackware.com/config/x.php

The doc on this site is very good for a first time user, and can help you sort your problems.

Once you have a good xorg.conf, Slackware will boot to init level 3, and not start the x window system. To test if it will run, type startx at the command line. If it works, you will need to edit /etc/inittab and change the line with 'initdefault to a 4 from 3.

Mine looks like this:

Quote:
# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
Then x will start on every boot.
 
Old 04-08-2012, 09:10 PM   #3
Kipkay211
LQ Newbie
 
Registered: Nov 2011
Location: Kingsport, TN
Distribution: Ubuntu, Slackware
Posts: 25

Original Poster
Rep: Reputation: 1
Thank you very much, I will try that as soon as possible and post back, and hopefully on Slackware.
 
Old 04-10-2012, 05:54 AM   #4
Kipkay211
LQ Newbie
 
Registered: Nov 2011
Location: Kingsport, TN
Distribution: Ubuntu, Slackware
Posts: 25

Original Poster
Rep: Reputation: 1
How do I do this, I tried Slackware but I can't figure it out, can it be like mor dricribed or simplified?
 
Old 04-10-2012, 08:01 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047
Which graphics hardware are you using?
Slackware doesn't but to a graphical login by default, so I don't think that a wrong Xorg configuration is the problem here, it is more likely that your problem is caused by kernel mode setting.
It is easy to test that: Start the machine and when the Lilo bootloader screen appears press the Tab key. A commandline will appear, type
Code:
Linux nomodeset
and press Enter to boot. If you can boot to the login then kernel mode setting is the culprit.
 
Old 04-10-2012, 09:04 AM   #6
yoK0
LQ Newbie
 
Registered: Apr 2012
Distribution: Slackware, CentOS
Posts: 29

Rep: Reputation: 0
Quote:
Originally Posted by camorri View Post
Once you have a good xorg.conf, Slackware will boot to init level 3, and not start the x window system. To test if it will run, type startx at the command line. If it works, you will need to edit /etc/inittab and change the line with 'initdefault to a 4 from 3.

Then x will start on every boot.
I believe you meant runlevel 5 instead of runlevel 4.

id:5:initdefault:
 
Old 04-10-2012, 10:05 AM   #7
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,851

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
yoKo - No.

This is a direct copy for 13.37 64 bit /etc/inittab file.

Quote:
# These are the default runlevels in Slackware:
# 0 = halt
# 1 = single user mode
# 2 = unused (but configured the same as runlevel 3)
# 3 = multiuser mode (default Slackware runlevel)
# 4 = X11 with KDM/GDM/XDM (session managers)
# 5 = unused (but configured the same as runlevel 3)
# 6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
Run level 5 is not used in Slack.
 
Old 04-10-2012, 10:58 AM   #8
yoK0
LQ Newbie
 
Registered: Apr 2012
Distribution: Slackware, CentOS
Posts: 29

Rep: Reputation: 0
Quote:
Originally Posted by camorri View Post
yoKo - No.

This is a direct copy for 13.37 64 bit /etc/inittab file.



Run level 5 is not used in Slack.
My bad then. Was it always like this ?
 
Old 04-10-2012, 11:57 AM   #9
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,851

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Quote:
Was it always like this ?
I can't say, I was a long time Mandrake - Mandriva user. Switched to Slack a little over a year ago, and that is the way its been since 13.0.
 
Old 04-10-2012, 05:21 PM   #10
Kipkay211
LQ Newbie
 
Registered: Nov 2011
Location: Kingsport, TN
Distribution: Ubuntu, Slackware
Posts: 25

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by TobiSGD View Post
Which graphics hardware are you using?
Slackware doesn't but to a graphical login by default, so I don't think that a wrong Xorg configuration is the problem here, it is more likely that your problem is caused by kernel mode setting.
It is easy to test that: Start the machine and when the Lilo bootloader screen appears press the Tab key. A commandline will appear, type
Code:
Linux nomodeset
and press Enter to boot. If you can boot to the login then kernel mode setting is the culprit.


Ok, typed this, entered the closest resolution to my screen (324) and it went along as norm untill the screen went all black came back then all black again and back again and a message appeared.

******************************************************************
*** An error occurred during the root file system check. ***
*** You will now be given a chance to log into the ***
*** system in single-user mode to fix the problem. ***
*** ***
*** If you are using the ext2 file system, running ***
*** 'e2fsck -v -y <partition>' might help. ***
******************************************************************

Once you exit the single-user shell, the system will reboot.


Type control-d to proceed with normal startup,
(or give root password for system maintenance):

Any one have anything?

Last edited by Kipkay211; 04-10-2012 at 05:23 PM.
 
Old 04-10-2012, 06:49 PM   #11
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047
That is rather strange, the display options should have nothing to do with your filesystems. Are you sure that your machine is working correctly? Does it work with other operating systems?
 
Old 04-10-2012, 06:58 PM   #12
Kipkay211
LQ Newbie
 
Registered: Nov 2011
Location: Kingsport, TN
Distribution: Ubuntu, Slackware
Posts: 25

Original Poster
Rep: Reputation: 1
Yes it does, I'm currently running Ubuntu on it and I also just had windows (which I'm replacing with Slackware, or at least tring to).
 
Old 05-08-2012, 05:12 PM   #13
Kipkay211
LQ Newbie
 
Registered: Nov 2011
Location: Kingsport, TN
Distribution: Ubuntu, Slackware
Posts: 25

Original Poster
Rep: Reputation: 1
Cool

I have a long long story but I'll make it short, reloaded onto hdd and rebooted, stopped at splash screen and reported an error, changed from a 04 socket 775 intel CPU to a Anthlon 64 x2 AMD CPU and it boots and I have also (with some help) got my printer and Internet to work so thanks for all that helped.
 
  


Reply

Tags
booting, screen resolution, slackware 13.37


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no display screen is came after booting in fedora vipin_jss Linux - Software 3 08-18-2007 08:40 AM
Problem withChanging DISPLAY environment variable to display on someone else's screen wantsri Linux - Networking 1 10-25-2005 11:14 AM
Problem With Display Screen Frequency (Hz) Xavius Slackware 17 01-03-2005 07:15 AM
full screen display problem misophist Linux - General 0 09-02-2003 01:52 PM


All times are GMT -5. The time now is 02:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration