LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Display problem with screen when booting up Slackware 13.37 (http://www.linuxquestions.org/questions/linux-newbie-8/display-problem-with-screen-when-booting-up-slackware-13-37-a-938694/)

Kipkay211 04-07-2012 09:39 PM

Display problem with screen when booting up Slackware 13.37
 
Sorry I'm very new to Slackware and only know how to basically turn the computer on. I'm having trouble booting Slackware 13.37, I have somehow managed to install it and restarted the system but every time I try booting it starts the black screen with fast scrolling words (like normal) and after so long the screen goes all black (no words) and a box appears and says "input signal out of range change settings to 1280x1624-60hz" and the moniter goes to sleep. Any reasons this would happen or solutions for how to fix it is very much appreciated. Thank you for even looking at this thread and very much thanks for all replies.

camorri 04-08-2012 08:30 AM

Quote:

"input signal out of range change settings to 1280x1624-60hz"
This simply indicates you do not have a good xorg.conf configuration. There are thousands of video cards and chip sets, the correct one has not been detected for your system.

Here is a link to help. -->http://www.slackware.com/config/x.php

The doc on this site is very good for a first time user, and can help you sort your problems.

Once you have a good xorg.conf, Slackware will boot to init level 3, and not start the x window system. To test if it will run, type startx at the command line. If it works, you will need to edit /etc/inittab and change the line with 'initdefault to a 4 from 3.

Mine looks like this:

Quote:

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
Then x will start on every boot.

Kipkay211 04-08-2012 09:10 PM

Thank you very much, I will try that as soon as possible and post back, and hopefully on Slackware.

Kipkay211 04-10-2012 05:54 AM

How do I do this, I tried Slackware but I can't figure it out, can it be like mor dricribed or simplified?

TobiSGD 04-10-2012 08:01 AM

Which graphics hardware are you using?
Slackware doesn't but to a graphical login by default, so I don't think that a wrong Xorg configuration is the problem here, it is more likely that your problem is caused by kernel mode setting.
It is easy to test that: Start the machine and when the Lilo bootloader screen appears press the Tab key. A commandline will appear, type
Code:

Linux nomodeset
and press Enter to boot. If you can boot to the login then kernel mode setting is the culprit.

yoK0 04-10-2012 09:04 AM

Quote:

Originally Posted by camorri (Post 4647653)
Once you have a good xorg.conf, Slackware will boot to init level 3, and not start the x window system. To test if it will run, type startx at the command line. If it works, you will need to edit /etc/inittab and change the line with 'initdefault to a 4 from 3.

Then x will start on every boot.

I believe you meant runlevel 5 instead of runlevel 4.

id:5:initdefault:

camorri 04-10-2012 10:05 AM

yoKo - No.

This is a direct copy for 13.37 64 bit /etc/inittab file.

Quote:

# These are the default runlevels in Slackware:
# 0 = halt
# 1 = single user mode
# 2 = unused (but configured the same as runlevel 3)
# 3 = multiuser mode (default Slackware runlevel)
# 4 = X11 with KDM/GDM/XDM (session managers)
# 5 = unused (but configured the same as runlevel 3)
# 6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
Run level 5 is not used in Slack.

yoK0 04-10-2012 10:58 AM

Quote:

Originally Posted by camorri (Post 4649325)
yoKo - No.

This is a direct copy for 13.37 64 bit /etc/inittab file.



Run level 5 is not used in Slack.

My bad then. Was it always like this ?

camorri 04-10-2012 11:57 AM

Quote:

Was it always like this ?
I can't say, I was a long time Mandrake - Mandriva user. Switched to Slack a little over a year ago, and that is the way its been since 13.0.

Kipkay211 04-10-2012 05:21 PM

Quote:

Originally Posted by TobiSGD (Post 4649209)
Which graphics hardware are you using?
Slackware doesn't but to a graphical login by default, so I don't think that a wrong Xorg configuration is the problem here, it is more likely that your problem is caused by kernel mode setting.
It is easy to test that: Start the machine and when the Lilo bootloader screen appears press the Tab key. A commandline will appear, type
Code:

Linux nomodeset
and press Enter to boot. If you can boot to the login then kernel mode setting is the culprit.



Ok, typed this, entered the closest resolution to my screen (324) and it went along as norm untill the screen went all black came back then all black again and back again and a message appeared.

******************************************************************
*** An error occurred during the root file system check. ***
*** You will now be given a chance to log into the ***
*** system in single-user mode to fix the problem. ***
*** ***
*** If you are using the ext2 file system, running ***
*** 'e2fsck -v -y <partition>' might help. ***
******************************************************************

Once you exit the single-user shell, the system will reboot.


Type control-d to proceed with normal startup,
(or give root password for system maintenance):

Any one have anything?

TobiSGD 04-10-2012 06:49 PM

That is rather strange, the display options should have nothing to do with your filesystems. Are you sure that your machine is working correctly? Does it work with other operating systems?

Kipkay211 04-10-2012 06:58 PM

Yes it does, I'm currently running Ubuntu on it and I also just had windows (which I'm replacing with Slackware, or at least tring to).

Kipkay211 05-08-2012 05:12 PM

I have a long long story but I'll make it short, reloaded onto hdd and rebooted, stopped at splash screen and reported an error, changed from a 04 socket 775 intel CPU to a Anthlon 64 x2 AMD CPU and it boots and I have also (with some help) got my printer and Internet to work so thanks for all that helped.


All times are GMT -5. The time now is 10:55 AM.