LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-06-2004, 07:49 PM   #1
plainwlkr8
LQ Newbie
 
Registered: Feb 2004
Location: niagara ny
Distribution: redhat 9
Posts: 10

Rep: Reputation: 0
display problem


ive tried fixing my display. im running rh 9 and i use gedit to configure my XF86Config file. the highest res i can get (and its been higher before) is only 1024x786. ive added other resolutions but they just erase when i add them, and save them to the file. here is my config.

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x786" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

do i need to make another default depth? refresh rates are horizontal 60-90 kHz, vertical are 50-160 Hz. my monitor is a mag innovision 996PF. what do i need to change so i can add more modes?
 
Old 02-06-2004, 07:50 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
Did you edit the file as a normal user or as root?
 
Old 02-06-2004, 07:53 PM   #3
plainwlkr8
LQ Newbie
 
Registered: Feb 2004
Location: niagara ny
Distribution: redhat 9
Posts: 10

Original Poster
Rep: Reputation: 0
as root yes
 
Old 02-06-2004, 08:01 PM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
where do you put the new resolution(s)? It/they should go before the "1024x768" in quotes. Then save the file.
 
Old 02-06-2004, 08:04 PM   #5
plainwlkr8
LQ Newbie
 
Registered: Feb 2004
Location: niagara ny
Distribution: redhat 9
Posts: 10

Original Poster
Rep: Reputation: 0
i put them before the listed resolutions but when i save and then restart, it erases them so only the 3 are there
 
Old 02-06-2004, 08:07 PM   #6
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
Are you editing the XF86Config file or the XF86Config-4 file? Do you see the Nvidia logo screen when you boot up?
 
Old 02-06-2004, 08:25 PM   #7
plainwlkr8
LQ Newbie
 
Registered: Feb 2004
Location: niagara ny
Distribution: redhat 9
Posts: 10

Original Poster
Rep: Reputation: 0
XF86Config, no i dont see any nvidia logos when i start up
 
Old 02-06-2004, 08:30 PM   #8
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
If no Nvidia logo, that means that the driver isn't being seen. AFAIK, XF86Config hasn't been used for quite a while. You will need to edit XF86Config-4 - just repeat the changes you made on XF86Config in XF86Config-4. Restart X and let me know if your nvidia logo is coming up and if your new resolution is working.
 
Old 02-06-2004, 08:39 PM   #9
plainwlkr8
LQ Newbie
 
Registered: Feb 2004
Location: niagara ny
Distribution: redhat 9
Posts: 10

Original Poster
Rep: Reputation: 0
dont know what the XF86Config-4 is, im using rh 9, theres only XF86Config and .backup
 
Old 02-06-2004, 08:41 PM   #10
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
Try issuing whereis XF86Cconfig that should bring up all variations of the file. I have used RH9 and that file should be there.
 
Old 02-06-2004, 08:46 PM   #11
plainwlkr8
LQ Newbie
 
Registered: Feb 2004
Location: niagara ny
Distribution: redhat 9
Posts: 10

Original Poster
Rep: Reputation: 0
[joe@localhost joe]$ whereis XF86Cconfig
XF86Cconfig:


thats all that comes up, im going to reinstall my drivers for nvidia and see if that works.
 
Old 02-07-2004, 03:37 AM   #12
jerrymei
LQ Newbie
 
Registered: Feb 2004
Distribution: Red Hat
Posts: 20

Rep: Reputation: 0
Hi,

So files shouldn't be modified manually or changes will be lost. I don't know but my be XF86Config file is that type. So I think it worths if you use the preferences command in the start menu to change your resolution.

Hope it would be useful.
 
Old 02-09-2004, 06:54 PM   #13
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
I'm guessing he made a typo. Try whereis XF86Config and whereis XF86config
 
Old 02-10-2004, 02:31 PM   #14
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
Yep - it was a typo. Many apologies. whereis xf86config, issued as root is the correct command.

Apologies again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem withChanging DISPLAY environment variable to display on someone else's screen wantsri Linux - Networking 1 10-25-2005 12:14 PM
display problem. bruse Linux - Newbie 1 10-19-2005 09:22 AM
Display problem firefly87 Linux - Hardware 4 09-18-2005 02:19 PM
Display problem aviceda Mandriva 0 07-10-2004 06:05 PM
RH9 Shrike /sbin/loader display problem with SIS 630 laptop - display is blank ! johnvoisey Red Hat 4 11-01-2003 07:52 AM


All times are GMT -5. The time now is 02:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration