LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-14-2012, 05:32 AM   #1
Karita
LQ Newbie
 
Registered: Jul 2012
Posts: 1

Rep: Reputation: Disabled
Display not set


Going round in circles.

I'm trying to get Xming working but nothing is happening when I try and start an xterm using Xlaunch. I've also tried using plink directly: -

plink -ssh -X me@666.666.666.666 xterm

but I get

xterm Xt error: Can't open display:
xterm: DISPLAY is not set

my sshd_config has as required
X11Forwarding yes

I can SSH into the server no problem using putty.

Xming troubleshooting tells me DISPLAY should be set.

I'm confused and don't really know where to look next. It feels likes I'm going round in circles.

Any help appreciated.
 
Old 07-15-2012, 04:00 PM   #2
Elv13
Member
 
Registered: Apr 2006
Location: Montreal,Quebec
Distribution: Gentoo
Posts: 825

Rep: Reputation: 128Reputation: 128
You could install a virtual machine instead of trying to setup xming. Then use that VM to interact with your server.

As for the current problem, be sure the sshd config on the server all X11 redirection.
 
Old 07-20-2012, 11:43 AM   #3
cool_bub
LQ Newbie
 
Registered: Jul 2012
Posts: 1

Rep: Reputation: Disabled
You need to set the DISPLAY on your remote server:

> DISPLAY=<your local ip>:0.0; export DISPLAY

Using Xming's XLaunch you can check "No Access Control", but this is not recommended. This will allow connections from any outside server. Safer solution is to add the IP of your remote server to the X0.hosts file. By default, Xming only allows connections only from localhost when access control is on. You can find the X0.hosts file where you installed Xming.

Ex: C:\Progam Files\Xming\X0.hosts

Good Luck!
John
 
Old 07-20-2012, 12:42 PM   #4
Buibui
LQ Newbie
 
Registered: Dec 2011
Posts: 1

Rep: Reputation: Disabled
Hello Karita,

You may try MobaXterm : it is a single executable with no setup required, there is no need to configure anything, you just start it and you have a cool SSH client with a full X11 server correctly configured.

- Download and run MobaXterm
- In MobaXterm terminal, just type your ssh command
e.g. ssh root@myserver
- type xclock

It's just that simple: your xclock application will be displayed on your local computer. No need to change your DISPLAY environment variable, MobaXterm will handle this for you.

I hope this helps!
 
Old 07-20-2012, 12:53 PM   #5
dmdeb
Member
 
Registered: Jul 2007
Location: Germany
Distribution: Debian
Posts: 45

Rep: Reputation: 6
Quote:
Originally Posted by cool_bub View Post
You need to set the DISPLAY on your remote server:

> DISPLAY=<your local ip>:0.0; export DISPLAY

Using Xming's XLaunch you can check "No Access Control", but this is not recommended. This will allow connections from any outside server. Safer solution is to add the IP of your remote server to the X0.hosts file. By default, Xming only allows connections only from localhost when access control is on. You can find the X0.hosts file where you installed Xming.

Ex: C:\Progam Files\Xming\X0.hosts

Good Luck!
John
And if you don't want to do that for some reason, you can provide the DISPLAY setting with the ssh command line:

ssh -X user@targetmachine DISPLAY=clientmachine:0.0 xterm

... or the like.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
display preferences can not be set Phil Reid Linux - Newbie 0 08-24-2009 02:37 PM
$display not set (help) Alexander.s Linux - Hardware 1 10-27-2004 04:11 PM
$DISPLAY is not set? radub Slackware 8 10-23-2004 10:40 AM
set DISPLAY variable W1pEout[64] Linux - Software 4 01-07-2004 10:41 AM
set and display workspace name xconspirisist Linux - Software 13 10-06-2003 05:28 PM


All times are GMT -5. The time now is 12:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration