LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-25-2013, 10:27 PM   #1
tmortred
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Rep: Reputation: Disabled
display chinese character in a termial


Hello everyone ! I am new to debian .I have install debian yesterday .but now i do not how to display chinese character in a termial .nor do i can view pdf document in a termial .
if i can solve this two questions ,It can be a good benefits to me !
can anyone give me some tips
 
Old 03-26-2013, 12:30 AM   #2
shivaa
Senior Member
 
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,800
Blog Entries: 4

Rep: Reputation: 286Reputation: 286Reputation: 286
Well, simply you can't! A terminal cannot display two languages or two different font type at a time.

Also a terminal accepts only 'monospace' fonts, so you have an option to download chinese font that is hinted in 'monospace' style. Copy it in /usr/share/fonts/truetype directory and then change font setting in terminal and choose your chinese mono font instead of default mono sans font.
 
Old 03-26-2013, 10:17 AM   #3
tmortred
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
yes ,thank you ! now I am try my best to change font setting in a termial !
 
Old 03-26-2013, 06:00 PM   #4
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958
Modern linux and modern consoles like bash are generally UTF-8 compliant, which means they are capable of displaying any language (I have no problem with Japanese in mine). You just have to make sure that the text being displayed is also in UTF-8 format, and that the font you're using also supports the language (most unicode fonts will support most major languages).

If your text files use another encoding, you can usually use iconv to convert them. And for filenames, there's convmv. Also check the mount settings for your storage devices for character conversion settings.

Text entry of CJK languages generally just requires an IME framework, like iBus or SCIM, and the appropriate backend. These generally only work in the gui environment though, so you may have a hard time manipulating files with non-western names if you ever have to use a non-gui terminal.
 
Old 03-26-2013, 06:30 PM   #5
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Hiding somewhere on planet Earth.
Distribution: OpenBSD
Posts: 1,644
Blog Entries: 8

Rep: Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577
There is also a package called mlterm (multi-lingual terminal) that can be useful. As David the H. already stated, it also requires IBus (my preferred) or SCIM to input characters.
 
Old 03-28-2013, 09:17 PM   #6
tmortred
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
[QUOTE=David the H.;4919478]Modern linux and modern consoles like bash are generally UTF-8 compliant, which means they are capable of displaying any language (I have no problem with Japanese in mine). You just have to make sure that the text being displayed is also in UTF-8 format, and that the font you're using also supports the language (most unicode fonts will support most major languages).

Thank for your help ! In fact , when I execute the command dpkg-reconfigure locales ,set the default LANG=en_US.UTF-8 . the Xterm can display the chinese character ,but in termial (that means I have just login the tty ) it display the square instead of chinese . also ,I have tried to set LANG=ZH_CN.UTF-8. then when I execute dpkg-reconfigure locales ,the termial display many squares .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] where to set to display chinese chinese characters vitalstrike82 Slackware 4 11-17-2012 03:38 AM
Insert chinese character tahrenyie85 Linux - Newbie 2 01-03-2008 04:59 AM
Read Chinese character ust Linux - Software 1 05-17-2006 05:53 AM
Chinese Character display firefox/mozilla crnchyfrog Linux - Software 6 10-10-2004 11:30 PM
chinese character input and display -- need help carboncopy Slackware 5 07-06-2004 09:12 PM


All times are GMT -5. The time now is 04:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration