LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-09-2004, 08:18 PM   #1
ako
Member
 
Registered: Nov 2003
Location: Manila, Philippines
Distribution: Red Hat 9.0, Suse 9.0, Bayanihan Linux 3.0
Posts: 69

Rep: Reputation: 15
disabling x-windows autologin in Suse .0


Opensourcerers,

I would like to ask how to disable the automatic login in Suse's X-windows?
whenever my systme boot up... it automatically logs in my user account, how will set Suse to ask login name and password first...? please do help me...

Thanx...

-AKO-
 
Old 02-09-2004, 10:04 PM   #2
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
I think it's /etc/sysconfig/displaymanager

Change the DISPLAYMANAGER_AUTOLOGIN to "no" or null, and I think you're set.
 
Old 02-10-2004, 04:51 AM   #3
ako
Member
 
Registered: Nov 2003
Location: Manila, Philippines
Distribution: Red Hat 9.0, Suse 9.0, Bayanihan Linux 3.0
Posts: 69

Original Poster
Rep: Reputation: 15
Yo Milkshaw,

Ihave already tried what you have suggested but it is still the same...
I tried changing the DISPLAYMANAGER_AUTOLOGIN to "no" or null but It still boots up with my user account, by the way there is also one more thing that is confusing me... whenever I'm trying to edit the file displaymanager it prompts me that I am trying to change a read only file... does this has something to do why it doesn't work even if I already changed it...?

Thanx...

-AKO-
 
Old 02-10-2004, 03:23 PM   #4
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
Probably. You need root access to edit system files. Open up the file again and see if your changes were kept. If the changes did not stick, type su, then the root password, and then open the file in that same terminal (e.g. vim /etc/sysconfig/displaymanager).
You might also start up yast2 instead, but in this case all it's doing is giving you a graphical gateway to the same file.
 
Old 02-11-2004, 12:49 AM   #5
DigitalVampire
LQ Newbie
 
Registered: Feb 2004
Distribution: SUSE 9.0
Posts: 6

Rep: Reputation: 0
Graphical Way

Try the graphical approach, click the Start Button Simliar Type Icon, while in X, and choose Control Panel (You Will Need To Be Root To Make These Changes) Look For An Administration Option, upon which you should find a Login Manager option, click it and look around in the tabs it displays one should have autologin checked, just uncheck it .
Hope that helps!
DV
 
Old 02-11-2004, 12:59 AM   #6
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
You could do that, too. Since it's a KDE-specific method, though, I tried to avoid it in the event that ako doesn't have KDE.




...ok, I'm lying. I just don't know anything about KDE....
 
Old 02-11-2004, 02:30 AM   #7
ako
Member
 
Registered: Nov 2003
Location: Manila, Philippines
Distribution: Red Hat 9.0, Suse 9.0, Bayanihan Linux 3.0
Posts: 69

Original Poster
Rep: Reputation: 15
Opensourcerers,

It all workin' now, thanx...

-AKHMAD-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
suse 10 autologin..(dont want that) nikoz SUSE / openSUSE 2 11-17-2005 06:52 PM
Activating/Disabling the autologin videoediting Programming 3 04-05-2005 11:44 PM
Problems with autologin SUSE 9.1 torpedo Linux - Newbie 3 08-18-2004 04:17 AM
disabling autologin nacha Debian 5 05-30-2004 06:45 PM
Disabling X Windows sleep kernelpanicguy Linux - Software 1 09-14-2003 12:12 AM


All times are GMT -5. The time now is 07:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration