LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-04-2006, 09:16 AM   #1
Rostfrei
Member
 
Registered: Aug 2005
Location: Slovenia
Distribution: Fedora, Ubuntu
Posts: 69

Rep: Reputation: 15
Disabling X on startup and few configurations help


Hello!

I know that I while ago I was reading some howtos (don't remeber which) and I read that you can configure one file where you tell if X server will start at boot or not. Which file is that? As I remember it was yust one number change. I want to start X manualy.

I have newly installed Debian 3.1 with Gnome. I have few more questions:
- How to kill X when I go to text-mode console with Crl-F2? Because; when I startx there, it tells me that X is already running.
- Do native X11 and in my case Gnome use the same configuration file? I have wery old monitor and I have succesfuly configured it to 800x600 56Hz refresh rate (trough "Screen Resolution" setting). When I logout to login screen, this setting is discarded and I barely see anything because of the wrong settings for the monitor refresh rate. Cycling trough settings with Ctrl,Alt,+ does not help either (if I'm loged in and everything is ok and I start cycling between settings I cannot cycle to OK setting again...weird!)

Please help someone...its quite frustrating start....not to mention that I set to "Slovenian" keyboard, but still can't type specific characters (but about that another time).

Best regards,
 
Old 03-04-2006, 09:24 AM   #2
ckoniecny
Member
 
Registered: Oct 2005
Posts: 162

Rep: Reputation: 30
Change your init level in /etc/inittab.
 
Old 03-04-2006, 09:28 AM   #3
Rostfrei
Member
 
Registered: Aug 2005
Location: Slovenia
Distribution: Fedora, Ubuntu
Posts: 69

Original Poster
Rep: Reputation: 15
which line to which value?
 
Old 03-04-2006, 09:32 AM   #4
ckoniecny
Member
 
Registered: Oct 2005
Posts: 162

Rep: Reputation: 30
search for the line "init" and then change the runlevel from 4 to 3.
 
Old 03-04-2006, 09:46 AM   #5
Rostfrei
Member
 
Registered: Aug 2005
Location: Slovenia
Distribution: Fedora, Ubuntu
Posts: 69

Original Poster
Rep: Reputation: 15
By default in the inittab file it is:

# The default runlevel
id:2:initdefault:


...so I can't change from 4 to 3 because it is already 2 and gnome is still stated...
 
Old 03-04-2006, 11:04 AM   #6
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
Hello,
Quote:
Originally Posted by Rostfrei
Hello!
I know that I while ago I was reading some howtos (don't remeber which) and I read that you can configure one file where you tell if X server will start at boot or not. Which file is that? As I remember it was yust one number change. I want to start X manualy.

I have newly installed Debian 3.1 with Gnome. I have few more questions:
- How to kill X when I go to text-mode console with Crl-F2? Because; when I startx there, it tells me that X is already running.
- Do native X11 and in my case Gnome use the same configuration file? I have wery old monitor and I have succesfuly configured it to 800x600 56Hz refresh rate (trough "Screen Resolution" setting). When I logout to login screen, this setting is discarded and I barely see anything because of the wrong settings for the monitor refresh rate. Cycling trough settings with Ctrl,Alt,+ does not help either (if I'm loged in and everything is ok and I start cycling between settings I cannot cycle to OK setting again...weird!)

Please help someone...its quite frustrating start....not to mention that I set to "Slovenian" keyboard, but still can't type specific characters (but about that another time).

Best regards,
To kill X when it is already simply do "Ctrl+Alt+Backspace" (to work the DontZap option must be disable in server config file)
To prevent X from being started, use "rc-update" to disable the execution of X in runlevel 2
 
Old 03-04-2006, 11:09 AM   #7
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Debian is a bit different to most linux distros when it comes to runlevels. To prevent X starting at boot up, do
Code:
#update-rc.d -n -f gdm remove
to enable X at boot up you would do
Code:
#update-rc.d -n gdm defaults
To just stop X whilst already logged in, do
Code:
#/etc/init.d/gdm stop
to start X,
Code:
#/etc/init.d/gdm start
 
Old 03-05-2006, 01:22 PM   #8
Rostfrei
Member
 
Registered: Aug 2005
Location: Slovenia
Distribution: Fedora, Ubuntu
Posts: 69

Original Poster
Rep: Reputation: 15
Thank you reddazz! That it exactly what I needed!
 
Old 05-02-2006, 05:52 PM   #9
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
or use
# update-rc.d -f ?dm remove stop 1 2 3 4 5 6

if you have multiple login managers

This is from
http://linux.derkeiler.com/Mailing-L...3-08/4607.html
 
  


Reply

Tags
disabling, xwindows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
disabling ethernet at startup tedivm Linux - Newbie 2 08-18-2004 03:33 AM
Disabling startup services Corallis Fedora 2 08-02-2004 11:51 AM
Disabling Sendmail on startup? BajaNick Linux - Software 3 02-01-2004 09:53 PM
Disabling Hardware Check at startup Psykoral Mandriva 4 11-18-2003 06:16 PM
Disabling Startup Services loadedmind Slackware 7 11-07-2003 09:36 PM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration