LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-30-2005, 10:15 AM   #1
Joe2003
Member
 
Registered: May 2005
Distribution: Core 4
Posts: 34
Blog Entries: 2

Rep: Reputation: 15
disabling X and keyboard/mouse


HI

Were tring to set up a server, when I disconnect the mouse or keyboard an error occurs on startup, is there away to enable the computer so it doesnt require a keyboard and mouse on startup??

Also, it automatically opens up in X windows, can this be disabled to????

thanks
joe
 
Old 07-30-2005, 10:36 AM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
If the keyboard/mouse problem occurs before linux is booting (most likely) then you'll need to check with your BIOS vendor on that. On at least one of my headless machines I have to leave a keyboard connected to get it to boot.

Depending on your distribution, X can be disabled by changing the startup scripts or default runlevel. What distro do you have?
 
Old 07-30-2005, 06:15 PM   #3
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
The BIOS should have an option called "Halt On" or something similar to that. You can change to All Except Keyboard. I have seen this on Award and Pheonix BIOS.

Edit /etc/inittab. Look for default level. Level 3 should be a good level for a server. Usually level 5 or 4 is the GUI. You can use chkconfig (Redhat based distributions using System V init scripts) or env-update (Gentoo) to list, turn on, or turn off services for certain runlevels.
 
Old 07-31-2005, 04:02 AM   #4
Joe2003
Member
 
Registered: May 2005
Distribution: Core 4
Posts: 34
Blog Entries: 2

Original Poster
Rep: Reputation: 15
Thanks

im using core 1, ive managed to disable X, the mouse and keyboard. The next problem is if I leave it on, (but not in X) it goes to sleep after about 30mins of running and needs mouse/keyboard input to awaken it, is there away to sort this??
 
Old 07-31-2005, 12:25 PM   #5
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
Most likely this is an ACPI function, so look and see if anything is defined in /etc/acpi.d/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
disabling the right mouse button in icewm rhaley Linux - Software 0 06-03-2005 04:21 PM
disabling side buttons on wireless mouse bradleyw Linux - Hardware 3 02-02-2005 02:27 AM
Keyboard on suse 8.2, disabling 1 key !? iner Linux - Hardware 0 09-04-2004 10:30 AM
disabling keyboard until completely booted thebover Linux - Hardware 0 08-23-2004 03:41 PM
Disabling the Mouse pointer jgabe_link Linux - General 3 01-30-2004 11:41 PM


All times are GMT -5. The time now is 07:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration