LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-14-2011, 01:12 PM   #1
ADX
Member
 
Registered: Jul 2011
Location: 127.0.0.1
Distribution: Slackware64-13.37
Posts: 47

Rep: Reputation: 0
Disabling USB automount (KDE)


When I plug in a removable device, KDE automounts it, but I prefer to do this manually (also perhaps not liking the idea that any user could plug a device in and have it mounted). I've searched around and looked at KDE -> System Settings -> Removable Devices, and "Enable automatic mounting of removable devices" is already unchecked.

Any tips would be appreciated. Thanks

Last edited by ADX; 07-14-2011 at 01:20 PM.
 
Old 07-14-2011, 02:19 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,764

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
Look through the udev rules in /etc/udev. Find the rule that automounts usb devices and comment out the rule. I recommend comment out rather that edit out, just in case something comes up later and you want to use that rule again.
 
Old 07-14-2011, 05:07 PM   #3
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Rep: Reputation: 48
Quote:
Originally Posted by ADX View Post
When I plug in a removable device, KDE automounts it, but I prefer to do this manually (also perhaps not liking the idea that any user could plug a device in and have it mounted). I've searched around and looked at KDE -> System Settings -> Removable Devices, and "Enable automatic mounting of removable devices" is already unchecked.

Any tips would be appreciated. Thanks
I had the reverse problem and the solution was to *include* the 'plugdev' group in my user profile.

Maybe *excluding* the 'plugdev' from your user profile will do it.
 
1 members found this post helpful.
Old 07-15-2011, 12:43 PM   #4
ADX
Member
 
Registered: Jul 2011
Location: 127.0.0.1
Distribution: Slackware64-13.37
Posts: 47

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Robert.Thompson View Post
I had the reverse problem and the solution was to *include* the 'plugdev' group in my user profile.

Maybe *excluding* the 'plugdev' from your user profile will do it.
That did it. I didn't realize at the time that only users in the "plugdev" group were allowed to use removable devices. As far as the notifications, it was just a matter of tweaking KDE's widgets.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automount USB drives in KDE Xeratul Linux - Software 5 05-21-2007 04:03 PM
USB automount in KDE 3.5.5? rothchild Ubuntu 0 10-17-2006 07:47 AM
disabling automount suse 9.1? cunokyle Linux - Distributions 0 06-10-2004 12:18 AM
Automount (disabling Konqueror?) syberspaz Linux - Newbie 2 11-20-2003 11:22 PM
Automount (Disabling Konqueror?) syberspaz Linux - Software 5 10-07-2003 08:18 PM


All times are GMT -5. The time now is 11:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration