LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-24-2009, 11:39 PM   #1
SheppardArc
LQ Newbie
 
Registered: May 2009
Posts: 1

Rep: Reputation: 0
Disabling Startup logo (Tux) in Debian


My aging iBook has been freezing recently, and I think the graphics card has been overheating recently whenever it displays a gui for an extended amount of time. I've been trying out console mode, in both OS X and Debian, and they both seem to work without freezing.

My problem is when Debian boots up and displays the Tux logo in the upper left, it seems to switch to a graphics mode which blanks out my screen and freezes my computer if I've been leaving it running for too long (due to the graphics card still being hot). There's no problem after the computer boots up further and the logo disappears. What's the easiest way to stay in a strictly console mode during start up, or trying to disable the startup logo? (I've already disabled gdm)

Thanks for any help.
 
Old 05-24-2009, 11:42 PM   #2
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
You would have to recompile the kernel to get rid of framebuffer support
 
Old 05-30-2009, 06:12 PM   #3
SheppardArc2
LQ Newbie
 
Registered: May 2009
Posts: 1

Rep: Reputation: 0
As an update, on menuconfig I found an option for disabling the startup logo, so I tried that out. I managed to get my kernel to recompile, and the logo did indeed disappear, but it didn't fix my problem; my computer still would go to a blank screen if I rebooted after leaving my computer on for too long.

I tried AceofSpade's suggestion, and disabled framebuffer support and recompiled the kernel, and now I have a problem that when I boot up, where it would normally switch to the framebuffered screen with a logo on it, it remains frozen on the wall of text of the nonframebuffered boot screen, without showing any of the remaining boot. I can still enter commands (I've logged in and shut down the computer) but the screen remains frozen on the text from boot.

Any suggestions?

Thanks.
 
Old 06-15-2009, 03:52 AM   #4
stoner_di
LQ Newbie
 
Registered: Jun 2009
Posts: 3

Rep: Reputation: 0
I want to ask someone tried to incorporate the bootup logo ( mini tux in the top left of the display to load the system).
Perform all necessary for this:
- when compiling the kernel, I select this:

Support for frame buffer devices FB->VESA VGA graphics support FB_VESA

Select all in the:

Console display driver support ->

selct all in the:

Bootup logo LOGO->

-in the GRUB, in the file menu.lst fix this row:

kernel /boot/vmlinuz-2.6.29.3 root=UUID=d5b52903-5…. video=vesafb vga=00323 ro quiet

-in the file /etc/modprobe.d/blacklist-framebuffer.conf, comment this row:

#blacklist vesafb

-in the file /etc/initramfs-tools/modules, add:

fbcon
vesafb

-in the end update initramfs this command:

update-initramfs -u

In all my UBUNTU not load boot logo!!!!!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change the tux logo during kernel boot kushalkoolwal Debian 3 10-20-2014 06:08 AM
Disabling startup services in Debian Etch swampdog2002 Debian 11 11-27-2007 09:13 AM
framebuffer during booting and the Tux Logo kushalkoolwal Debian 9 01-23-2006 02:57 AM
change tux logo Tuttle General 17 11-27-2005 07:15 PM
Missing tux logo in Sarge? uk_dave Debian 33 08-06-2004 08:17 PM


All times are GMT -5. The time now is 07:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration