LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-17-2011, 02:42 AM   #1
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Rep: Reputation: 40
Disabling SD reader? Error at boot (mmc0) DO NOT want to blacklist.


This may belong in the Laptop section, and I apologize if it belongs there. But I am new, and though I could get specified info here without being overcome with confusion ... Any who

I have a Fujitsu Lifebook S-2640,running dreamlinux,Xfce desktop, and it has a SD card reader on front. Everytime I boot up, I get


||MMC:0 Unknown controller version (16). may cause problems.||
_

Sometimes it freezes there and I have to re-boot until it will get past that (about 80% of the time, it loads fine though). What I have learned here,google, and some other forums is that my problem is most likely SD reader, and the lack of a linux friendly driver.
I have seen a few places that say to edit a file and blacklist, But I hear that doesn't work automatically on boot ... and don't want to edit files all willy-nilly if it doesn't serve the purpose.


I looked in USB viewer and found:
4 UHCI (Which I think is my USB ports)
and EHCI (Unless I read wrong, related to my 4 USBs)

and no SDHI...
So does anyone know of a way to just disable my reader? I never use cards so I could care less.
 
Old 04-17-2011, 03:03 AM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
In this post there's a file to edit that will turn it off & you can always turn back on when necessary.
http://goinggnu.wordpress.com/2009/1...ubuntu-laptop/
Look for this name a little past the half way point
Michel Finkel / Jan 3 2010 6:55 pm

I googled to change to enable after login so such luck.

Last edited by EDDY1; 04-17-2011 at 03:08 AM.
 
Old 04-17-2011, 03:46 AM   #3
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Take a look at this 1 if you haven't disabled.
https://bugs.launchpad.net/ubuntu/+s...ux/+bug/605043
 
Old 04-17-2011, 04:10 PM   #4
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
I am looking at those links now, First one is easier for me to understand it's set up for easy step by step. Looks like what I want ... Thanks alot for the help!
 
Old 04-17-2011, 04:11 PM   #5
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720
If the problem is solved, mark the thread as solved.
 
Old 04-17-2011, 04:59 PM   #6
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
Just marked it as solved ... Wasn't gonna call it solved when I hadn't even tried it yet :P

Links were useful, Me and the terminal don't get along, But I dug through the files manually, made my edit (I did use terminal to make a backup), restarted, and I am fine now. Thanks again.
 
Old 04-17-2011, 06:08 PM   #7
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Nice to know it worked.
 
Old 04-17-2011, 07:02 PM   #8
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720
To learn the terminal, see the tutorials in my sig (LinuxCommand is very newbie-oriented and easy to follow).
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling apache2 from boot brgsousa Linux - Software 5 05-21-2010 08:43 AM
Disabling Hard Drive on Boot-Up Completely Clueless Linux - Security 1 07-21-2008 03:03 PM
?Odd bug. modprobe.blacklist~ behaves as modprobe.blacklist arubin Slackware 1 11-05-2006 08:08 PM
Disabling apmd during boot seran Linux - General 4 12-20-2005 05:39 AM
network disabling on boot siku Linux - Laptop and Netbook 1 11-22-2004 10:38 AM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration