LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2009, 01:19 AM   #1
deepak_cucek
Member
 
Registered: Feb 2008
Posts: 36

Rep: Reputation: 16
Question disabling promiscous mode in suse


Hi guys

how to disable promiscous mode in suse..
i use the command ifconfig eth0 -promisc
but after restart the value is not taking affect....

is there any files i need to configure
 
Old 05-18-2009, 01:31 AM   #2
tuxtroll
LQ Newbie
 
Registered: May 2009
Posts: 11
Blog Entries: 1

Rep: Reputation: 0
edit the file "/etc/sysconfig/network-scripts/ifcfg-eth0" and add


PROMISC=yes
 
Old 05-18-2009, 01:43 AM   #3
deepak_cucek
Member
 
Registered: Feb 2008
Posts: 36

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by tuxtroll View Post
edit the file "/etc/sysconfig/network-scripts/ifcfg-eth0" and add


PROMISC=yes
in my machine there is no directory called "network -scripts"

but i tried in "/etc/sysconfig/network/ifcfg-eth-id-00f:fe:24:03:ab"
and add the entry PROMISC=yes
then i restart the machine. and check the promisc mode using "ifconfig" commmand , but still it doesnt take affect
 
Old 05-18-2009, 03:20 AM   #4
tuxtroll
LQ Newbie
 
Registered: May 2009
Posts: 11
Blog Entries: 1

Rep: Reputation: 0
it seems you are using debian or deian based linux distro eg ubuntu. in that case you need to add this line to

/etc/network/interfaces

under your interface (ethx) you can add

promisc on.

You dont need to restart computer to check it.
just execute this as root

service network restart
or
service networking restart
 
Old 05-18-2009, 03:28 AM   #5
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,335
Blog Entries: 55

Rep: Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535
Quote:
Originally Posted by tuxtroll View Post
edit the file "/etc/sysconfig/network-scripts/ifcfg-eth0" and add PROMISC=yes
The OP seeks to disable promiscuous mode, wouldn't this actually accomplish the opposite?..


Quote:
Originally Posted by deepak_cucek View Post
then i restart the machine. and check the promisc mode using "ifconfig" commmand , but still it doesnt take affect
Network cards should not enter promiscuous mode without reason. If setting "PROMISC=no" does not work can you tell us if ( as root) setting -promisc (man ifconfig) works? If not then there may be applications listening in promiscuous mode. You can list those easily with a small shell script like this:
Code:
INODES=$(grep /proc/net/packet -ve ^sk|awk '{print $9}'|tr ' ' '|');
INODES=${INODES[*]}; INODES=${INODES[*]// /|}; INODES="(${INODES})";
/usr/sbin/lsof -P -w -n -d 1-20 | egrep "${INODES}.c" | awk '{print $2}' | xargs -iX /usr/bin/readlink -f /proc/'X'/exe
 
Old 05-18-2009, 04:30 AM   #6
deepak_cucek
Member
 
Registered: Feb 2008
Posts: 36

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by tuxtroll View Post
it seems you are using debian or deian based linux distro eg ubuntu. in that case you need to add this line to

/etc/network/interfaces

under your interface (ethx) you can add

promisc on.

You dont need to restart computer to check it.
just execute this as root

service network restart
or
service networking restart
am using SuSe 10.......
even my machine dont have "/etc/network/interface"

the file that am currently editing contains all the information about the ethernet card like IP........
 
Old 05-18-2009, 05:48 AM   #7
deepak_cucek
Member
 
Registered: Feb 2008
Posts: 36

Original Poster
Rep: Reputation: 16
Unhappy

any help guys...............
 
Old 05-18-2009, 10:54 AM   #8
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,335
Blog Entries: 55

Rep: Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535Reputation: 3535
Quote:
Originally Posted by deepak_cucek View Post
any help guys.
There's no reason to act all confused. Just read more carefully.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NIC in Promiscous mode chingkhuba Linux - Security 1 04-17-2009 03:15 AM
IPW2200 Promiscous Mode Help pjenkins2006 Linux - Software 1 03-16-2006 01:54 PM
promiscous mode on wifi card s0lid Linux - Wireless Networking 3 12-10-2004 12:52 PM
Network card in Promiscous mode thetwin Linux - Security 2 07-29-2003 07:56 PM
eth0 is enabled in promiscous mode saravanan1979 Linux - Networking 11 06-15-2002 09:01 AM


All times are GMT -5. The time now is 08:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration