LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2009, 06:36 AM   #1
v_fone
Member
 
Registered: Feb 2009
Posts: 43

Rep: Reputation: 16
Disabling ntpd service


Hello everyone.

I have a Red Hat 5.2 and when the system start, it remains a lot of time with the ntp synchronization. If I log in the system in single user mode, Could I disable the ntpd service? Or there are other possibilities?
Thanks
 
Old 02-22-2009, 06:44 AM   #2
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Code:
/sbin/chkconfig ntpd off
should do.
 
Old 02-22-2009, 07:17 AM   #3
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529
Quote:
Originally Posted by v_fone View Post
Or there are other possibilities?
Does it throw any errors? What servers does it (try to) sync with ('ntpq -p | grep -e "^[\+|\*]"')?
 
Old 02-22-2009, 07:24 AM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
doesn't /etc/init.d/ntpd has this code:

Code:
# Check that networking is up.
[ ${NETWORKING} = "no" ] && exit 0

if [ -f /etc/sysconfig/ntpd ];then
        . /etc/sysconfig/ntpd
fi

Then you can start
/etc/init.d/ntpd
when the connection is up
 
Old 02-22-2009, 07:40 AM   #5
v_fone
Member
 
Registered: Feb 2009
Posts: 43

Original Poster
Rep: Reputation: 16
My problem is that I cant access to the login console and I cant enter on the system because ntpd services tries to synchronize (and it's impossible to do because is doesnt have internet connection). Due to this fact I thought to enter on the system as single user, and then disable the service, it's a good solution?
Thanks a lot!
 
Old 02-22-2009, 07:42 AM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
what happens when you press CTRL-C or CTRL-X?
when it stops at ntpd

Last edited by repo; 02-22-2009 at 07:44 AM.
 
Old 02-22-2009, 08:52 AM   #7
v_fone
Member
 
Registered: Feb 2009
Posts: 43

Original Poster
Rep: Reputation: 16
Thanks for your answers.
I think that I dont explain me so well.
The problem is, in graphical environment, when the system is starting and loading the modules ( I mean, when I turn on the machine) appears (more or less)
mounting file system --> ok
Bring up eth0 --> ok
Starting ntpd services --> And then it waits to synchronize and the minutes goes away and the system looks like locked

I want to disabled the service but I cant do on a normal way because it remains at this point.
Then, do you think If I enter on single user mode and use chkconfig everithing will be ok and the ntpd service appears no more?

Thanks and sorry for my poor english

Last edited by v_fone; 02-22-2009 at 09:00 AM.
 
Old 02-22-2009, 08:56 AM   #8
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Quote:
Originally Posted by v_fone View Post
Then, do you think If I enter on single user mode and use chkconfig everithing will be ok and the ntpd service not appear no more?
Yes.
 
Old 02-22-2009, 11:14 AM   #9
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Starting ntpd services --> And then it waits to synchronize and the minutes goes away and the system looks like locked

here you can press CTRL-C or CTRL-X
then it will continue loading.
Then you can disable or remove ntpd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
disabling service in Unix linuxfia Solaris / OpenSolaris 7 10-23-2008 06:00 PM
Disabling shutdown service shankarbrnair Fedora 4 10-26-2007 11:28 AM
Disabling the Windbind service. dougnc SUSE / openSUSE 2 01-29-2007 07:57 PM
Installed Software in Slackware 9.1 and disabling network service odin123 Slackware 5 10-25-2003 01:24 AM


All times are GMT -5. The time now is 06:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration