LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-15-2013, 02:45 AM   #1
mathieudutour
LQ Newbie
 
Registered: Jul 2013
Posts: 2

Rep: Reputation: Disabled
Disabling irq 16


I have a problem that I got the message "Disabling IRQ #16" when
the CPU goes idle. After which the system becomes slow.
dmesg shows following:

[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 3.2.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.6.3 (Debian 4.6.3-15) ) #1 SMP Debian 3.2.41-2
[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-amd64 root=UUID=b889045c-05ff-4a57-8fa9-ebb62ed6a61f ro irqpoll initrd=/install/gtk/initrd.gz quiet
.
.
.
[11630.162245] irq 16: nobody cared (try booting with the "irqpoll" option)
[11630.162252] Pid: 0, comm: swapper/4 Not tainted 3.2.0-4-amd64 #1 Debian 3.2.41-2
[11630.162255] Call Trace:
[11630.162257] <IRQ> [<ffffffff81092505>] ? __report_bad_irq+0x2c/0xb5
[11630.162270] [<ffffffff810928c2>] ? note_interrupt+0x170/0x1f2
[11630.162275] [<ffffffff81090c8c>] ? handle_irq_event_percpu+0x15f/0x17d
[11630.162281] [<ffffffff8101361a>] ? read_tsc+0x5/0x14
[11630.162284] [<ffffffff81090cde>] ? handle_irq_event+0x34/0x52
[11630.162291] [<ffffffff8106bd8d>] ? arch_local_irq_save+0x11/0x17
[11630.162295] [<ffffffff81093039>] ? handle_fasteoi_irq+0x7c/0xaf
[11630.162302] [<ffffffff8100f89d>] ? handle_irq+0x1d/0x21
[11630.162306] [<ffffffff8100f5cd>] ? do_IRQ+0x42/0x98
[11630.162312] [<ffffffff8134dc6e>] ? common_interrupt+0x6e/0x6e
[11630.162314] <EOI> [<ffffffff811afabc>] ? timerqueue_add+0x80/0xa0
[11630.162323] [<ffffffff811ed5cc>] ? intel_idle+0xed/0x119
[11630.162326] [<ffffffff811ed5a8>] ? intel_idle+0xc9/0x119
[11630.162333] [<ffffffff8126ecc3>] ? cpuidle_idle_call+0xec/0x179
[11630.162337] [<ffffffff8100d243>] ? cpu_idle+0xa5/0xf2
[11630.162342] [<ffffffff8133fc84>] ? start_secondary+0x1d5/0x1db
[11630.162345] handlers:
[11630.162367] [<ffffffffa000c069>] usb_hcd_irq
[11630.162370] Disabling IRQ #16

So, the linux kernel option "irqpoll" has no effec. I think it
is read since thedmesg shows that it is present, but it is not
efficient.
What can I do now?
 
Old 07-15-2013, 03:52 PM   #2
sag47
Senior Member
 
Registered: Sep 2009
Location: Orange County, CA
Distribution: Kubuntu x64, Raspbian, CentOS
Posts: 1,845
Blog Entries: 36

Rep: Reputation: 453Reputation: 453Reputation: 453Reputation: 453Reputation: 453
Need more info, what architecture and kernel version are you using?

Code:
uname -rms
 
Old 07-16-2013, 02:17 AM   #3
mathieudutour
LQ Newbie
 
Registered: Jul 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Computer is
Linux kotohira 3.2.0-4-amd64 #1 SMP Debian 3.2.41-2 x86_64 GNU/Linux
 
Old 07-17-2013, 10:37 AM   #4
sag47
Senior Member
 
Registered: Sep 2009
Location: Orange County, CA
Distribution: Kubuntu x64, Raspbian, CentOS
Posts: 1,845
Blog Entries: 36

Rep: Reputation: 453Reputation: 453Reputation: 453Reputation: 453Reputation: 453
After some google, this thread seems to indicate it has to do with graphics drivers. What graphics driver are you using? You should probably try changing it to another driver to see if it resolves the problem (or an updated driver if yours is out of date). I would even go so far as to update the firmware on my bios.

Code:
[11630.162245] irq 16: nobody cared (try booting with the "irqpoll" option)
It telling you to boot with the "irqpoll" option is something to take note. In the kernel documentation, the irqpoll option is a mode which tries to allow the kernel to load on a machine with misbehaving firmware. That doesn't necessarily mean your firmware/bios is the cause but if nothing else works I would go that route. Usually manufacturers make the process of updating bios relatively painless. If you have a battery backup for your machine make sure that it's on and working before updating in case the power goes out mid-bios-upgrade.

SAM

Last edited by sag47; 07-17-2013 at 10:43 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling IRQ #16 blue_k Slackware 44 07-30-2011 06:25 AM
Disabling irq #19 mengchun_khor Linux - Newbie 2 08-15-2008 11:10 AM
Disabling IRQ #17 okos Linux - Newbie 4 10-04-2007 08:54 PM
Disabling IRQ #11 keripukki Linux - Hardware 4 09-18-2004 06:54 PM
Disabling IRQ #7? rjerina Linux - Hardware 4 07-30-2004 01:47 AM


All times are GMT -5. The time now is 11:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration