LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-16-2005, 03:50 PM   #1
stonehurstX11
Member
 
Registered: Dec 2003
Location: New Jersey, USA
Distribution: Ubuntu 10.04
Posts: 120

Rep: Reputation: 15
Disabling eth1


Hi, I'm running Mandrake 10.1 CE, and I have a small issue with my boot up time.
As my machine brings up eth1 (eth0 is fine), it seems to take well over fourty seconds just for it to fail. I'm not sure if I even need eth1, so I was hoping someone would tell me how I can disable that particular service, or at least reduce the time it takes for it to time out. I know I can disable the network services from the Mandrake Control Center, but if I do, neither the eth0 nor the loopback interfaces are brought up.

Thanks in advance!

Last edited by stonehurstX11; 12-16-2005 at 03:52 PM.
 
Old 12-16-2005, 04:19 PM   #2
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
Edit /etc/network/interfaces. Where it says eth1 auto, make it noauto.
 
Old 12-16-2005, 04:29 PM   #3
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 540

Rep: Reputation: 32
If eth0 and eth1 are different cards (manufacturer or model) and use two different modules, try adding a line with the module of eth1 you won't load to /etc/hotplug/blacklist.
ie if the card you won't load is a Realtek 8139 add
rtl8139too
This should stop probing for the card at boot
if are trhe same card it is possible you're experiencing a hardware problem
Hope this helps
Ciao
 
Old 12-17-2005, 04:34 PM   #4
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
I made a mistake in my earlier post, it shouldn't be changed to "noauto", the eth1 name should just be deleted from the "auto" line. If you have a line:
Code:
auto lo eth0 eth1
in /etc/network/interfaces, change it to:
Code:
auto lo eth0
That should prevent eth1 from being brought up during boot up.

You can also disable the module for eth1 as described above to achieve the same thing.
 
Old 12-17-2005, 07:25 PM   #5
stonehurstX11
Member
 
Registered: Dec 2003
Location: New Jersey, USA
Distribution: Ubuntu 10.04
Posts: 120

Original Poster
Rep: Reputation: 15
Thanks for the suggestions! Now I can finally enjoy a quick boot up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot activate eth1 using ifup or using ifcfg-eth1 akay Linux - Hardware 10 12-16-2010 06:10 AM
eth1 down Krogen MEPIS 1 06-18-2005 08:09 AM
Routing between eth1 and eth1:1 cli_man Linux - Networking 3 04-05-2004 12:54 PM
eth1 added, mysql connections FROM this machine are from eth1. Need bound to eth0??? kreese Linux - Networking 9 03-31-2004 01:12 PM
Kernel 2.4.22 finds eth0 and eth1 but 2.6.0 does not find eth1 coollink Linux - Networking 3 01-13-2004 08:32 PM


All times are GMT -5. The time now is 11:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration